aboutsummaryrefslogtreecommitdiff
path: root/net/openldap25-server/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/openldap25-server/Makefile')
-rw-r--r--net/openldap25-server/Makefile58
1 files changed, 33 insertions, 25 deletions
diff --git a/net/openldap25-server/Makefile b/net/openldap25-server/Makefile
index 3b87457cf290..b01b10ba22ce 100644
--- a/net/openldap25-server/Makefile
+++ b/net/openldap25-server/Makefile
@@ -1,7 +1,5 @@
-# Created by: Xin LI <delphij@FreeBSD.org>
-
PORTNAME= openldap
-DISTVERSION= 2.5.7
+DISTVERSION= 2.5.17
PORTREVISION= ${OPENLDAP_PORTREVISION}
CATEGORIES= net databases
MASTER_SITES= https://www.openldap.org/software/download/OpenLDAP/%SUBDIR%/ \
@@ -23,6 +21,7 @@ PKGNAMESUFFIX= 25-server
.endif
MAINTAINER= delphij@FreeBSD.org
+WWW= https://www.OpenLDAP.org/
.if defined(CLIENT_ONLY)
COMMENT= Open source LDAP client implementation
.else
@@ -38,24 +37,32 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
USES= cpe gmake libtool:keepla localbase ssl tar:tgz
.if defined(CLIENT_ONLY)
-CONFLICTS_INSTALL= ${PORTNAME}2[0-46-9]-client-* ${PORTNAME}-client-*
+CONFLICTS_INSTALL= ${PORTNAME}2[0-46-9]-client ${PORTNAME}-client
.else
-CONFLICTS_INSTALL= ${PORTNAME}2[0-46-9]-server-* ${PORTNAME}-server-*
+CONFLICTS_INSTALL= ${PORTNAME}2[0-46-9]-server ${PORTNAME}-server
.endif
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
-PORTREVISION_CLIENT= 0
-PORTREVISION_SERVER= 1
+PORTREVISION_CLIENT= 1
+PORTREVISION_SERVER= 2
OPENLDAP_SHLIB_MAJOR= 0
-OPENLDAP_SHLIB_MINOR= 1.2
+OPENLDAP_SHLIB_MINOR= 1.12
OPENLDAP_MAJOR= ${DISTVERSION:R}
-OPTIONS_DEFINE= DEBUG
+OPTIONS_DEFINE= DEBUG FETCH GSSAPI
OPTIONS_DEFAULT+= DEBUG
+FETCH_DESC= Enable fetch(3) support
+FETCH_BUILD_DEPENDS= autoconf>0:devel/autoconf
+FETCH_CONFIGURE_WITH= fetch
+
+GSSAPI_DESC= With GSSAPI support
+GSSAPI_RUN_DEPENDS= cyrus-sasl-gssapi>0:security/cyrus-sasl2-gssapi
+
.if defined(CLIENT_ONLY)
-OPTIONS_DEFINE+= DOCS FETCH
+OPTIONS_DEFINE+= DOCS
.else
OPTIONS_GROUP= BKNDS OVLYS
BKNDS_DESC= OpenLDAP backends
@@ -78,6 +85,7 @@ OPTIONS_GROUP_OVLYS+= DENYOP
OPTIONS_GROUP_OVLYS+= DEREF
OPTIONS_GROUP_OVLYS+= DYNGROUP
OPTIONS_GROUP_OVLYS+= DYNLIST
+OPTIONS_GROUP_OVLYS+= EMPTYDS
OPTIONS_GROUP_OVLYS+= HOMEDIR
OPTIONS_GROUP_OVLYS+= LASTBIND
OPTIONS_GROUP_OVLYS+= LASTMOD
@@ -116,8 +124,6 @@ OPTIONS_SUB= yes
ACI_DESC= Per-object ACI (experimental)
ARGON2_DESC= Argon2 password hashing module
DYNACL_DESC= Run-time loadable ACL (experimental)
-FETCH_DESC= Enable fetch(3) support
-GSSAPI_DESC= With GSSAPI support
LLOADD_DESC= Enable load balancer
OUTLOOK_DESC= Force caseIgnoreOrderingMatch on name attribute (experimental)
RLOOKUPS_DESC= With reverse lookups of client hostnames
@@ -164,6 +170,7 @@ ALLOP_DESC= With allop overlay (experimental)
AUTOGROUP_DESC= With autogroup overlay (experimental)
CLOAK_DESC= With cloak overlay (experimental)
DENYOP_DESC= With denyop overlay (experimental)
+EMPTYDS_DESC= With emptyds overlay (experimental)
LASTBIND_DESC= With lastbind overlay
LASTMOD_DESC= With lastmod overlay (experimental)
TRACE_DESC= With Trace overlay
@@ -189,11 +196,10 @@ DNSSRV_CONFIGURE_ENABLE= dnssrv=mod
DYNACL_CONFIGURE_ENABLE= dynacl
DYNGROUP_CONFIGURE_ENABLE= dyngroup=mod
DYNLIST_CONFIGURE_ENABLE= dynlist=mod
-FETCH_CONFIGURE_WITH= fetch
HOMEDIR_CONFIGURE_ENABLE= homedir=mod
LLOADD_CONFIGURE_ENABLE= balancer=mod
LLOADD_LIB_DEPENDS= libevent.so:devel/libevent
-MDB_CONFIGURE_ENABLE= mdb=mod
+MDB_CONFIGURE_ENABLE= mdb=yes
MEMBEROF_CONFIGURE_ENABLE= memberof=mod
OTP_CONFIGURE_ENABLE= otp=mod
PASSWD_CONFIGURE_ENABLE= passwd=mod
@@ -203,7 +209,7 @@ PERL_USES= perl5
PPOLICY_CONFIGURE_ENABLE= ppolicy=mod
PROXYCACHE_CONFIGURE_ENABLE= proxycache=mod
REFINT_CONFIGURE_ENABLE= refint=mod
-RELAY_CONFIGURE_ENABLE= relay=mod
+RELAY_CONFIGURE_ENABLE= relay=yes
REMOTEAUTH_CONFIGURE_ENABLE= remoteauth=mod
RETCODE_CONFIGURE_ENABLE= retcode=mod
RLOOKUPS_CONFIGURE_ENABLE= rlookups
@@ -218,7 +224,7 @@ SQL_CONFIGURE_ENABLE= sql=mod
SQL_LDFLAGS= -L${LOCALBASE}/lib
SQL_LIB_DEPENDS= libodbc.so:databases/unixODBC
SSSVLV_CONFIGURE_ENABLE= sssvlv=mod
-SYNCPROV_CONFIGURE_ENABLE= syncprov=mod
+SYNCPROV_CONFIGURE_ENABLE= syncprov=yes
TRANSLUCENT_CONFIGURE_ENABLE= translucent=mod
UNIQUE_CONFIGURE_ENABLE= unique=mod
VALSORT_CONFIGURE_ENABLE= valsort=mod
@@ -268,8 +274,7 @@ EXTRA_PATCHES+= ${FILESDIR}/extrapatch-Makefile.in
LDFLAGS+= -L${LOCALBASE}/lib
-SED_MODULES= -e 's,mandir = \$$(exec_prefix)/share/man,mandir = $$(exec_prefix)/man,' \
- -e 's/\(moduleload[ ]*back_[a-z]*\)\.la/\1/' \
+SED_MODULES= -e 's/\(moduleload[ ]*back_[a-z]*\)\.la/\1/' \
-e 's/\# *\(modulepath\)/\1/'
CONFIGURE_ARGS+= --enable-modules \
@@ -316,12 +321,6 @@ PLIST_SUB+= SHLIB_MAJOR=${OPENLDAP_SHLIB_MAJOR}
PLIST_SUB+= SHLIB_MINOR=${OPENLDAP_SHLIB_MINOR}
PLIST_SUB+= OPENLDAP_MAJOR=${OPENLDAP_MAJOR}
-.include <bsd.port.pre.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1200085 && ${SSL_DEFAULT} == base
-BROKEN= Requires OpenSSL 1.1.1+
-.endif
-
.if ${PORT_OPTIONS:MFETCH} && (defined(OPENSSL_INSTALLED) && ${OPENSSL_INSTALLED} != "" || ${SSL_DEFAULT} != base)
BROKEN= using OpenSSL from ports and OPTION FETCH together is not supported
. endif
@@ -346,6 +345,10 @@ CONTRIB_CLEANFILES+= cloak.a
CONTRIB_MODULES+= slapd-modules/denyop
CONTRIB_CLEANFILES+= denyop.a
.endif
+.if ${PORT_OPTIONS:MEMPTYDS}
+CONTRIB_MODULES+= slapd-modules/emptyds
+CONTRIB_CLEANFILES+= emptyds.a
+.endif
.if ${PORT_OPTIONS:MLASTBIND}
CONTRIB_MODULES+= slapd-modules/lastbind
CONTRIB_CLEANFILES+= lastbind.a
@@ -378,6 +381,8 @@ CONTRIB_CLEANFILES+= smbk5pwd.a
post-patch:
@${REINPLACE_CMD} -e 's|%LOCALSTATEDIR%/run/|${LDAP_RUN_DIR}/|g' \
${SED_MODULES} ${WRKSRC}/servers/slapd/slapd.conf
+ @${REINPLACE_CMD} -e 's|%LOCALSTATEDIR%/run/|${LDAP_RUN_DIR}/|g' \
+ ${SED_MODULES} ${WRKSRC}/servers/slapd/slapd.ldif
@${REINPLACE_CMD} -e 's|^OPT =.*|OPT = ${CFLAGS}|g' \
-e 's|^CC =.*|CC = ${CC}|g' \
${SED_MODULES} ${WRKSRC}/contrib/slapd-modules/*/Makefile \
@@ -387,6 +392,9 @@ post-patch:
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
.endif
+pre-configure-FETCH-on:
+ @(cd ${WRKSRC} && ${LOCALBASE}/bin/autoconf)
+
.if !defined(CLIENT_ONLY)
test: build
@(cd ${BUILD_WRKSRC} && ${SETENV} ${MAKE_ENV} \
@@ -439,4 +447,4 @@ post-install-SLAPI-on:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lib$${library}-${OPENLDAP_MAJOR}.so.${OPENLDAP_SHLIB_MAJOR}; \
done
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>