aboutsummaryrefslogtreecommitdiff
path: root/net/p5-URI/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/p5-URI/Makefile')
-rw-r--r--net/p5-URI/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/net/p5-URI/Makefile b/net/p5-URI/Makefile
index e0c68815d7fd..fb5ede0253a4 100644
--- a/net/p5-URI/Makefile
+++ b/net/p5-URI/Makefile
@@ -6,15 +6,15 @@
#
PORTNAME= URI
-PORTVERSION= 1.19
+PORTVERSION= 1.20
CATEGORIES= net perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= URI
PKGNAMEPREFIX= p5-
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= erwin@lansing.dk
-BUILD_DEPENDS= ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
PERL_CONFIGURE= yes
@@ -28,4 +28,8 @@ MAN3= URI.3 \
URI::file.3 \
URI::ldap.3
+post-patch:
+ ${PERL} -pi -e 's/^our\s+([\$$\@\%]\w+)/use vars qw($$1);/' \
+ ${WRKSRC}/URI/urn.pm
+
.include <bsd.port.mk>