aboutsummaryrefslogtreecommitdiff
path: root/net/pacemaker1/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/pacemaker1/Makefile')
-rw-r--r--net/pacemaker1/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/net/pacemaker1/Makefile b/net/pacemaker1/Makefile
index 0ed8bdd696c3..b978cea40f88 100644
--- a/net/pacemaker1/Makefile
+++ b/net/pacemaker1/Makefile
@@ -22,6 +22,9 @@ SHEBANG_FILES+= cts/cts \
REPLACE_ARGS_GETOPT= -e 's,getopt,${LOCALBASE}/bin/getopt,'
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-cts_remote.py \
+ ${PATCHDIR}/extra-patch-cts_watcher.py
+
.include <bsd.port.pre.mk>
# Fix building it with clang 11
@@ -29,11 +32,6 @@ REPLACE_ARGS_GETOPT= -e 's,getopt,${LOCALBASE}/bin/getopt,'
CFLAGS+= -fcommon
.endif
-.if ${PYTHON_SUFFIX} > 36
-EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-cts_remote.py \
- ${PATCHDIR}/extra-patch-cts_watcher.py
-.endif
-
post-patch: post-patch-common
@${REINPLACE_CMD} ${REPLACE_ARGS_GETOPT} ${WRKSRC}/tools/crm_failcount
@${REINPLACE_CMD} ${REPLACE_ARGS_GETOPT} ${WRKSRC}/tools/crm_master