aboutsummaryrefslogtreecommitdiff
path: root/net/pecl-oauth/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/pecl-oauth/Makefile')
-rw-r--r--net/pecl-oauth/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/net/pecl-oauth/Makefile b/net/pecl-oauth/Makefile
new file mode 100644
index 000000000000..4a8bf56a33a4
--- /dev/null
+++ b/net/pecl-oauth/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: pecl-oauth
+# Date created: 25 Nov 2008
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= oauth
+PORTVERSION= 0.99.1
+CATEGORIES= net pear
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= A Php Interface to the OAuth Protocol
+
+BUILD_DEPENDS= ${LOCALBASE}/include/curl/curl.h:${PORTSDIR}/ftp/curl
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+
+USE_PHP= yes
+USE_PHPEXT= yes
+
+.include <bsd.port.mk>