aboutsummaryrefslogtreecommitdiff
path: root/net/py-err-backend-mattermost/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/py-err-backend-mattermost/Makefile')
-rw-r--r--net/py-err-backend-mattermost/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/net/py-err-backend-mattermost/Makefile b/net/py-err-backend-mattermost/Makefile
new file mode 100644
index 000000000000..986c3200b4ee
--- /dev/null
+++ b/net/py-err-backend-mattermost/Makefile
@@ -0,0 +1,24 @@
+PORTNAME= err-backend-mattermost
+PORTVERSION= 3.0.0
+CATEGORIES= net python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Mattermost backend for Errbot
+WWW= https://err-backend-mattermost.readthedocs.io/en/latest/ \
+ https://github.com/errbotio/err-backend-mattermost
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=61.0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mattermostdriver>=4.0:net-im/py-mattermostdriver@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent pep517
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>