aboutsummaryrefslogtreecommitdiff
path: root/net/py-pypcap
diff options
context:
space:
mode:
Diffstat (limited to 'net/py-pypcap')
-rw-r--r--net/py-pypcap/Makefile17
-rw-r--r--net/py-pypcap/distinfo6
-rw-r--r--net/py-pypcap/pkg-descr2
3 files changed, 13 insertions, 12 deletions
diff --git a/net/py-pypcap/Makefile b/net/py-pypcap/Makefile
index da073e9c4e30..c16f372658bd 100644
--- a/net/py-pypcap/Makefile
+++ b/net/py-pypcap/Makefile
@@ -1,18 +1,21 @@
-# Created by: George V. Neville-Neil
-
PORTNAME= pypcap
-DISTVERSION= 1.2.3
+PORTVERSION= 1.3.0
+PORTREVISION= 1
CATEGORIES= net python
-MASTER_SITES= CHEESESHOP
+MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Simplified object-oriented Python wrapper for libpcap
+WWW= https://github.com/pynetwork/pypcap
LICENSE= BSD3CLAUSE
-USES= python:3.6+
-USE_PYTHON= autoplist concurrent cython distutils
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent cython pep517
# PR 239725: workaround to avoid using /usr/lib32 over /usr/lib
LDFLAGS+= -L/usr/lib
@@ -21,6 +24,6 @@ pre-configure:
cd ${WRKSRC} && cython-${PYTHON_VER} pcap.pyx
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/pcap*.so
+ ${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +
.include <bsd.port.mk>
diff --git a/net/py-pypcap/distinfo b/net/py-pypcap/distinfo
index 07615a2e5e33..78c405a2b398 100644
--- a/net/py-pypcap/distinfo
+++ b/net/py-pypcap/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1563640738
-SHA256 (pypcap-1.2.3.tar.gz) = ad87fa22fe05f46b5dc602724958f1025af82ba3116694eddf5cb3035f3ab1f0
-SIZE (pypcap-1.2.3.tar.gz) = 136072
+TIMESTAMP = 1663672878
+SHA256 (pypcap-1.3.0.tar.gz) = 669976786b2b4c43869c0ecf6228cbbb70336d1d8eb8d4fe2a3a81df395f45b5
+SIZE (pypcap-1.3.0.tar.gz) = 140870
diff --git a/net/py-pypcap/pkg-descr b/net/py-pypcap/pkg-descr
index 29276a309e51..f88a45d59558 100644
--- a/net/py-pypcap/pkg-descr
+++ b/net/py-pypcap/pkg-descr
@@ -1,3 +1 @@
Python PCAP module is a simplified object-oriented wrapper for libpcap.
-
-WWW: https://github.com/pynetwork/pypcap