aboutsummaryrefslogtreecommitdiff
path: root/net/py-stomp.py
diff options
context:
space:
mode:
Diffstat (limited to 'net/py-stomp.py')
-rw-r--r--net/py-stomp.py/Makefile13
-rw-r--r--net/py-stomp.py/distinfo6
-rw-r--r--net/py-stomp.py/files/patch-2to313
-rw-r--r--net/py-stomp.py/pkg-descr2
4 files changed, 12 insertions, 22 deletions
diff --git a/net/py-stomp.py/Makefile b/net/py-stomp.py/Makefile
index 47f2c07ed261..fd05a92d1393 100644
--- a/net/py-stomp.py/Makefile
+++ b/net/py-stomp.py/Makefile
@@ -1,21 +1,26 @@
PORTNAME= stomp.py
-PORTVERSION= 4.1.17
+PORTVERSION= 8.0.1
+PORTREVISION= 1
CATEGORIES= net python
-MASTER_SITES= CHEESESHOP
+MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= james@elstone.net
COMMENT= Python STOMP client, supporting >=1.0 and <=1.2 of the protocol
+WWW= https://github.com/jasonrbriggs/stomp.py
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}docopt>=0.6.2:devel/py-docopt@${PY_FLAVOR}
+
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=2.8.1:devel/py-pytest@${PY_FLAVOR}
-OPTIONS_DEFINE= DOXYGEN
+USES= python
+
+OPTIONS_DEFINE= DOXYGEN
DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen
-USES= python:3.6+
USE_PYTHON= autoplist distutils
NO_ARCH= yes
diff --git a/net/py-stomp.py/distinfo b/net/py-stomp.py/distinfo
index bcd42792606a..a8331f7ca141 100644
--- a/net/py-stomp.py/distinfo
+++ b/net/py-stomp.py/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1493691925
-SHA256 (stomp.py-4.1.17.tar.gz) = 52af093b0a19a5c7093057ca0c65152fd0764afcb2b8f87815f8549b2663e021
-SIZE (stomp.py-4.1.17.tar.gz) = 46277
+TIMESTAMP = 1661968032
+SHA256 (stomp.py-8.0.1.tar.gz) = d2bc55b4596604feb51d56895d93431ff8ee159b31b28d9038a2310777bbd3fa
+SIZE (stomp.py-8.0.1.tar.gz) = 35300
diff --git a/net/py-stomp.py/files/patch-2to3 b/net/py-stomp.py/files/patch-2to3
deleted file mode 100644
index 795a89f846ba..000000000000
--- a/net/py-stomp.py/files/patch-2to3
+++ /dev/null
@@ -1,13 +0,0 @@
---- stomp/backwardsock25.py.orig 2016-11-13 14:00:03 UTC
-+++ stomp/backwardsock25.py
-@@ -25,8 +25,8 @@ def get_socket(host, port, timeout=None):
- sock.connect(sa)
- return sock
-
-- except error, msg:
-+ except error as msg:
- if sock is not None:
- sock.close()
-
-- raise error, ERRMSG
-+ raise error(ERRMSG)
diff --git a/net/py-stomp.py/pkg-descr b/net/py-stomp.py/pkg-descr
index 04ce639f5253..0eaab5d86689 100644
--- a/net/py-stomp.py/pkg-descr
+++ b/net/py-stomp.py/pkg-descr
@@ -1,5 +1,3 @@
stomp.py is a Python client library for accessing messaging servers (such as
Apollo or RabbitMQ) using the STOMP protocol (versions 1.0, 1.1 and 1.2). It
can also be run as a standalone, command-line client for testing.
-
-WWW: https://github.com/jasonrbriggs/stomp.py