aboutsummaryrefslogtreecommitdiff
path: root/net/py-txamqp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/py-txamqp/Makefile')
-rw-r--r--net/py-txamqp/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/net/py-txamqp/Makefile b/net/py-txamqp/Makefile
index 3dd4949669e1..72bdcde65089 100644
--- a/net/py-txamqp/Makefile
+++ b/net/py-txamqp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= txamqp
PORTVERSION= 0.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net python
MASTER_SITES= http://launchpadlibrarian.net/30388120/ \
# http://launchpad.net/txamqp/trunk/${PORTVERSION}/+download/
@@ -15,20 +15,18 @@ COMMENT= Twisted Python library for the AMQP messaging protocol
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}thrift>0:${PORTSDIR}/devel/py-thrift
-USE_PYTHON= 2
-USE_PYDISTUTILS=easy_install
+USE_PYTHON= 2
+USE_PYDISTUTILS= yes
+PYDISTUTILS_AUTOPLIST= yes
USES= twisted
WRKSRC= ${WRKDIR}/python-${PORTNAME}-${PORTVERSION}
-PYDISTUTILS_PKGNAME= txAMQP
-PYDISTUTILS_PKGVERSION= 0.3
PLIST_SUB= PORTNAME="${PORTNAME}"
# TODO: Install txAMQP examples.
# Don't try to install Twisted yourself, txAMQP. thx!
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e '/install_requires/s/^/#/' ${WRKSRC}/setup.py