aboutsummaryrefslogtreecommitdiff
path: root/net/rpki-client/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/rpki-client/Makefile')
-rw-r--r--net/rpki-client/Makefile22
1 files changed, 9 insertions, 13 deletions
diff --git a/net/rpki-client/Makefile b/net/rpki-client/Makefile
index 4ede2180b43d..27599f9c795c 100644
--- a/net/rpki-client/Makefile
+++ b/net/rpki-client/Makefile
@@ -1,33 +1,29 @@
PORTNAME= rpki-client
-DISTVERSION= 7.2
+DISTVERSION= 9.0
CATEGORIES= net
+MASTER_SITES= OPENBSD
+MASTER_SITE_SUBDIR=rpki-client
-MAINTAINER= zeising@FreeBSD.org
+MAINTAINER= bofh@FreeBSD.org
COMMENT= Resource Public Key Infrastructure (RPKI) implementation from OpenBSD
+WWW= https://www.rpki-client.org/
LICENSE= ISCL
BUILD_DEPENDS= rsync>0:net/rsync
LIB_DEPENDS= libexpat.so:textproc/expat2 \
libtls.so:security/libretls
-RUN_DEPENDS= ca_root_nss>=0:security/ca_root_nss \
- rsync>0:net/rsync
+RUN_DEPENDS= rsync>0:net/rsync
-USES= autoreconf libtool pkgconfig ssl
-
-USE_GITHUB= yes
-GH_PROJECT= ${PORTNAME}-portable ${PORTNAME}-openbsd:openbsd
-GH_SUBDIR= openbsd:openbsd
-GH_TAGNAME= ${PORTNAME}-${DISTVERSION}:openbsd
+USES= autoreconf:build libtool pkgconfig ssl
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
CONFIGURE_ARGS= --with-libtls=libtls
USERS= _rpki-client
GROUPS= ${USERS}
-PLIST_SUB= USERS="${USERS}"
-pre-configure:
- cd ${WRKSRC} && ${SH} update.sh
+PLIST_SUB= USERS="${USERS}"
.include <bsd.port.mk>