aboutsummaryrefslogtreecommitdiff
path: root/net/samba3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/samba3/Makefile')
-rw-r--r--net/samba3/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/net/samba3/Makefile b/net/samba3/Makefile
index 7326e2d130bb..bf43f83eea92 100644
--- a/net/samba3/Makefile
+++ b/net/samba3/Makefile
@@ -34,7 +34,7 @@ SAMPLE_CONFIG= ${SAMBA_CONFDIR}/smb.conf.default
DOCSDIR= ${PREFIX}/share/doc/samba
NO_LATEST_LINK= yes
-GNU_CONFIGURE= yes
+USE_AUTOCONF= yes
CONFIGURE_ARGS= --libdir=${SAMBA_CONFDIR} \
--localstatedir=${VARDIR} --with-swatdir=${PREFIX}/share/swat \
--with-sambabook=${PREFIX}/share/swat/using_samba \
@@ -45,6 +45,8 @@ CONFIGURE_ARGS= --libdir=${SAMBA_CONFDIR} \
.if defined(KRB5_HOME) && exists(${KRB5_HOME})
CONFIGURE_ARGS+= --with-krb5=${KRB5_HOME}
+.else
+CONFIGURE_ARGS+= --with-krb5=no
.endif
.if defined(WITH_CUPS)