aboutsummaryrefslogtreecommitdiff
path: root/net/smm++/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/smm++/Makefile')
-rw-r--r--net/smm++/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/net/smm++/Makefile b/net/smm++/Makefile
index 77a565a0ec7a..d4ab65a6f887 100644
--- a/net/smm++/Makefile
+++ b/net/smm++/Makefile
@@ -17,12 +17,18 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libitk.so:${PORTSDIR}/x11-toolkits/itk \
${LOCALBASE}/lib/libitcl.so:${PORTSDIR}/lang/itcl
WRKSRC= ${WRKDIR}/smm/Install.unix
-USE_GMAKE= yes
-USE_TK= 84+
+USES= gmake tk
EXTRACT_AFTER_ARGS=--exclude CVS
-NO_STAGE= yes
+MAKE_ENV+= STAGEDIR=${STAGEDIR}
+
post-patch:
${REINPLACE_CMD} -e 's,itkarray=.*,itkarray=${WISH},' ${WRKSRC}/itk.sh
+post-install:
+ ${FIND} ${STAGEDIR}${PREFIX}/lib/smm -type f | ${XARGS} \
+ ${CHMOD} ${SHAREMODE}
+ ${FIND} ${STAGEDIR}${PREFIX}/lib/smm -type d | ${XARGS} \
+ ${CHMOD} 755
+
.include <bsd.port.mk>