aboutsummaryrefslogtreecommitdiff
path: root/net/tridiavnc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/tridiavnc/Makefile')
-rw-r--r--net/tridiavnc/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/net/tridiavnc/Makefile b/net/tridiavnc/Makefile
new file mode 100644
index 000000000000..7d8629651f86
--- /dev/null
+++ b/net/tridiavnc/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: tridiavnc
+# Date created: 14 June 2001
+# Whom: dwcjr
+#
+# $FreeBSD$
+#
+
+PORTNAME= tridiavnc
+PORTVERSION= 1.4
+CATEGORIES= net
+MASTER_SITES= http://www.developvnc.org/logged-in/downloadnow/
+DISTNAME= DevVNC_unix
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= dwcjr@freebsd.org
+
+USE_PERL5= yes
+WRKSRC= ${WRKDIR}/unix/vnc_unixsrc
+USE_IMAKE= yes
+NO_INSTALL_MANPAGES= yes
+
+# We have to frob a few things, and we want our own permissions, so it's easier
+# to do the install ourselves.
+post-install:
+# ${INSTALL_PROGRAM} ${WRKSRC}/Xvnc/programs/Xserver/Xvnc ${PREFIX}/bin/Xvnc
+ ${INSTALL_PROGRAM} ${WRKSRC}/vncviewer/vncviewer ${PREFIX}/bin/vncviewer
+ ${INSTALL_PROGRAM} ${WRKSRC}/vncpasswd/vncpasswd ${PREFIX}/bin/vncpasswd
+ ${INSTALL_PROGRAM} ${WRKSRC}/vncconnect/vncconnect ${PREFIX}/bin/vncconnect
+ ${SED} -e s%/usr/local/vnc/classes%${PREFIX}/share/vnc/classes% \
+ -e s%^\#!/usr/bin/perl%\#!${PERL}% \
+ < ${WRKSRC}/vncserver \
+ > ${WRKSRC}/vncserver.local
+ ${INSTALL_SCRIPT} ${WRKSRC}/vncserver.local ${PREFIX}/bin/vncserver
+# Go install Java classes
+ ${MKDIR} ${PREFIX}/share/vnc
+ ${CP} -R ${WRKSRC}/classes ${PREFIX}/share/vnc
+.include <bsd.port.mk>