aboutsummaryrefslogtreecommitdiff
path: root/net/vnstat
diff options
context:
space:
mode:
Diffstat (limited to 'net/vnstat')
-rw-r--r--net/vnstat/Makefile30
-rw-r--r--net/vnstat/distinfo6
-rw-r--r--net/vnstat/pkg-descr2
3 files changed, 16 insertions, 22 deletions
diff --git a/net/vnstat/Makefile b/net/vnstat/Makefile
index 7ee4857d116f..2218afad5f0e 100644
--- a/net/vnstat/Makefile
+++ b/net/vnstat/Makefile
@@ -1,18 +1,22 @@
-# Created by: Dennis Herrmann <adox@mcx2.org>
-
PORTNAME= vnstat
-PORTVERSION= 2.8
+PORTVERSION= 2.12
CATEGORIES= net
-MASTER_SITES= https://humdi.net/vnstat/
+MASTER_SITES= https://github.com/vergoh/vnstat/releases/download/v${PORTVERSION}/ \
+ https://humdi.net/vnstat/
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Console-based network traffic monitor
+WWW= https://humdi.net/vnstat/ \
+ https://github.com/vergoh/vnstat
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
-USES= sqlite
+USES= localbase sqlite
+CONFIGURE_ARGS= --disable-extra-paths
GNU_CONFIGURE= yes
+INSTALL_TARGET= install-exec install-man
USE_RC_SUBR= vnstat
USERS= vnstat
@@ -28,22 +32,14 @@ OPTIONS_DEFAULT=GUI
OPTIONS_SUB= yes
GUI_DESC= Build with graphics/gd dependency
+GUI_CONFIGURE_OFF= --disable-image-output
GUI_LIB_DEPENDS= libgd.so:graphics/gd
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/vnstat ${STAGEDIR}${PREFIX}/bin/vnstat
- ${INSTALL_DATA} ${WRKSRC}/cfg/vnstat.conf ${STAGEDIR}${PREFIX}/etc/vnstat.conf.sample
- ${INSTALL_PROGRAM} ${WRKSRC}/vnstatd ${STAGEDIR}${PREFIX}/sbin/vnstatd
- ${INSTALL_MAN} ${WRKSRC}/man/vnstat.1 ${STAGEDIR}${PREFIX}/share/man/man1/vnstat.1
- ${INSTALL_MAN} ${WRKSRC}/man/vnstat.conf.5 ${STAGEDIR}${PREFIX}/share/man/man5/vnstat.conf.5
- ${INSTALL_MAN} ${WRKSRC}/man/vnstatd.8 ${STAGEDIR}${PREFIX}/share/man/man8/vnstatd.8
-
-do-install-GUI-on:
- ${INSTALL_PROGRAM} ${WRKSRC}/vnstati ${STAGEDIR}${PREFIX}/bin/vnstati
- ${INSTALL_MAN} ${WRKSRC}/man/vnstati.1 ${STAGEDIR}${PREFIX}/share/man/man1/vnstati.1
-
do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/cfg/vnstat.conf ${STAGEDIR}${PREFIX}/etc/vnstat.conf.sample
+
.include <bsd.port.mk>
diff --git a/net/vnstat/distinfo b/net/vnstat/distinfo
index c805e9775052..fa3a54bf3e8d 100644
--- a/net/vnstat/distinfo
+++ b/net/vnstat/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1632036896
-SHA256 (vnstat-2.8.tar.gz) = 03f858a7abf6bd85bb8cd595f3541fc3bd31f8f400ec092ef3034825ccb77c25
-SIZE (vnstat-2.8.tar.gz) = 290644
+TIMESTAMP = 1705942248
+SHA256 (vnstat-2.12.tar.gz) = b7386b12fc1fc6f47fab31f208b12eda61862e63e229e84e95a6fa80406d2852
+SIZE (vnstat-2.12.tar.gz) = 325227
diff --git a/net/vnstat/pkg-descr b/net/vnstat/pkg-descr
index e4b0b25a93f8..45c540e334bf 100644
--- a/net/vnstat/pkg-descr
+++ b/net/vnstat/pkg-descr
@@ -3,5 +3,3 @@ log of network traffic for the selected interface(s). It uses the network
interface statistics provided by the kernel as information source. This means
that vnStat won't actually be sniffing any traffic and also ensures light use of
system resources regardless of network traffic rate.
-
-WWW: https://humdi.net/vnstat/