aboutsummaryrefslogtreecommitdiff
path: root/net/xrdp-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/xrdp-devel/Makefile')
-rw-r--r--net/xrdp-devel/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/net/xrdp-devel/Makefile b/net/xrdp-devel/Makefile
index 166a9cb3dd42..d5904cef0e37 100644
--- a/net/xrdp-devel/Makefile
+++ b/net/xrdp-devel/Makefile
@@ -2,7 +2,7 @@
PORTNAME= xrdp
DISTVERSIONPREFIX= v
-DISTVERSION= 0.9.16
+DISTVERSION= 0.9.18.b20220107
PORTEPOCH= 1
CATEGORIES= net
PKGNAMESUFFIX= -devel
@@ -20,6 +20,7 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/nasm:devel/nasm
RUN_DEPENDS= xterm:x11/xterm \
${LOCALBASE}/lib/xorg/modules/libxorgxrdp.so:x11-drivers/xorgxrdp \
${LOCALBASE}/lib/pulse-14.2/modules/module-xrdp-sink.so:audio/pulseaudio-module-xrdp
+LIB_DEPENDS= libImlib2.so:graphics/imlib2
USES= autoreconf:build compiler:c11 cpe jpeg localbase libtool pkgconfig \
ssl xorg
@@ -30,13 +31,15 @@ USE_GITHUB= yes
GNU_CONFIGURE= yes
GH_ACCOUNT= neutrinolabs
-GH_TUPLE= neutrinolabs:librfxcodec:v0.1.5:librfxcodec/librfxcodec \
+GH_TAGNAME= 96a92d4
+GH_TUPLE= neutrinolabs:librfxcodec:v0.1.6:librfxcodec/librfxcodec \
neutrinolabs:libpainter:v0.1.1:libpainter/libpainter
CONFIGURE_ARGS= --localstatedir=/var --enable-strict-locations \
--with-pkgconfigdir=${LOCALBASE}/libdata/pkgconfig \
--enable-pam-config=freebsd \
- --enable-jpeg --enable-pixman --enable-rfxcodec --enable-painter
+ --enable-jpeg --enable-pixman --enable-rfxcodec --enable-painter \
+ --enable-imlib2
LDFLAGS+= -lssl
CONFLICTS= xrdp
INSTALL_TARGET= install-strip
@@ -52,7 +55,7 @@ FUSE_DESC= Enable drive redirection via FUSE (experimental)
MP3LAME_DESC= Enable MP3 Lame for audio redirection
OPUS_DESC= Enable Opus for audio redirection
-DEBUG_CONFIGURE_ENABLE= xrdpdebug
+DEBUG_CONFIGURE_ENABLE= devel-debug devel-logging
FDKAAC_CONFIGURE_ENABLE= fdkaac
FDKAAC_LIB_DEPENDS= libfdk-aac.so:audio/fdk-aac
FUSE_CONFIGURE_ENABLE= fuse