aboutsummaryrefslogtreecommitdiff
path: root/net/xrdp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/xrdp/Makefile')
-rw-r--r--net/xrdp/Makefile71
1 files changed, 40 insertions, 31 deletions
diff --git a/net/xrdp/Makefile b/net/xrdp/Makefile
index fdba59d8cdc7..e003a07e7868 100644
--- a/net/xrdp/Makefile
+++ b/net/xrdp/Makefile
@@ -1,8 +1,7 @@
-# Created by: alepulver
-
PORTNAME= xrdp
DISTVERSIONPREFIX= v
-DISTVERSION= 0.9.17
+DISTVERSION= 0.9.25.1-7
+DISTVERSIONSUFFIX= -g2d78ee85
PORTEPOCH= 1
CATEGORIES= net
DIST_SUBDIR?= ${PORTNAME}
@@ -11,57 +10,63 @@ PATCH_SITES= https://github.com/${GH_ACCOUNT}/${PORTNAME}/commit/
MAINTAINER= meta@FreeBSD.org
COMMENT= Open source Remote Desktop Protocol (RDP) server
+WWW= http://www.xrdp.org/
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${LOCALBASE}/bin/nasm:devel/nasm
-RUN_DEPENDS= xterm:x11/xterm \
- ${LOCALBASE}/lib/xorg/modules/libxorgxrdp.so:x11-drivers/xorgxrdp \
- ${LOCALBASE}/lib/pulse-14.2/modules/module-xrdp-sink.so:audio/pulseaudio-module-xrdp
+RUN_DEPENDS= ${LOCALBASE}/lib/xorg/modules/libxorgxrdp.so:x11-drivers/xorgxrdp \
+ xterm:x11/xterm
+LIB_DEPENDS= libImlib2.so:graphics/imlib2
-USES= autoreconf:build compiler:c11 cpe jpeg localbase libtool pkgconfig \
- ssl xorg
+USES= autoreconf:build compiler:c11 cpe jpeg libtool localbase \
+ pkgconfig ssl xorg
+CPE_VENDOR= neutrinolabs
USE_XORG= ice pixman sm x11 xfixes xrandr
USE_LDCONFIG= ${PREFIX}/lib/xrdp
USE_GITHUB= yes
-CPE_VENDOR= neutrinolabs
-
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
GH_ACCOUNT= neutrinolabs
-GH_TUPLE= neutrinolabs:librfxcodec:v0.1.5:librfxcodec/librfxcodec \
- neutrinolabs:libpainter:v0.1.1:libpainter/libpainter
+GH_TUPLE= neutrinolabs:librfxcodec:c537401a:librfxcodec/librfxcodec \
+ neutrinolabs:libpainter:b44f2fa:libpainter/libpainter
-CONFIGURE_ARGS= --localstatedir=/var --enable-strict-locations \
- --with-pkgconfigdir=${LOCALBASE}/libdata/pkgconfig \
+CONFIGURE_ARGS= --enable-imlib2 \
+ --enable-jpeg \
+ --enable-painter \
--enable-pam-config=freebsd \
- --enable-jpeg --enable-pixman --enable-rfxcodec --enable-painter
+ --enable-pixman \
+ --enable-rfxcodec \
+ --enable-strict-locations \
+ --localstatedir=/var \
+ --with-pkgconfigdir=${LOCALBASE}/libdata/pkgconfig
LDFLAGS+= -lssl
-CONFLICTS= xrdp-devel[0-9]*
+CONFLICTS= xrdp-devel
INSTALL_TARGET= install-strip
SUB_FILES= pkg-deinstall pkg-install pkg-message
SUB_LIST= OPENSSLBASE=${OPENSSLBASE}
-OPTIONS_DEFINE= DEBUG FUSE IPV6
-OPTIONS_DEFAULT= FDKAAC OPUS
-OPTIONS_GROUP= AUDIO_CODEC
+OPTIONS_DEFINE= DEBUG FUSE IPV6
+OPTIONS_DEFAULT= FDKAAC OPUS
+OPTIONS_GROUP= AUDIO_CODEC
OPTIONS_GROUP_AUDIO_CODEC= FDKAAC MP3LAME OPUS
-FDKAAC_DESC= Enable Fraunhofer FDK AAC for audio redirection
-FUSE_DESC= Enable drive redirection via FUSE (experimental)
-MP3LAME_DESC= Enable MP3 Lame for audio redirection
-OPUS_DESC= Enable Opus for audio redirection
+FDKAAC_DESC= Enable Fraunhofer FDK AAC for audio redirection
+FUSE_DESC= Enable drive redirection via FUSE (experimental)
+MP3LAME_DESC= Enable MP3 Lame for audio redirection
+OPUS_DESC= Enable Opus for audio redirection
-DEBUG_CONFIGURE_ENABLE= debug-all
+DEBUG_CONFIGURE_ENABLE= devel-debug devel-logging
FDKAAC_CONFIGURE_ENABLE= fdkaac
-FDKAAC_LIB_DEPENDS= libfdk-aac.so:audio/fdk-aac
-FUSE_CONFIGURE_ENABLE= fuse
-FUSE_USES= fuse
-IPV6_CONFIGURE_ENABLE= ipv6
+FDKAAC_LIB_DEPENDS= libfdk-aac.so:audio/fdk-aac
+FUSE_CONFIGURE_ENABLE= fuse
+FUSE_USES= fuse
+IPV6_CONFIGURE_ENABLE= ipv6
MP3LAME_CONFIGURE_ENABLE= mp3lame
-MP3LAME_LIB_DEPENDS= libmp3lame.so:audio/lame
-OPUS_CONFIGURE_ENABLE= opus
-OPUS_LIB_DEPENDS= libopus.so:audio/opus
+MP3LAME_LIB_DEPENDS= libmp3lame.so:audio/lame
+OPUS_CONFIGURE_ENABLE= opus
+OPUS_LIB_DEPENDS= libopus.so:audio/opus
.include <bsd.port.pre.mk>
@@ -76,6 +81,10 @@ CONFIGURE_ENV+= OPENSSL_CFLAGS="-I${OPENSSLINC}" \
pre-configure:
@cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ./bootstrap
+post-patch:
+ ${REINPLACE_CMD} -e "s|^param=Xorg|param=${LOCALBASE}/libexec/Xorg|" \
+ ${WRKSRC}/sesman/sesman.ini.in
+
post-install:
${INSTALL_SCRIPT} ${FILESDIR}/startwm.sh ${STAGEDIR}${ETCDIR}