aboutsummaryrefslogtreecommitdiff
path: root/net/zaptel12/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/zaptel12/Makefile')
-rw-r--r--net/zaptel12/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/net/zaptel12/Makefile b/net/zaptel12/Makefile
index 53878fb30bdc..eacba3125337 100644
--- a/net/zaptel12/Makefile
+++ b/net/zaptel12/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= zaptel
-PORTVERSION= 0.10
-PORTREVISION= 1
+PORTVERSION= 0.11
CATEGORIES= misc
MASTER_SITES= http://www.portaone.com/~gonzo/
DISTNAME= ${PORTNAME}-freebsd-${PORTVERSION}
@@ -26,6 +25,12 @@ ONLY_FOR_ARCHS= i386
PKGMESSAGE= ${WRKSRC}/.MESSAGE
MAKE_ENV= KMODDIR=${PREFIX}/lib/zaptel
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= "does not build on FreeBSD \< 5.x"
+.endif
+
pre-everything::
@if [ ! -f /usr/src/sys/Makefile ]; then \
${ECHO_MSG} ">> The zaptel port needs FreeBSD kernel source code to compile."; \
@@ -50,4 +55,4 @@ post-install:
@${INSTALL_SCRIPT} ${WRKDIR}/zaptel.sh.sample ${PREFIX}/etc/rc.d
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>