aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/c3270/Makefile114
-rw-r--r--net/c3270/distinfo2
-rw-r--r--net/c3270/pkg-descr9
-rw-r--r--net/c3270/pkg-plist10
4 files changed, 10 insertions, 125 deletions
diff --git a/net/c3270/Makefile b/net/c3270/Makefile
index 93ba2291c572..b198535cffe6 100644
--- a/net/c3270/Makefile
+++ b/net/c3270/Makefile
@@ -1,118 +1,14 @@
-# Created by: pdseniura@techie.com
# $FreeBSD$
PORTNAME= c3270
-PORTVERSION= 3.3.14ga11
-PORTREVISION= 3
CATEGORIES= net
-MASTER_SITES= http://x3270.bgp.nu/download/03.03.14/
-MASTER_SITES_VER_PATH= ${PORTVERSION:C/(0[0-9]\.0[0-9])/}
-EXTRACT_SUFX= -src.tgz
-MAINTAINER= kbowling@FreeBSD.org
-COMMENT= Full-screen curses-based remote login to IBM mainframes
+COMMENT= curses-based remote login to IBM mainframes without x3270
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/([0-9]\.[0-9])(\..*)/\1/}
+CONFLICTS_INSTALL= x3270
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= ac_cv_search_libiconv=${ICONV_LIB}
+C3270= YES
-USES= iconv readline gmake
+MASTERDIR= ${.CURDIR}/../../x11/x3270
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
-
-# c3270's ./configure script supports these.
-# Within it all options except DBCS are enabled by default.
-
-OPTIONS_DEFINE= OPENSSL READLINE PR3287 ANSI APL DBCS FT LOCAL_PROCESS \
- PRINTER SCRIPT TN3270E TRACE DOCS
-OPTIONS_DEFAULT= OPENSSL READLINE PR3287 ANSI APL FT LOCAL_PROCESS \
- PRINTER SCRIPT TN3270E TRACE
-PR3287_DESC= Build pr3287 component
-ANSI_DESC= Include NVT (ANSI) support
-APL_DESC= Include APL support
-DBCS_DESC= Include EBCDIC DBCS support
-FT_DESC= Include IND\$$FILE support
-LOCAL_PROCESS_DESC= Include Local Process support
-PRINTER_DESC= Include printer session support
-SCRIPT_DESC= Include scripting support
-TN3270E_DESC= Include TN3270-Extended support
-TRACE_DESC= Include trace support
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MDOCS}
-PORTDOCS= *
-.endif
-
-.if ! ${PORT_OPTIONS:MOPENSSL}
-CONFIGURE_ARGS+= --disable-ssl
-.else
-USES+= ssl
-.endif
-
-.if ! ${PORT_OPTIONS:MREADLINE}
-CONFIGURE_ARGS+= --without-readline
-.undef USE_READLINE
-.endif
-
-.if ! ${PORT_OPTIONS:MANSI}
-CONFIGURE_ARGS+= --disable-ansi
-.endif
-
-.if ! ${PORT_OPTIONS:MAPL}
-CONFIGURE_ARGS+= --disable-apl
-.endif
-
-# EBCDIC double-byte character set support is disabled by default
-.if ${PORT_OPTIONS:MDBCS}
-CONFIGURE_ARGS+= --enable-dbcs
-PLIST_SUB+= DBCS=""
-.else
-PLIST_SUB+= DBCS="@comment "
-.endif
-
-.if ! ${PORT_OPTIONS:MFT}
-CONFIGURE_ARGS+= --disable-ft
-.endif
-
-.if ! ${PORT_OPTIONS:MLOCAL_PROCESS}
-CONFIGURE_ARGS+= --disable-local-process
-.endif
-
-.if ! ${PORT_OPTIONS:MPRINTER}
-CONFIGURE_ARGS+= --disable-printer
-.endif
-
-.if ! ${PORT_OPTIONS:MSCRIPT}
-CONFIGURE_ARGS+= --disable-script
-.endif
-
-.if ! ${PORT_OPTIONS:MTN3270E}
-CONFIGURE_ARGS+= --disable-tn3270e
-.endif
-
-.if ! ${PORT_OPTIONS:MTRACE}
-CONFIGURE_ARGS+= --disable-trace
-.endif
-
-post-install:
- @${INSTALL_MAN} ${WRKSRC}/c3270.man \
- ${STAGEDIR}${MANPREFIX}/man/man1/c3270.1
- @${INSTALL_MAN} ${WRKSRC}/x3270-script.man \
- ${STAGEDIR}${MANPREFIX}/man/man1/x3270-script.1
- @${INSTALL_MAN} ${WRKSRC}/x3270if.man \
- ${STAGEDIR}${MANPREFIX}/man/man1/x3270if.1
- @${INSTALL_MAN} ${WRKSRC}/ibm_hosts.man \
- ${STAGEDIR}${MANPREFIX}/man/man5/ibm_hosts.5
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- @${MKDIR} ${STAGEDIR}${DOCSDIR}/html
-.for i in ${PORTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/html/${i} ${STAGEDIR}${DOCSDIR}/${i}
-.endfor
- @${ECHO_MSG} "===> Extra Documentation installed in ${DOCSDIR}/html ."
-.endif
-
-.include <bsd.port.mk>
+.include "${MASTERDIR}/Makefile"
diff --git a/net/c3270/distinfo b/net/c3270/distinfo
deleted file mode 100644
index 972d1d444735..000000000000
--- a/net/c3270/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (c3270-3.3.14ga11-src.tgz) = 8d2f72e4f7b1cf4dea73acd5c30c3344d15a358e16a74b4d9da333fc6317d28c
-SIZE (c3270-3.3.14ga11-src.tgz) = 923356
diff --git a/net/c3270/pkg-descr b/net/c3270/pkg-descr
index 5bedf41e76fc..741ea30b3aee 100644
--- a/net/c3270/pkg-descr
+++ b/net/c3270/pkg-descr
@@ -1,5 +1,6 @@
-c3270 is a curses-based IBM 3270 terminal emulator. It can be used to
-communicate with any IBM host that supports 3270-style connections
-over TELNET. It can also communicate with hosts that use line-by-line
-ASCII mode to do initial login negotiation before switching to
+c3270 is a curses-based IBM 3270 terminal emulator from the x3270 project.
+
+It can be used to communicate with any IBM host that supports 3270-style
+connections over TELNET. It can also communicate with hosts that use
+line-by-line ASCII mode to do initial login negotiation before switching to
full-screen 3270 mode.
diff --git a/net/c3270/pkg-plist b/net/c3270/pkg-plist
deleted file mode 100644
index 1cef745e0e83..000000000000
--- a/net/c3270/pkg-plist
+++ /dev/null
@@ -1,10 +0,0 @@
-bin/c3270
-bin/x3270if
-etc/x3270/ibm_hosts
-man/man1/c3270.1.gz
-man/man1/x3270-script.1.gz
-man/man1/x3270if.1.gz
-man/man5/ibm_hosts.5.gz
-%%DBCS%%etc/x3270/icudt28l_ibm-1027_P100-1995.cnv
-%%DBCS%%etc/x3270/icudt28l_ibm-300_P110-1997.cnv
-%%DBCS%%etc/x3270/icudt28l_ibm-837_P100-2000.cnv