aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/tcptraceroute/Makefile13
-rw-r--r--net/tcptraceroute/files/patch-Makefile4
-rw-r--r--net/tcptraceroute/pkg-descr2
-rw-r--r--net/tcptraceroute/pkg-plist4
4 files changed, 9 insertions, 14 deletions
diff --git a/net/tcptraceroute/Makefile b/net/tcptraceroute/Makefile
index 72d8f2ee358b..a08ca62344a0 100644
--- a/net/tcptraceroute/Makefile
+++ b/net/tcptraceroute/Makefile
@@ -11,18 +11,11 @@ MASTER_SITES= http://michael.toren.net/code/tcptraceroute/ \
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Traceroute implementation using TCP packets
-BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet10
+LICENSE= GPLv2
-MAN8= tcptraceroute.8
+BUILD_DEPENDS= ${LOCALBASE}/bin/libnet10-config:${PORTSDIR}/net/libnet10
-LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet10-config
-
-NO_STAGE= yes
post-patch:
- @${REINPLACE_CMD} -e 's|libnet-config|${LIBNET_CONFIG}|' \
- ${WRKSRC}/${MAKEFILE}
-
-post-install:
- @${CHMOD} u+s ${PREFIX}/sbin/tcptraceroute
+ @${REINPLACE_CMD} -e 's|libnet-config|libnet10-config|' ${WRKSRC}/Makefile
.include <bsd.port.mk>
diff --git a/net/tcptraceroute/files/patch-Makefile b/net/tcptraceroute/files/patch-Makefile
index f137ff657f9d..3edd31ed9068 100644
--- a/net/tcptraceroute/files/patch-Makefile
+++ b/net/tcptraceroute/files/patch-Makefile
@@ -29,8 +29,8 @@
install: tcptraceroute
- install -D tcptraceroute $(DESTDIR)/tcptraceroute
-+ install -c -s tcptraceroute $(BINDIR)/tcptraceroute
-+ install -c -m 444 tcptraceroute.8 $(MANDIR)/man8/tcptraceroute.8
++ install -c -s tcptraceroute $(DESTDIR)$(BINDIR)/tcptraceroute
++ install -c -m 444 tcptraceroute.8 $(DESTDIR)$(MANDIR)/man8/tcptraceroute.8
distrib: clean changelog man
diff --git a/net/tcptraceroute/pkg-descr b/net/tcptraceroute/pkg-descr
index 35920dc8ed50..46f41ba20522 100644
--- a/net/tcptraceroute/pkg-descr
+++ b/net/tcptraceroute/pkg-descr
@@ -15,4 +15,4 @@ listening for connections on. By sending out TCP SYN packets instead of
UDP or ICMP ECHO packets, tcptraceroute is able to bypass the most
common firewall filters.
-WWW: http://michael.toren.net/code/tcptraceroute/
+WWW: https://github.com/mct/tcptraceroute
diff --git a/net/tcptraceroute/pkg-plist b/net/tcptraceroute/pkg-plist
index cbdc4f42fa33..d7390d954fe8 100644
--- a/net/tcptraceroute/pkg-plist
+++ b/net/tcptraceroute/pkg-plist
@@ -1,2 +1,4 @@
-@comment $FreeBSD$
+man/man8/tcptraceroute.8.gz
+@mode 4555
sbin/tcptraceroute
+@mode