aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/Makefile3
-rw-r--r--net/hping/Makefile52
-rw-r--r--net/hping/distinfo2
-rw-r--r--net/hping/files/extra-patch-sendip.c33
-rw-r--r--net/hping/files/patch-Makefile.in33
-rw-r--r--net/hping/files/patch-bytesex.h17
-rw-r--r--net/hping/files/patch-configure10
-rw-r--r--net/hping/pkg-descr21
-rw-r--r--net/queso/Makefile35
-rw-r--r--net/queso/distinfo2
-rw-r--r--net/queso/files/patch-configure19
-rw-r--r--net/queso/files/patch-tcpip.c81
-rw-r--r--net/queso/pkg-descr21
-rw-r--r--net/queso/pkg-plist3
-rw-r--r--net/ssvnc/Makefile51
-rw-r--r--net/ssvnc/distinfo2
-rw-r--r--net/ssvnc/files/patch-Makefile57
-rw-r--r--net/ssvnc/files/patch-vncstorepw_Makefile45
-rw-r--r--net/ssvnc/files/patch-vncstorepw_ultravnc__dsm__helper.c199
-rw-r--r--net/ssvnc/files/patch-wr__tool8
-rw-r--r--net/ssvnc/pkg-descr15
-rw-r--r--net/ssvnc/pkg-message12
-rw-r--r--net/ssvnc/pkg-plist21
23 files changed, 0 insertions, 742 deletions
diff --git a/net/Makefile b/net/Makefile
index 8c2b9d32b926..b1f253b9369e 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -249,7 +249,6 @@
SUBDIR += honeyd
SUBDIR += hostapd
SUBDIR += hostapd-devel
- SUBDIR += hping
SUBDIR += hping3
SUBDIR += hsflowd
SUBDIR += htpdate
@@ -1169,7 +1168,6 @@
SUBDIR += qt5-network
SUBDIR += qt5-networkauth
SUBDIR += quagga
- SUBDIR += queso
SUBDIR += quiche
SUBDIR += quiterss
SUBDIR += quoted
@@ -1449,7 +1447,6 @@
SUBDIR += ssldump
SUBDIR += sslh
SUBDIR += ssspl
- SUBDIR += ssvnc
SUBDIR += stone
SUBDIR += storj
SUBDIR += stund
diff --git a/net/hping/Makefile b/net/hping/Makefile
deleted file mode 100644
index a60662cc436d..000000000000
--- a/net/hping/Makefile
+++ /dev/null
@@ -1,52 +0,0 @@
-# Created by: Roman Shterenzon <roman@xpert.com>
-
-PORTNAME= hping
-PORTVERSION= 2.0.0r3
-PORTREVISION= 2
-PORTEPOCH= 1
-CATEGORIES= net security
-MASTER_SITES= http://www.hping.org/ \
- http://200ok.org/distfiles/hping/
-DISTNAME= hping2.0.0-rc3
-
-MAINTAINER= ecu@200ok.org
-COMMENT= Network auditing tool
-
-DEPRECATED= Deprecated upstream, please consider using net/hping3 instead
-EXPIRATION_DATE=2022-03-31
-
-CONFLICTS= hping-devel
-
-WRKSRC= ${WRKDIR}/hping2-rc3
-
-BROKEN_aarch64= fails to build: cannot find the byte order for this architecture, fix bytesex.h
-BROKEN_riscv64= fails to build: cannot find the byte order for this architecture, fix bytesex.h
-
-USES= gmake
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --force-libpcap
-
-PLIST_FILES= sbin/hping man/man8/hping.8.gz
-PORTDOCS= AS-BACKDOOR HPING2-HOWTO.txt HPING2-IS-OPEN \
- MORE-FUN-WITH-IPID SPOOFED_SCAN.txt APD.txt
-
-OPTIONS_DEFINE= DOCS
-
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-sendip.c
-
-post-patch:
- @${REINPLACE_CMD} -e '/^struct ars_layer_info ars_linfo/d' \
- ${WRKSRC}/ars.h
- @${REINPLACE_CMD} -e '/^volatile struct delaytable_element/d' \
- ${WRKSRC}/hping2.h
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/hping2 ${STAGEDIR}${PREFIX}/sbin/hping
- ${INSTALL_MAN} ${WRKSRC}/docs/hping2.8 \
- ${STAGEDIR}${MANPREFIX}/man/man8/hping.8
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
-.for i in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/docs/${i} ${STAGEDIR}${DOCSDIR}
-.endfor
-
-.include <bsd.port.mk>
diff --git a/net/hping/distinfo b/net/hping/distinfo
deleted file mode 100644
index 92498c34b65a..000000000000
--- a/net/hping/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (hping2.0.0-rc3.tar.gz) = f59292de39b9a4010414bd120a494226399767148efa37278bd53d9613167964
-SIZE (hping2.0.0-rc3.tar.gz) = 124573
diff --git a/net/hping/files/extra-patch-sendip.c b/net/hping/files/extra-patch-sendip.c
deleted file mode 100644
index 872861983e5a..000000000000
--- a/net/hping/files/extra-patch-sendip.c
+++ /dev/null
@@ -1,33 +0,0 @@
---- sendip.c.orig 2003-08-01 21:28:07.000000000 +0800
-+++ sendip.c 2015-12-22 23:16:39.296072000 +0800
-@@ -48,12 +48,12 @@
- ip->ihl = (IPHDR_SIZE + optlen + 3) >> 2;
- ip->tos = ip_tos;
-
--#if defined OSTYPE_FREEBSD || defined OSTYPE_NETBSD || defined OSTYPE_BSDI
--/* FreeBSD */
-+#if defined OSTYPE_NETBSD || defined OSTYPE_BSDI
- /* NetBSD */
- ip->tot_len = packetsize;
- #else
- /* Linux */
-+/* FreeBSD */
- /* OpenBSD */
- ip->tot_len = htons(packetsize);
- #endif
-@@ -73,13 +73,13 @@
- htons((unsigned short) src_id);
- }
-
--#if defined OSTYPE_FREEBSD || defined OSTYPE_NETBSD | defined OSTYPE_BSDI
--/* FreeBSD */
-+#if defined OSTYPE_NETBSD | defined OSTYPE_BSDI
- /* NetBSD */
- ip->frag_off |= more_fragments;
- ip->frag_off |= fragoff >> 3;
- #else
- /* Linux */
-+/* FreeBSD */
- /* OpenBSD */
- ip->frag_off |= htons(more_fragments);
- ip->frag_off |= htons(fragoff >> 3); /* shift three flags bit */
diff --git a/net/hping/files/patch-Makefile.in b/net/hping/files/patch-Makefile.in
deleted file mode 100644
index da0dfa76aff1..000000000000
--- a/net/hping/files/patch-Makefile.in
+++ /dev/null
@@ -1,33 +0,0 @@
---- Makefile.in.orig Mon May 3 11:29:39 2004
-+++ Makefile.in Wed May 19 11:23:43 2004
-@@ -6,10 +6,10 @@
- # $date: Sun Jul 25 17:56:15 MET DST 1999$
- # $rev: 3$
-
--CC= gcc
-+CC?= gcc
- AR=/usr/bin/ar
- RANLIB=/usr/bin/ranlib
--CCOPT= -O2 -Wall @PCAP_INCLUDE@
-+CCOPT= -Wall @CFLAGS@ @PCAP_INCLUDE@
- DEBUG= -g
- #uncomment the following if you need libpcap based build under linux
- #(not raccomanded)
-@@ -43,7 +43,7 @@
- $(RANLIB) $@
-
- hping2: byteorder.h $(OBJ)
-- $(CC) -o hping2 $(CCOPT) $(DEBUG) $(OBJ) $(PCAP) @SOLARISLIB@
-+ $(CC) -o hping2 $(CCOPT) $(OBJ) $(PCAP) @SOLARISLIB@
- @echo
- ./hping2 -v
- @echo "use \`make strip' to strip hping2 binary"
-@@ -53,7 +53,7 @@
- ./configure
-
- .c.o:
-- $(CC) -c $(CCOPT) $(DEBUG) $(COMPILE_TIME) $<
-+ $(CC) -c $(CCOPT) $(COMPILE_TIME) $<
-
- clean:
- rm -rf hping2 *.o *.a
diff --git a/net/hping/files/patch-bytesex.h b/net/hping/files/patch-bytesex.h
deleted file mode 100644
index 6159fea08192..000000000000
--- a/net/hping/files/patch-bytesex.h
+++ /dev/null
@@ -1,17 +0,0 @@
---- bytesex.h.orig 2003-07-28 17:00:55.000000000 +0800
-+++ bytesex.h 2015-12-22 22:30:11.367208000 +0800
-@@ -8,10 +8,14 @@
- #define ARS_BYTESEX_H
-
- #if defined(__i386__) \
-+ || defined (__amd64__) \
-+ || defined(__ia64__) \
- || defined(__alpha__) \
-+ || defined(__arm__) \
- || (defined(__mips__) && (defined(MIPSEL) || defined (__MIPSEL__)))
- #define BYTE_ORDER_LITTLE_ENDIAN
- #elif defined(__mc68000__) \
-+ || (defined(__arm__) && (defined(ARMEB) || defined (__ARMEB__))) \
- || defined (__sparc__) \
- || defined (__sparc) \
- || defined (__PPC__) \
diff --git a/net/hping/files/patch-configure b/net/hping/files/patch-configure
deleted file mode 100644
index b7dda57f7370..000000000000
--- a/net/hping/files/patch-configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.orig Fri Sep 14 22:04:25 2001
-+++ configure Fri Sep 14 22:05:02 2001
-@@ -99,6 +99,7 @@
- -e "s^@PCAP_INCLUDE@^$PCAP_INCLUDE^g" \
- -e "s^@MANPATH@^$INSTALL_MANPATH^g" \
- -e "s^@SOLARISLIB@^$SOLARISLIB^g" \
-+ -e "s^@CFLAGS@^$CFLAGS^g" \
- <Makefile.in > Makefile
-
- #
diff --git a/net/hping/pkg-descr b/net/hping/pkg-descr
deleted file mode 100644
index 5abe6132695b..000000000000
--- a/net/hping/pkg-descr
+++ /dev/null
@@ -1,21 +0,0 @@
-hping is a command-line oriented TCP/IP packet assembler/analyzer.
-The interface is inspired to the ping(8) Unix command, but hping isn't
-only able to send ICMP echo requests. It supports TCP, UDP, ICMP and
-RAW-IP protocols, has a traceroute mode, the ability to send files
-between a covered channel, and many other features.
-While hping was mainly used as a security tool in the past, it can be
-used in many ways by people that don't care about security to test
-networks and hosts. A subset of the stuff you can do using hping:
-
- - Test firewall rules
- - [spoofed] port scanning
- - Test net performance using different protocols,
- packet size, TOS (type of service) and fragmentation.
- - Path MTU discovery
- - Files transfering even between really fascist firewall rules.
- - Traceroute like under different protocols.
- - Firewalk like usage.
- - Remote OS fingerprint.
- - TCP/IP stack auditing.
-
-WWW: http://www.hping.org/
diff --git a/net/queso/Makefile b/net/queso/Makefile
deleted file mode 100644
index 15d9eafc5d6a..000000000000
--- a/net/queso/Makefile
+++ /dev/null
@@ -1,35 +0,0 @@
-# Created by: Wu Ching-hong <woju@freebsd.ee.ntu.edu.tw>
-
-PORTNAME= queso
-PORTVERSION= 980922
-PORTREVISION= 3
-CATEGORIES= net security
-MASTER_SITES= PACKETSTORM/UNIX/scanners
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Determine the remote OS using simple TCP packets
-
-LICENSE= GPLv2
-
-DEPRECATED= Abandonware and obsolete, last release back in 1998. Please consider using security/nmap instead
-EXPIRATION_DATE=2022-03-31
-
-OPTIONS_DEFINE= DOCS
-
-GNU_CONFIGURE= yes
-
-post-patch:
- @${REINPLACE_CMD} -e \
- 's|-O2 -pipe|| ; \
- s|^LDFLAGS|#LDFLAGS|' ${WRKSRC}/Makefile.in
- @${LN} -sf queso.conf ${WRKSRC}/queso.conf.sample
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/queso ${STAGEDIR}${PREFIX}/sbin
- ${INSTALL_DATA} ${WRKSRC}/queso.conf.sample ${STAGEDIR}${PREFIX}/etc
-
-post-install-DOCS-on:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/Documentation.txt ${STAGEDIR}${DOCSDIR}
-
-.include <bsd.port.mk>
diff --git a/net/queso/distinfo b/net/queso/distinfo
deleted file mode 100644
index bb96c694d041..000000000000
--- a/net/queso/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (queso-980922.tar.gz) = a27ca8e6af2c543cc7c8a61380aaed455be03bead270bbafc24af06d35a68030
-SIZE (queso-980922.tar.gz) = 41830
diff --git a/net/queso/files/patch-configure b/net/queso/files/patch-configure
deleted file mode 100644
index 703293921f9d..000000000000
--- a/net/queso/files/patch-configure
+++ /dev/null
@@ -1,19 +0,0 @@
---- configure.orig Tue Sep 22 13:42:29 1998
-+++ configure Sat Oct 24 11:56:57 1998
-@@ -1110,6 +1110,16 @@
- ;;
- esac
- ;;
-+FreeBSD)
-+ PCAP=1
-+ case "`uname -m`" in
-+ i386)
-+ unset NEEDS_HTONS_IP_LEN
-+ ;;
-+ alpha)
-+ ;;
-+ esac
-+ ;;
- *)
- PCAP=1
- ;;
diff --git a/net/queso/files/patch-tcpip.c b/net/queso/files/patch-tcpip.c
deleted file mode 100644
index b36efff5619f..000000000000
--- a/net/queso/files/patch-tcpip.c
+++ /dev/null
@@ -1,81 +0,0 @@
---- tcpip.c.orig Tue Sep 22 13:35:43 1998
-+++ tcpip.c Sat Oct 24 11:46:58 1998
-@@ -25,6 +25,12 @@
- #include <stdarg.h>
- #include <net/if.h>
-
-+#if defined(__FreeBSD__) || defined(__OpenBSD__) || defined(__NetBSD__) || defined(__bsdi__)
-+#include <err.h>
-+#include <errno.h>
-+#include <sysexits.h>
-+#endif
-+
- #include "tcpip.h"
-
- /*-- LINUX routilng TABLES */
-@@ -333,7 +339,64 @@
- }
- }
-
--#else /* !LINUX ---------------------------------------------- OTHER --*/
-+/*------------------------------- FreeBSD / OpenBSD / NetBSD / BSDI --*/
-+#elif defined(__FreeBSD__) || defined(__OpenBSD__) || defined(__NetBSD__) || defined(__bsdi__)
-+/*
-+ FreeBSD Ref: /usr/share/examples/find_interface/
-+*/
-+ struct sockaddr_in local, remote;
-+ int s, rv, namelen;
-+
-+ remote.sin_addr.s_addr = dest;
-+ remote.sin_port = htons(60000);
-+ remote.sin_family = AF_INET;
-+ remote.sin_len = sizeof remote;
-+
-+ local.sin_addr.s_addr = htonl(INADDR_ANY);
-+ local.sin_port = htons(60000);
-+ local.sin_family = AF_INET;
-+ local.sin_len = sizeof local;
-+
-+ s = socket(PF_INET, SOCK_DGRAM, 0);
-+ if (s < 0)
-+ err(EX_OSERR, "socket");
-+
-+ do
-+ {
-+ rv = bind(s, (struct sockaddr *)&local, sizeof local);
-+ local.sin_port = htons(ntohs(local.sin_port) + 1);
-+ } while(rv < 0 && errno == EADDRINUSE);
-+
-+ if (rv < 0)
-+ err(EX_OSERR, "bind");
-+
-+ do
-+ {
-+ rv = connect(s, (struct sockaddr *)&remote, sizeof remote);
-+ remote.sin_port = htons(ntohs(remote.sin_port) + 1);
-+ } while(rv < 0 && errno == EADDRINUSE);
-+
-+ if (rv < 0)
-+ err(EX_OSERR, "bind");
-+
-+ do
-+ {
-+ rv = connect(s, (struct sockaddr *)&remote, sizeof remote);
-+ remote.sin_port = htons(ntohs(remote.sin_port) + 1);
-+ } while(rv < 0 && errno == EADDRINUSE);
-+
-+ if (rv < 0)
-+ err(EX_OSERR, "connect");
-+
-+ namelen = sizeof local;
-+ rv = getsockname(s, (struct sockaddr *)&local, &namelen);
-+
-+ if (rv < 0)
-+ err(EX_OSERR, "getsockname");
-+
-+ return local.sin_addr;
-+
-+#else /* !LINUX && !BSD ---------------------------------- OTHER --*/
- struct sockaddr_in sin;
- char myname[80];
-
diff --git a/net/queso/pkg-descr b/net/queso/pkg-descr
deleted file mode 100644
index 06650d65ab37..000000000000
--- a/net/queso/pkg-descr
+++ /dev/null
@@ -1,21 +0,0 @@
-former QueSO home page <URL:http://www.apostols.org/projectz/queso/>:
-
-How we can determine the remote OS using simple TCP packets? Well,
-it's easy, they're packets that don't make any sense, so the RFCs
-don't clearly state what to answer in these kind of situations.
-Facing this ambiguous, each TCP/IP stack takes a different approach
-to the problem, and this way, we get a different response. In some
-cases (like Linux, to name one) some programming mistakes make the OS
-detectable.
-
-QueSO sends:
-
- 0 SYN * THIS IS VALID, used to verify LISTEN
- 1 SYN+ACK
- 2 FIN
- 3 FIN+ACK
- 4 SYN+FIN
- 5 PSH
- 6 SYN+XXX+YYY * XXX & YYY are unused TCP flags
-
-All packets have a random seq_num and a 0x0 ack_num.
diff --git a/net/queso/pkg-plist b/net/queso/pkg-plist
deleted file mode 100644
index 6ec2c03f0349..000000000000
--- a/net/queso/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-sbin/queso
-@sample etc/queso.conf.sample
-%%PORTDOCS%%%%DOCSDIR%%/Documentation.txt
diff --git a/net/ssvnc/Makefile b/net/ssvnc/Makefile
deleted file mode 100644
index 9b65dd35924f..000000000000
--- a/net/ssvnc/Makefile
+++ /dev/null
@@ -1,51 +0,0 @@
-# Created by: Alejandro Pulver <alepulver@FreeBSD.org>
-
-PORTNAME= ssvnc
-PORTVERSION= 1.0.29
-PORTREVISION= 4
-CATEGORIES= net security
-MASTER_SITES= SF
-EXTRACT_SUFX= .src.tar.gz
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Enhanced TightVNC Viewer (SSVNC: SSL/SSH VNC viewer)
-
-LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
-
-DEPRECATED= Abandonware, last release in 2011 and broken functionality reported upstream
-EXPIRATION_DATE=2022-03-31
-
-RUN_DEPENDS= stunnel:security/stunnel \
- xterm:x11/xterm
-
-USES= gmake imake:env jpeg perl5 ssl tk:wrapper xorg
-USE_PERL5= run
-USE_XORG= ice sm x11 xaw xext xi xmu xpm xt
-
-CFLAGS+= -I${OPENSSLINC}
-LDFLAGS+= -L${OPENSSLLIB}
-MAKE_ENV+= ROOT=${STAGEDIR}
-
-OPTIONS_DEFINE= DOCS ULTRAFTP
-OPTIONS_SUB= yes
-
-DOCS_MAKE_ARGS_OFF= DOCS=""
-
-ULTRAFTP_DESC= UltraVNC File Transfer support (Java required)
-ULTRAFTP_USE= JAVA=yes
-ULTRAFTP_MAKE_ARGS_OFF= JSRC=""
-
-.include <bsd.port.pre.mk>
-
-post-patch:
- @${REINPLACE_CMD} -e 's|netstat -ant|netstat -an|' \
- ${WRKSRC}/scripts/util/ss_vncviewer
- @${REINPLACE_CMD} -e 's|[[:<:]]ssvnc[[:>:]]|ssvnc-gui|' \
- ${WRKSRC}/man/man1/ssvnc.1
-
-do-configure:
- (cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} \
- ${MAKE_CMD} ${MAKE_ARGS} config)
-
-.include <bsd.port.post.mk>
diff --git a/net/ssvnc/distinfo b/net/ssvnc/distinfo
deleted file mode 100644
index 400464629ae1..000000000000
--- a/net/ssvnc/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (ssvnc-1.0.29.src.tar.gz) = 74df32eb8eaa68b07c9693a232ebe42154617c7f3cbe1d4e68d3fe7c557d618d
-SIZE (ssvnc-1.0.29.src.tar.gz) = 552796
diff --git a/net/ssvnc/files/patch-Makefile b/net/ssvnc/files/patch-Makefile
deleted file mode 100644
index 2c3459285eb3..000000000000
--- a/net/ssvnc/files/patch-Makefile
+++ /dev/null
@@ -1,57 +0,0 @@
---- Makefile.orig 2010-02-26 02:29:31 UTC
-+++ Makefile
-@@ -29,6 +29,7 @@ MAN = man
- MANDIR ?= $(MAN)
- APPS ?= share/applications
- BINNAME ?= ssvncviewer
-+DOCS ?= share/doc/ssvnc
-
-
- VSRC = vnc_unixsrc
-@@ -65,23 +66,30 @@ clean:
- cd $(PSRC); $(MAKE) clean
-
- install: all
-- mkdir -p $(ROOT)$(PREFIX)/$(BIN) $(ROOT)$(PREFIX)/$(LIB) $(ROOT)$(PREFIX)/$(MANDIR)/man1
-- strip $(VIEWER)
-- cp -p $(VIEWER) $(ROOT)$(PREFIX)/$(LIB)
-- cp -p $(VNCSPW) $(ROOT)$(PREFIX)/$(LIB)
-- cp -p $(UNWRAP) $(ROOT)$(PREFIX)/$(LIB)
-- cp -p $(LIMACC) $(ROOT)$(PREFIX)/$(LIB)
-- cp -p $(ULTDSM) $(ROOT)$(PREFIX)/$(LIB)
-- cp -pR scripts/* $(ROOT)$(PREFIX)/$(LIB)
-- if [ "X$(JSRC)" != "X" ]; then cp -p $(ARCHIVE) $(ROOT)$(PREFIX)/$(LIB)/util; fi
-- cp -p $(MAN)/man1/ssvnc.1 $(ROOT)$(PREFIX)/$(MANDIR)/man1
-- ./wr_tool $(ROOT)$(PREFIX)/$(BIN)/ssvnc $(PREFIX)/$(LIB)/ssvnc
-- ./wr_tool $(ROOT)$(PREFIX)/$(BIN)/tsvnc $(PREFIX)/$(LIB)/tsvnc
-- ./wr_tool $(ROOT)$(PREFIX)/$(BIN)/sshvnc $(PREFIX)/$(LIB)/sshvnc
-+ mkdir -p $(ROOT)$(PREFIX)/$(BIN) $(ROOT)$(PREFIX)/$(LIB)/util $(ROOT)$(PREFIX)/$(MANDIR)/man1
-+ ${BSD_INSTALL_PROGRAM} $(VIEWER) $(ROOT)$(PREFIX)/$(LIB)
-+ ${BSD_INSTALL_PROGRAM} $(VNCSPW) $(ROOT)$(PREFIX)/$(LIB)
-+ ${BSD_INSTALL_LIB} $(UNWRAP) $(ROOT)$(PREFIX)/$(LIB)
-+ ${BSD_INSTALL_LIB} $(LIMACC) $(ROOT)$(PREFIX)/$(LIB)
-+ ${BSD_INSTALL_PROGRAM} $(ULTDSM) $(ROOT)$(PREFIX)/$(LIB)
-+ ${BSD_INSTALL_SCRIPT} scripts/ssvnc $(ROOT)$(PREFIX)/$(LIB)
-+ ${BSD_INSTALL_SCRIPT} scripts/ssvnc_cmd $(ROOT)$(PREFIX)/$(LIB)
-+ ${BSD_INSTALL_SCRIPT} scripts/tsvnc $(ROOT)$(PREFIX)/$(LIB)
-+ ${BSD_INSTALL_SCRIPT} scripts/util/ssvnc.tcl $(ROOT)$(PREFIX)/$(LIB)/util
-+ ${BSD_INSTALL_SCRIPT} scripts/util/ss_vncviewer $(ROOT)$(PREFIX)/$(LIB)/util
-+ if [ "X$(JSRC)" != "X" ]; then ${BSD_INSTALL_DATA} $(ARCHIVE) $(ROOT)$(PREFIX)/$(LIB)/util; fi
-+ ${BSD_INSTALL_MAN} $(MAN)/man1/ssvnc.1 $(ROOT)$(PREFIX)/$(MANDIR)/man1/ssvnc.1
-+ ${BSD_INSTALL_MAN} $(MAN)/man1/ssvnc.1 $(ROOT)$(PREFIX)/$(MANDIR)/man1/ssvnc-gui.1
-+ ./wr_tool $(ROOT)$(PREFIX)/$(BIN)/ssvnc-gui $(PREFIX)/$(LIB)/ssvnc
-+ ./wr_tool $(ROOT)$(PREFIX)/$(BIN)/ssvnc-ts $(PREFIX)/$(LIB)/tsvnc
-+ ./wr_tool $(ROOT)$(PREFIX)/$(BIN)/ssvnc-stunnel $(PREFIX)/$(LIB)/util/ss_vncviewer
- if [ "X$(APPS)" != X ]; then mkdir -p $(ROOT)$(PREFIX)/$(APPS); fi
-- if [ "X$(APPS)" != X ]; then cp -p ssvnc.desktop $(ROOT)$(PREFIX)/$(APPS); fi
-- if [ "X$(BINNAME)" != X ]; then cp -p $(VIEWER) $(ROOT)$(PREFIX)/$(BIN)/$(BINNAME); fi
-- if [ "X$(BINNAME)" != X ]; then cp -p $(MAN)/man1/ssvncviewer.1 $(ROOT)$(PREFIX)/$(MANDIR)/man1/$(BINNAME).1; fi
-+ if [ "X$(APPS)" != X ]; then ${BSD_INSTALL_DATA} ssvnc.desktop $(ROOT)$(PREFIX)/$(APPS); fi
-+ if [ "X$(BINNAME)" != X ]; then ${BSD_INSTALL_PROGRAM} $(VIEWER) $(ROOT)$(PREFIX)/$(BIN)/$(BINNAME); fi
-+ if [ "X$(BINNAME)" != X ]; then ${BSD_INSTALL_MAN} $(MAN)/man1/ssvncviewer.1 $(ROOT)$(PREFIX)/$(MANDIR)/man1/$(BINNAME).1; fi
-+ if [ "X$(DOCS)" != X ]; then mkdir -p $(ROOT)$(PREFIX)/$(DOCS); fi
-+ if [ "X$(DOCS)" != X ]; then ${BSD_INSTALL_DATA} scripts/util/stunnel-server.conf $(ROOT)$(PREFIX)/$(DOCS); fi
-+ if [ "X$(DOCS)" != X ]; then ${BSD_INSTALL_MAN} README $(ROOT)$(PREFIX)/$(DOCS); fi
-
-
- #internal use only, a test install:
diff --git a/net/ssvnc/files/patch-vncstorepw_Makefile b/net/ssvnc/files/patch-vncstorepw_Makefile
deleted file mode 100644
index 6ed065e2a2ff..000000000000
--- a/net/ssvnc/files/patch-vncstorepw_Makefile
+++ /dev/null
@@ -1,45 +0,0 @@
---- vncstorepw/Makefile.orig 2010-04-22 03:22:40 UTC
-+++ vncstorepw/Makefile
-@@ -7,21 +7,18 @@ UNWRAP = unwrap.so
- LIMACC = lim_accept.so
- ULTDSM = ultravnc_dsm_helper
-
--# gcc must be used:
--CC = gcc
-
- all: $(CMD) $(UNWRAP) $(LIMACC) $(ULTDSM)
-
- $(CMD): vncauth.o vncstorepw.o d3des.o
- PATH=$$PATH:$(EPATH) $(CC) -o $(CMD) vncstorepw.o vncauth.o d3des.o
-- PATH=$$PATH:$(EPATH) strip $(CMD)
- @ls -l $(CMD)
-
- $(UNWRAP): unwrap.c
- if [ `uname` = "Darwin" ]; then \
- PATH=$$PATH:$(EPATH) $(CC) -o $(UNWRAP) -dynamiclib -fPIC unwrap.c; \
- else \
-- PATH=$$PATH:$(EPATH) $(CC) -o $(UNWRAP) -shared -fPIC unwrap.c; \
-+ PATH=$$PATH:$(EPATH) $(CC) -o $(UNWRAP) -shared $(CFLAGS) -fPIC unwrap.c; \
- fi
- @ls -l $(UNWRAP)
-
-@@ -29,7 +26,7 @@ $(LIMACC): lim_accept.c
- if [ `uname` = "Darwin" ]; then \
- PATH=$$PATH:$(EPATH) $(CC) -o $(LIMACC) -dynamiclib -fPIC -nostartfiles lim_accept.c; \
- else \
-- PATH=$$PATH:$(EPATH) $(CC) -o $(LIMACC) -shared -fPIC -nostartfiles lim_accept.c; \
-+ PATH=$$PATH:$(EPATH) $(CC) -o $(LIMACC) -shared $(CFLAGS) -fPIC -nostartfiles lim_accept.c; \
- fi
- @ls -l $(LIMACC)
-
-@@ -39,9 +36,8 @@ $(ULTDSM): ultravnc_dsm_helper.c
- if [ `uname` = "SunOS" ]; then \
- PATH=$$PATH:$(EPATH) $(CC) -o $(ULTDSM) $(CPP_SSL) ultravnc_dsm_helper.c $(LD_SSL) -lssl -lcrypto -lsocket -lnsl; \
- else \
-- PATH=$$PATH:$(EPATH) $(CC) -o $(ULTDSM) $(CPP_SSL) ultravnc_dsm_helper.c $(LD_SSL) -lssl -lcrypto; \
-+ PATH=$$PATH:$(EPATH) $(CC) -o $(ULTDSM) $(CPP_SSL) ultravnc_dsm_helper.c $(CFLAGS) $(LDFLAGS) -lssl -lcrypto; \
- fi
-- PATH=$$PATH:$(EPATH) strip $(ULTDSM)
- @ls -l $(ULTDSM)
-
- test: $(CMD)
diff --git a/net/ssvnc/files/patch-vncstorepw_ultravnc__dsm__helper.c b/net/ssvnc/files/patch-vncstorepw_ultravnc__dsm__helper.c
deleted file mode 100644
index 2c37647d074f..000000000000
--- a/net/ssvnc/files/patch-vncstorepw_ultravnc__dsm__helper.c
+++ /dev/null
@@ -1,199 +0,0 @@
---- vncstorepw/ultravnc_dsm_helper.c
-+++ vncstorepw/ultravnc_dsm_helper.c
-@@ -414,7 +414,9 @@ void enc_do(char *ciph, char *keyfile, c
- if (strstr(p, "md5+") == p) {
- Digest = EVP_md5(); p += strlen("md5+");
- } else if (strstr(p, "sha+") == p) {
-- Digest = EVP_sha(); p += strlen("sha+");
-+ fprintf(stderr, "%s: obsolete hash algorithm: SHA-0\n",
-+ prog, s);
-+ exit(1);
- } else if (strstr(p, "sha1+") == p) {
- Digest = EVP_sha1(); p += strlen("sha1+");
- } else if (strstr(p, "ripe+") == p) {
-@@ -655,8 +657,10 @@ static void enc_xfer(int sock_fr, int so
- */
- unsigned char E_keystr[EVP_MAX_KEY_LENGTH];
- unsigned char D_keystr[EVP_MAX_KEY_LENGTH];
-- EVP_CIPHER_CTX E_ctx, D_ctx;
-- EVP_CIPHER_CTX *ctx = NULL;
-+ //openssl1.1.patch - Do NOT create two context and only use one
-+ // - that's silly.
-+ //EVP_CIPHER_CTX *E_ctx, *D_ctx;
-+ EVP_CIPHER_CTX *ctx;
-
- unsigned char buf[BSIZE], out[BSIZE];
- unsigned char *psrc = NULL, *keystr;
-@@ -698,11 +702,14 @@ static void enc_xfer(int sock_fr, int so
- encsym = encrypt ? "+" : "-";
-
- /* use the encryption/decryption context variables below */
-+ ctx = EVP_CIPHER_CTX_new();
-+ if (!ctx) {
-+ fprintf(stderr, "Failed to create encryption/decryption context.\n");
-+ goto finished;
-+ }
- if (encrypt) {
-- ctx = &E_ctx;
- keystr = E_keystr;
- } else {
-- ctx = &D_ctx;
- keystr = D_keystr;
- }
-
-@@ -797,7 +804,6 @@ static void enc_xfer(int sock_fr, int so
- if (whoops) {
- fprintf(stderr, "%s: %s - WARNING: MSRC4 mode and IGNORING random salt\n", prog, encstr);
- fprintf(stderr, "%s: %s - WARNING: and initialization vector!!\n", prog, encstr);
-- EVP_CIPHER_CTX_init(ctx);
- if (pw_in) {
- /* for pw=xxxx a md5 hash is used */
- EVP_BytesToKey(Cipher, Digest, NULL, (unsigned char *) keydata,
-@@ -816,7 +822,6 @@ static void enc_xfer(int sock_fr, int so
-
- EVP_BytesToKey(Cipher, Digest, NULL, (unsigned char *) keydata,
- keydata_len, 1, keystr, ivec);
-- EVP_CIPHER_CTX_init(ctx);
- EVP_CipherInit_ex(ctx, Cipher, NULL, keystr, ivec,
- encrypt);
- }
-@@ -836,9 +841,9 @@ static void enc_xfer(int sock_fr, int so
- in_salt = salt;
- }
-
-- if (ivec_size < Cipher->iv_len && !securevnc) {
-+ if (ivec_size < EVP_CIPHER_iv_length(Cipher) && !securevnc) {
- fprintf(stderr, "%s: %s - WARNING: short IV %d < %d\n",
-- prog, encstr, ivec_size, Cipher->iv_len);
-+ prog, encstr, ivec_size, EVP_CIPHER_iv_length(Cipher));
- }
-
- /* make the hashed value and place in keystr */
-@@ -877,9 +882,6 @@ static void enc_xfer(int sock_fr, int so
- }
-
-
-- /* initialize the context */
-- EVP_CIPHER_CTX_init(ctx);
--
-
- /* set the cipher & initialize */
-
-@@ -986,6 +988,7 @@ static void enc_xfer(int sock_fr, int so
- /* transfer done (viewer exited or some error) */
- finished:
-
-+ if (ctx) EVP_CIPHER_CTX_free(ctx);
- fprintf(stderr, "\n%s: %s - close sock_to\n", prog, encstr);
- close(sock_to);
-
-@@ -1060,14 +1063,14 @@ static int securevnc_server_rsa_save_dia
- }
-
- static char *rsa_md5_sum(unsigned char* rsabuf) {
-- EVP_MD_CTX md;
-+ EVP_MD_CTX *md = EVP_MD_CTX_create();
- char digest[EVP_MAX_MD_SIZE], tmp[16];
- char md5str[EVP_MAX_MD_SIZE * 8];
- unsigned int i, size = 0;
-
-- EVP_DigestInit(&md, EVP_md5());
-- EVP_DigestUpdate(&md, rsabuf, SECUREVNC_RSA_PUBKEY_SIZE);
-- EVP_DigestFinal(&md, (unsigned char *)digest, &size);
-+ EVP_DigestInit(md, EVP_md5());
-+ EVP_DigestUpdate(md, rsabuf, SECUREVNC_RSA_PUBKEY_SIZE);
-+ EVP_DigestFinal(md, (unsigned char *)digest, &size);
-
- memset(md5str, 0, sizeof(md5str));
- for (i=0; i < size; i++) {
-@@ -1075,6 +1078,7 @@ static char *rsa_md5_sum(unsigned char*
- sprintf(tmp, "%02x", (int) uc);
- strcat(md5str, tmp);
- }
-+ EVP_MD_CTX_destroy(md);
- return strdup(md5str);
- }
-
-@@ -1184,7 +1188,7 @@ static void sslexit(char *msg) {
-
- static void securevnc_setup(int conn1, int conn2) {
- RSA *rsa = NULL;
-- EVP_CIPHER_CTX init_ctx;
-+ EVP_CIPHER_CTX *init_ctx = EVP_CIPHER_CTX_new();
- unsigned char keystr[EVP_MAX_KEY_LENGTH];
- unsigned char *rsabuf, *rsasav;
- unsigned char *encrypted_keybuf;
-@@ -1203,6 +1207,8 @@ static void securevnc_setup(int conn1, i
-
- ERR_load_crypto_strings();
-
-+ if (!init_ctx) sslexit("securevnc_setup: EVP_CIPHER_CTX_new() failed");
-+
- /* alloc and read from server the 270 comprising the rsa public key: */
- rsabuf = (unsigned char *) calloc(SECUREVNC_RSA_PUBKEY_SIZE, 1);
- rsasav = (unsigned char *) calloc(SECUREVNC_RSA_PUBKEY_SIZE, 1);
-@@ -1323,8 +1329,7 @@ static void securevnc_setup(int conn1, i
- /*
- * Back to the work involving the tmp obscuring key:
- */
-- EVP_CIPHER_CTX_init(&init_ctx);
-- rc = EVP_CipherInit_ex(&init_ctx, EVP_rc4(), NULL, initkey, NULL, 1);
-+ rc = EVP_CipherInit_ex(init_ctx, EVP_rc4(), NULL, initkey, NULL, 1);
- if (rc == 0) {
- sslexit("securevnc_setup: EVP_CipherInit_ex(init_ctx) failed");
- }
-@@ -1340,13 +1345,13 @@ static void securevnc_setup(int conn1, i
- /* decode with the tmp key */
- if (n > 0) {
- memset(to_viewer, 0, sizeof(to_viewer));
-- if (EVP_CipherUpdate(&init_ctx, to_viewer, &len, buf, n) == 0) {
-+ if (EVP_CipherUpdate(init_ctx, to_viewer, &len, buf, n) == 0) {
- sslexit("securevnc_setup: EVP_CipherUpdate(init_ctx) failed");
- exit(1);
- }
- to_viewer_len = len;
- }
-- EVP_CIPHER_CTX_cleanup(&init_ctx);
-+ EVP_CIPHER_CTX_free(init_ctx);
- free(initkey);
-
- /* print what we would send to the viewer (sent below): */
-@@ -1407,7 +1412,7 @@ static void securevnc_setup(int conn1, i
-
- if (client_auth_req && client_auth) {
- RSA *client_rsa = load_client_auth(client_auth);
-- EVP_MD_CTX dctx;
-+ EVP_MD_CTX *dctx = EVP_MD_CTX_create();
- unsigned char digest[EVP_MAX_MD_SIZE], *signature;
- unsigned int ndig = 0, nsig = 0;
-
-@@ -1421,8 +1426,8 @@ static void securevnc_setup(int conn1, i
- exit(1);
- }
-
-- EVP_DigestInit(&dctx, EVP_sha1());
-- EVP_DigestUpdate(&dctx, keystr, SECUREVNC_KEY_SIZE);
-+ EVP_DigestInit(dctx, EVP_sha1());
-+ EVP_DigestUpdate(dctx, keystr, SECUREVNC_KEY_SIZE);
- /*
- * Without something like the following MITM is still possible.
- * This is because the MITM knows keystr and can use it with
-@@ -1433,7 +1438,7 @@ static void securevnc_setup(int conn1, i
- * he doesn't have Viewer_ClientAuth.pkey.
- */
- if (0) {
-- EVP_DigestUpdate(&dctx, rsasav, SECUREVNC_RSA_PUBKEY_SIZE);
-+ EVP_DigestUpdate(dctx, rsasav, SECUREVNC_RSA_PUBKEY_SIZE);
- if (!keystore_verified) {
- fprintf(stderr, "securevnc_setup:\n");
- fprintf(stderr, "securevnc_setup: Warning: even *WITH* Client Authentication in SecureVNC,\n");
-@@ -1456,7 +1461,8 @@ static void securevnc_setup(int conn1, i
- fprintf(stderr, "securevnc_setup:\n");
- }
- }
-- EVP_DigestFinal(&dctx, (unsigned char *)digest, &ndig);
-+ EVP_DigestFinal(dctx, (unsigned char *)digest, &ndig);
-+ EVP_MD_CTX_destroy(dctx);
-
- signature = (unsigned char *) calloc(RSA_size(client_rsa), 1);
- RSA_sign(NID_sha1, digest, ndig, signature, &nsig, client_rsa);
diff --git a/net/ssvnc/files/patch-wr__tool b/net/ssvnc/files/patch-wr__tool
deleted file mode 100644
index 9c2f60f3eed4..000000000000
--- a/net/ssvnc/files/patch-wr__tool
+++ /dev/null
@@ -1,8 +0,0 @@
---- wr_tool.orig 2008-08-29 12:58:03 UTC
-+++ wr_tool
-@@ -6,4 +6,4 @@ cat > $wr <<END
- UNAME=.; export UNAME
- exec $cmd "\$@"
- END
--chmod 755 $wr
-+chmod 555 $wr
diff --git a/net/ssvnc/pkg-descr b/net/ssvnc/pkg-descr
deleted file mode 100644
index c65dc05027f9..000000000000
--- a/net/ssvnc/pkg-descr
+++ /dev/null
@@ -1,15 +0,0 @@
-The Enhanced TightVNC Viewer package started as a project to add some patches
-to the long neglected Unix TightVNC Viewer. However, now the front-end GUI and
-wrapper scripts features dwarf the Unix TightVNC Viewer patches (see the lists
-below).
-
-It adds a GUI for Windows, Mac OS X, and Unix that automatically starts up
-STUNNEL SSL tunnel for SSL or SSH connections to x11vnc, and then launches the
-TightVNC Viewer to use the tunnel. It also enables SSL encrypted VNC
-connections to any other VNC Server running an SSL tunnel, such as STUNNEL, at
-their end. It can be used to perform SSH tunnelled connections to any VNC
-Server as well. The tool has many additional features (see below for a list).
-
-The short name for this project is "ssvnc" for SSL/SSH VNC Viewer.
-
-WWW: http://www.karlrunge.com/x11vnc/ssvnc.html
diff --git a/net/ssvnc/pkg-message b/net/ssvnc/pkg-message
deleted file mode 100644
index 1f69c0daf52b..000000000000
--- a/net/ssvnc/pkg-message
+++ /dev/null
@@ -1,12 +0,0 @@
-[
-{ type: install
- message: <<EOM
-SSVNC has been installed, and the following commands are available:
-
-ssvncviewer - SSVNC viewer
-ssvnc-ts - Wrapper script for Terminal Services mode
-ssvnc-stunnel - Wrapper script for SSVNC + stunnel (SSH/SSL tunnels)
-ssvnc-gui - GUI for the previous commands
-EOM
-}
-]
diff --git a/net/ssvnc/pkg-plist b/net/ssvnc/pkg-plist
deleted file mode 100644
index 6e8ed7c7d897..000000000000
--- a/net/ssvnc/pkg-plist
+++ /dev/null
@@ -1,21 +0,0 @@
-bin/ssvnc-gui
-bin/ssvnc-stunnel
-bin/ssvnc-ts
-bin/ssvncviewer
-lib/ssvnc/lim_accept.so
-lib/ssvnc/ssvnc
-lib/ssvnc/ssvnc_cmd
-lib/ssvnc/tsvnc
-lib/ssvnc/ultravnc_dsm_helper
-lib/ssvnc/unwrap.so
-lib/ssvnc/util/ss_vncviewer
-lib/ssvnc/util/ssvnc.tcl
-%%ULTRAFTP%%lib/ssvnc/util/ultraftp.jar
-lib/ssvnc/vncstorepw
-lib/ssvnc/vncviewer
-man/man1/ssvnc-gui.1.gz
-man/man1/ssvnc.1.gz
-man/man1/ssvncviewer.1.gz
-share/applications/ssvnc.desktop
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/stunnel-server.conf