aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/arping/Makefile7
-rw-r--r--net/c3270/Makefile3
-rw-r--r--net/dante/Makefile4
-rw-r--r--net/freeradius2/Makefile8
-rw-r--r--net/freeradius3/Makefile10
-rw-r--r--net/freeswitch-core-devel/Makefile7
-rw-r--r--net/freeswitch-core-devel/files/patch-build-modmake.rules.in10
-rw-r--r--net/gutenfetch/Makefile4
-rw-r--r--net/isc-dhcp41-server/Makefile6
-rw-r--r--net/isc-dhcp42-server/Makefile5
-rw-r--r--net/isc-dhcp43-server/Makefile5
-rw-r--r--net/ldap2dns/Makefile6
-rw-r--r--net/nast/Makefile4
-rw-r--r--net/nast/files/patch-configure13
-rw-r--r--net/netdude/Makefile2
-rw-r--r--net/ntopng/Makefile1
-rw-r--r--net/ntopng/files/patch-configure7
-rw-r--r--net/openldap24-server/Makefile8
-rw-r--r--net/rtpproxy/Makefile3
-rw-r--r--net/siproxd/Makefile5
-rw-r--r--net/siproxd/files/patch-aclocal.m411
-rw-r--r--net/siproxd/files/patch-configure39
-rw-r--r--net/siproxd/files/patch-libltdl_aclocal.m411
-rw-r--r--net/siproxd/files/patch-libltdl_configure38
-rw-r--r--net/siproxd/pkg-plist5
-rw-r--r--net/tac_plus4/Makefile4
-rw-r--r--net/traff/Makefile14
-rw-r--r--net/trafshow3/Makefile2
-rw-r--r--net/trickle/Makefile2
-rw-r--r--net/tsclient/Makefile3
-rw-r--r--net/uplog/Makefile2
-rw-r--r--net/wire/Makefile4
-rw-r--r--net/wireshark/Makefile7
33 files changed, 79 insertions, 181 deletions
diff --git a/net/arping/Makefile b/net/arping/Makefile
index c8df0dac24a5..94fdd5a4cf11 100644
--- a/net/arping/Makefile
+++ b/net/arping/Makefile
@@ -14,10 +14,9 @@ LICENSE= GPLv2
LIB_DEPENDS= net:${PORTSDIR}/net/libnet
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="`${LIBNET_CONFIG} --libs` -lpcap"
-CFLAGS+= `${LIBNET_CONFIG} --defines`
-CPPFLAGS+= -I${LOCALBASE}/include `${LIBNET_CONFIG} --cflags`
-LDFLAGS+= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include \
+ `${LIBNET_CONFIG} --cflags` `${LIBNET_CONFIG} --defines`
+LIBS+= -L${LOCALBASE}/lib `${LIBNET_CONFIG} --libs` -lpcap
LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
diff --git a/net/c3270/Makefile b/net/c3270/Makefile
index 639a6e1e0113..76c7ab896e9b 100644
--- a/net/c3270/Makefile
+++ b/net/c3270/Makefile
@@ -18,9 +18,8 @@ CONFLICTS= x3270-*
GNU_CONFIGURE= yes
USES= iconv readline gmake
USE_OPENSSL= yes
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib
MAN1= c3270.1 \
x3270if.1 \
diff --git a/net/dante/Makefile b/net/dante/Makefile
index 3786f39675f8..29249b74d0d8 100644
--- a/net/dante/Makefile
+++ b/net/dante/Makefile
@@ -17,8 +17,8 @@ CONFLICTS= socks5-[0-9]*
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-socks-conf=${PREFIX}/etc/socks.conf \
--with-sockd-conf=${PREFIX}/etc/sockd.conf
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
USE_LDCONFIG= yes
diff --git a/net/freeradius2/Makefile b/net/freeradius2/Makefile
index 201fb931f033..294cabfce348 100644
--- a/net/freeradius2/Makefile
+++ b/net/freeradius2/Makefile
@@ -30,8 +30,9 @@ USES= gmake tar:bzip2 shebangfix
SHEBANG_FILES= scripts/radsqlrelay src/modules/rlm_counter/rad_counter
USE_AUTOTOOLS= libltdl libtool autoconf
USE_OPENSSL= yes
-MAKE_ARGS+= LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+CFLAGS+= ${CPPFLAGS}
+LIBS+= -L${LOCALBASE}/lib
MAKE_JOBS_UNSAFE= yes
PLIST_SUB= PORTVERSION=${DISTVERSION} LIBVER=0${PORTVERSION:C/\./0/g}
@@ -345,9 +346,6 @@ post-patch:
${WRKSRC}/scripts/Makefile
pre-configure:
-# Replace -pthread with ${PTHREAD_LIBS} in configure(.in) files
- @${FIND} -E ${WRKSRC} -regex '.*/configure(\.in)?$$' -exec \
- ${REINPLACE_CMD} -e "s:-pthread:${PTHREAD_LIBS}:g" {} \;
# Force the rebuild of some configures from configure.in, as we're patching
# the configure.in
# NOTE: ${WRKSRC}/configure is rebuilt automatically once autoconf is
diff --git a/net/freeradius3/Makefile b/net/freeradius3/Makefile
index e7d9a3597668..0e6b56f994e1 100644
--- a/net/freeradius3/Makefile
+++ b/net/freeradius3/Makefile
@@ -33,10 +33,11 @@ USES= gmake tar:bzip2 shebangfix
SHEBANG_FILES= src/modules/rlm_counter/rad_counter scripts/sql/radsqlrelay
GNU_CONFIGURE= yes
USE_OPENSSL= yes
-MAKE_ARGS+= LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
# Prevent /root/.rnd leftover
MAKE_ARGS+= HOME=/dev/null
-CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+CFLAGS+= ${CPPFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib
MAKE_JOBS_SAFE= yes
PLIST_SUB= PORTVERSION=${DISTVERSION} LIBVER=0${PORTVERSION:C/\./0/g}
@@ -370,11 +371,6 @@ post-patch:
@${RM} -fr ${WRKSRC}/src/modules/rlm_ruby/
.endif
-pre-configure:
-# Replace -pthread with ${PTHREAD_LIBS} in configure(.in) files
- @${FIND} -E ${WRKSRC} -regex '.*/configure(\.in)?$$' -exec \
- ${REINPLACE_CMD} -e "s:-pthread:${PTHREAD_LIBS}:g" {} \;
-
post-build:
@${FIND} ${WRKSRC}/build/lib -type f -name '*.so' -exec ${STRIP_CMD} {} \;
@${FIND} ${WRKSRC}/build/bin -type f -exec ${STRIP_CMD} {} \;
diff --git a/net/freeswitch-core-devel/Makefile b/net/freeswitch-core-devel/Makefile
index 8cd464a5755e..bd25da82b657 100644
--- a/net/freeswitch-core-devel/Makefile
+++ b/net/freeswitch-core-devel/Makefile
@@ -49,8 +49,8 @@ SUB_FILES= pkg-install
USE_RC_SUBR= freeswitch
HAS_CONFIGURE= yes
USE_LDCONFIG= yes
+CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-INCLUDES+= -I${LOCALBASE}/include
CONFIGURE_ARGS+=--prefix=${PREFIX} \
--bindir=${PREFIX}/bin \
--datadir=${VARBASE}/db/${PORTNAME} \
@@ -71,11 +71,6 @@ CONFIGURE_ARGS+=--prefix=${PREFIX} \
--with-ogg-includes=${LOCALBASE}/include
MAKE_JOBS_UNSAFE= yes
-CONFIGURE_ENV+= INCLUDES="${INCLUDES}" \
- PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
- PTHREAD_LIBS="${PTHREAD_LIBS}"
-CPPFLAGS+= -I${LOCALBASE}/include
-
FREESWITCH_USER?= freeswitch
FREESWITCH_GROUP?= ${FREESWITCH_USER}
FREESWITCH_UID?= 610
diff --git a/net/freeswitch-core-devel/files/patch-build-modmake.rules.in b/net/freeswitch-core-devel/files/patch-build-modmake.rules.in
new file mode 100644
index 000000000000..9157b9688ef7
--- /dev/null
+++ b/net/freeswitch-core-devel/files/patch-build-modmake.rules.in
@@ -0,0 +1,10 @@
+--- build/modmake.rules.in.orig
++++ build/modmake.rules.in
+@@ -42,6 +42,7 @@
+ OPENSSL_LIBS=@openssl_LIBS@
+ OPENSSL_CFLAGS=@openssl_CFLAGS@
+
++unexport LIBS
+ LIBS=$(switch_builddir)/libfreeswitch.la
+ DEFS=@DEFS@
+
diff --git a/net/gutenfetch/Makefile b/net/gutenfetch/Makefile
index ae4702eb09ce..8fd8c08cafdf 100644
--- a/net/gutenfetch/Makefile
+++ b/net/gutenfetch/Makefile
@@ -12,8 +12,8 @@ COMMENT= Fetch listings and books from Project Gutenberg
LIB_DEPENDS= gutenfetch:${PORTSDIR}/devel/libgutenfetch
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
USES= gmake tar:bzip2
MAN1= gutenfetch.1
diff --git a/net/isc-dhcp41-server/Makefile b/net/isc-dhcp41-server/Makefile
index 3e7a6a6afb40..c6690f36633b 100644
--- a/net/isc-dhcp41-server/Makefile
+++ b/net/isc-dhcp41-server/Makefile
@@ -100,9 +100,9 @@ USES+= perl5
USE_PERL5= run
USE_OPENLDAP= yes
USE_AUTOTOOLS= aclocal libtoolize autoconf autoheader automake
-LIBTOOLIZE_ARG= --copy --force
AUTOMAKE_ARGS= --foreign --add-missing --copy
-CFLAGS+= -I${PREFIX}/include -L${PREFIX}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS+= --with-ldap
.else
PLIST_SUB+= LDAP="@comment "
@@ -112,7 +112,7 @@ PLIST_SUB+= LDAP="@comment "
.if ${PORT_OPTIONS:MLDAP_SSL} && ${PORT_OPTIONS:MLDAP}
USE_OPENSSL= yes
CONFIGURE_ARGS+= --with-ldapcrypto
-CONFIGURE_ENV+= LIBS="-lssl"
+LIBS+= -lssl
# hack to get bsd.openssl.mk included at this late state
.include "${PORTSDIR}/Mk/bsd.openssl.mk"
.endif
diff --git a/net/isc-dhcp42-server/Makefile b/net/isc-dhcp42-server/Makefile
index 3fc49112a784..239da3812e33 100644
--- a/net/isc-dhcp42-server/Makefile
+++ b/net/isc-dhcp42-server/Makefile
@@ -102,7 +102,8 @@ USE_OPENLDAP= yes
LDAP_SCRIPT= ${WRKSRC}/contrib/ldap/dhcpd-conf-to-ldap
LDAP_SCHEMA= ${WRKSRC}/contrib/ldap/dhcp.schema
LDAP_README= ${WRKSRC}/contrib/ldap/README.ldap
-CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
PORTDOCS+= README.ldap
PLIST_SUB+= SCHEMA_DIR="${SCHEMA_DIR:S,^${PREFIX}/,,}" LDAP=""
USES+= shebangfix
@@ -114,7 +115,7 @@ PLIST_SUB+= LDAP="@comment "
.if ${PORT_OPTIONS:MLDAP_SSL} && ${PORT_OPTIONS:MLDAP}
USE_OPENSSL= yes
CONFIGURE_ARGS+=--with-ldapcrypto
-CONFIGURE_ENV+= LIBS="-lssl"
+LIBS+= -lssl
.include "${PORTSDIR}/Mk/bsd.openssl.mk"
.endif
diff --git a/net/isc-dhcp43-server/Makefile b/net/isc-dhcp43-server/Makefile
index bf1c558bac2a..40ea27a4b2a4 100644
--- a/net/isc-dhcp43-server/Makefile
+++ b/net/isc-dhcp43-server/Makefile
@@ -102,7 +102,8 @@ USE_OPENLDAP= yes
LDAP_SCRIPT= ${WRKSRC}/contrib/ldap/dhcpd-conf-to-ldap
LDAP_SCHEMA= ${WRKSRC}/contrib/ldap/dhcp.schema
LDAP_README= ${WRKSRC}/contrib/ldap/README.ldap
-CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
PORTDOCS+= README.ldap
PLIST_SUB+= SCHEMA_DIR="${SCHEMA_DIR:S,^${PREFIX}/,,}" LDAP=""
USES+= shebangfix
@@ -114,7 +115,7 @@ PLIST_SUB+= LDAP="@comment "
.if ${PORT_OPTIONS:MLDAP_SSL} && ${PORT_OPTIONS:MLDAP}
USE_OPENSSL= yes
CONFIGURE_ARGS+=--with-ldapcrypto
-CONFIGURE_ENV+= LIBS="-lssl"
+LIBS+= -lssl
.include "${PORTSDIR}/Mk/bsd.openssl.mk"
.endif
diff --git a/net/ldap2dns/Makefile b/net/ldap2dns/Makefile
index e3935a084087..24dfca4be4a8 100644
--- a/net/ldap2dns/Makefile
+++ b/net/ldap2dns/Makefile
@@ -24,7 +24,7 @@ USES= gmake perl5 shebangfix
SHEBANG_FILES= scripts/*.pl
USE_PERL5= run
USE_OPENLDAP= yes
-
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" LD="${CC}" LDFLAGS="${LDFLAGS}"
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -41,9 +41,7 @@ PLIST_DIRS= %%DATADIR%%
OPTIONS_DEFINE= DOCS
post-patch:
- @${REINPLACE_CMD} -e \
- 's|^CC=|CC?=| ; \
- s|^LD=.*|LD=$$(CC)|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} 's|?=|=|' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e \
's|"/etc|"${PREFIX}/etc|' ${WRKSRC}/ldap2dns.c
@${REINPLACE_CMD} -e \
diff --git a/net/nast/Makefile b/net/nast/Makefile
index a100d07b0c30..8dd40b8c744e 100644
--- a/net/nast/Makefile
+++ b/net/nast/Makefile
@@ -17,7 +17,6 @@ LIB_DEPENDS= net:${PORTSDIR}/net/libnet
USES= gmake
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="${PTHREAD_LIBS}"
PLIST_FILES= bin/nast man/man8/nast.8.gz
@@ -27,8 +26,7 @@ LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
post-patch:
@${REINPLACE_CMD} -e \
- 's|CFLAGS="-Wall -O2 -pthread"||g; \
- s|libnet-config|${LIBNET_CONFIG}|; \
+ 's|libnet-config|${LIBNET_CONFIG}|; \
s|-lnet|`${LIBNET_CONFIG} --libs`|' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
diff --git a/net/nast/files/patch-configure b/net/nast/files/patch-configure
index a2fd431efbcb..b8605f35fbc9 100644
--- a/net/nast/files/patch-configure
+++ b/net/nast/files/patch-configure
@@ -50,8 +50,17 @@
-fi
-
-fi
-+CPPFLAGS="`libnet-config --cflags`"
-+LDFLAGS="`libnet-config --libs`"
++CPPFLAGS="${CPPFLAGS} `libnet-config --cflags`"
++LDFLAGS="${LDFLAGS} `libnet-config --libs`"
if test "$filechk" = "no"; then { { echo "$as_me:$LINENO: error:
+@@ -3046,7 +3002,7 @@
+ CFLAGS="-Wall -O2"
+ ;;
+ *bsd*)
+- CFLAGS="-Wall -O2 -pthread"
++ CFLAGS="${CFLAGS} -Wall -pthread"
+ ;;
+ esac
+
diff --git a/net/netdude/Makefile b/net/netdude/Makefile
index 9e4b0ea4b283..87d90222e0d5 100644
--- a/net/netdude/Makefile
+++ b/net/netdude/Makefile
@@ -16,7 +16,7 @@ USES= gettext iconv libtool gmake
USE_AUTOTOOLS= libltdl
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-gtk-doc --with-html-dir=${DOCSDIR}
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -lltdl"
+LIBS+= -L${LOCALBASE}/lib -lltdl
USE_GNOME= glib12 gtk12
INSTALL_TARGET= install-strip
diff --git a/net/ntopng/Makefile b/net/ntopng/Makefile
index d1c432f2b62a..28483bb1e2b1 100644
--- a/net/ntopng/Makefile
+++ b/net/ntopng/Makefile
@@ -70,6 +70,7 @@ post-patch:
@${REINPLACE_CMD} -e "s#%%INSTALL_SCRIPT%%#${INSTALL_SCRIPT}#" ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e "s#%%INSTALL_DATA%%#${INSTALL_DATA}#" ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e "s#%%G++%%#${CXX}#" ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e "s#LIBS#LIBRARIES#" ${WRKSRC}/Makefile.in
pre-build:
cd ${WRKSRC}/third-party/json-c && ${MAKE} clean && ./configure && ${MAKE}
diff --git a/net/ntopng/files/patch-configure b/net/ntopng/files/patch-configure
index 3841dc597310..73c7b4962cb9 100644
--- a/net/ntopng/files/patch-configure
+++ b/net/ntopng/files/patch-configure
@@ -8,12 +8,9 @@
SVN_DATE
GMAKE
SQLITE_LIB
-@@ -2953,15 +2952,15 @@
- NTOPNG_VERS=`cat ./configure.in | head -1 | grep '_INIT' | cut -d " " -f 2|cut -d ')' -f 1`
- CFLAGS="${CFLAGS} -I/usr/local/include -I/opt/local/include"
+@@ -2955,13 +2954,13 @@
CPPFLAGS="${CPPFLAGS} -I/usr/local/include -I/opt/local/include"
--LDFLAGS="${LDFLAGS} -L/usr/local/lib -L/opt/local/lib"
-+LDFLAGS="${LDFLAGS}-L/usr/local/lib -L/opt/local/lib"
+ LDFLAGS="${LDFLAGS} -L/usr/local/lib -L/opt/local/lib"
-SVN_RELEASE=`svn info . | grep "^Revision"|cut -d " " -f 2`
+SVN_RELEASE="6939"
diff --git a/net/openldap24-server/Makefile b/net/openldap24-server/Makefile
index 779246a10809..5568d3ffb87e 100644
--- a/net/openldap24-server/Makefile
+++ b/net/openldap24-server/Makefile
@@ -486,12 +486,8 @@ CONFIGURE_ARGS+= --enable-wrappers
CPPFLAGS+= -DLDAP_CONNECTIONLESS
.endif
-CPPFLAGS+= ${PTHREAD_CFLAGS} \
- -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-#LIBS+= ${PTHREAD_LIBS}
-
-CONFIGURE_ENV+= LIBS="${LIBS}"
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
.if defined(CLIENT_ONLY)
.else
diff --git a/net/rtpproxy/Makefile b/net/rtpproxy/Makefile
index bf3d02d4835c..e76f9d3c848d 100644
--- a/net/rtpproxy/Makefile
+++ b/net/rtpproxy/Makefile
@@ -13,9 +13,8 @@ COMMENT= High-performance RTP proxy server for the SIP Express Router (SER)
LIB_DEPENDS= gsm.1:${PORTSDIR}/audio/gsm
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= LIBS=-L${LOCALBASE}/lib
CPPFLAGS+= -I${LOCALBASE}/include
-#CONFIGURE_ARGS= --mandir=${LOCALBASE}/man
+LIBS+= -L${LOCALBASE}/lib
MAN8= rtpproxy.8
USERS= ${PORTNAME}
diff --git a/net/siproxd/Makefile b/net/siproxd/Makefile
index 39e527fb8754..160564cdc5f1 100644
--- a/net/siproxd/Makefile
+++ b/net/siproxd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= siproxd
PORTVERSION= 0.7.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net
MASTER_SITES= SF
@@ -14,9 +14,10 @@ LICENSE= GPLv2
LIB_DEPENDS= libosip2.so:${PORTSDIR}/net/libosip
+USES= libtool:keepla
USE_RC_SUBR= siproxd
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-doc --with-libosip-prefix=${PREFIX}
+CONFIGURE_ARGS= --disable-doc --disable-static --with-libosip-prefix=${PREFIX}
PORTDOCS1= AUTHORS ChangeLog README RELNOTES
PORTDOCS2= FAQ KNOWN_BUGS RFC3261_compliance.txt \
diff --git a/net/siproxd/files/patch-aclocal.m4 b/net/siproxd/files/patch-aclocal.m4
deleted file mode 100644
index e430e1f88656..000000000000
--- a/net/siproxd/files/patch-aclocal.m4
+++ /dev/null
@@ -1,11 +0,0 @@
---- aclocal.m4.orig 2008-03-09 14:35:51.000000000 +0100
-+++ aclocal.m4 2008-09-23 11:23:56.000000000 +0200
-@@ -1276,7 +1276,7 @@
- ;;
-
- freebsd*)
-- objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
-+ objformat=elf
- version_type=freebsd-$objformat
- case $version_type in
- freebsd-elf*)
diff --git a/net/siproxd/files/patch-configure b/net/siproxd/files/patch-configure
index 5da8af5078ed..9e0453f6515b 100644
--- a/net/siproxd/files/patch-configure
+++ b/net/siproxd/files/patch-configure
@@ -1,38 +1,13 @@
--- configure.orig 2008-03-09 14:35:57.000000000 +0100
+++ configure 2008-09-23 11:25:19.000000000 +0200
-@@ -8063,7 +8063,7 @@
- ;;
+@@ -23988,7 +23988,9 @@
- freebsd*)
-- objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
-+ objformat=elf
- version_type=freebsd-$objformat
- case $version_type in
- freebsd-elf*)
-@@ -11733,7 +11733,7 @@
- ;;
- freebsd*)
-- objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
-+ objformat=elf
- version_type=freebsd-$objformat
- case $version_type in
- freebsd-elf*)
-@@ -14867,7 +14867,7 @@
- ;;
- freebsd*)
-- objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
-+ objformat=elf
- version_type=freebsd-$objformat
- case $version_type in
- freebsd-elf*)
-@@ -17197,7 +17197,7 @@
- ;;
+-LIBS="$LIBS $FWLIBS"
++tmp_LIBS="${LIBS}"
++unset LIBS
++LIBS="${tmp_LIBS} $FWLIBS"
+
+
- freebsd*)
-- objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
-+ objformat=elf
- version_type=freebsd-$objformat
- case $version_type in
- freebsd-elf*)
diff --git a/net/siproxd/files/patch-libltdl_aclocal.m4 b/net/siproxd/files/patch-libltdl_aclocal.m4
deleted file mode 100644
index bb986360da92..000000000000
--- a/net/siproxd/files/patch-libltdl_aclocal.m4
+++ /dev/null
@@ -1,11 +0,0 @@
---- libltdl/aclocal.m4.orig 2008-02-02 18:16:08.000000000 +0100
-+++ libltdl/aclocal.m4 2008-09-23 11:26:47.000000000 +0200
-@@ -1276,7 +1276,7 @@
- ;;
-
- freebsd*)
-- objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
-+ objformat=elf
- version_type=freebsd-$objformat
- case $version_type in
- freebsd-elf*)
diff --git a/net/siproxd/files/patch-libltdl_configure b/net/siproxd/files/patch-libltdl_configure
deleted file mode 100644
index d11e5372bf6d..000000000000
--- a/net/siproxd/files/patch-libltdl_configure
+++ /dev/null
@@ -1,38 +0,0 @@
---- libltdl/configure.orig 2008-02-02 18:16:08.000000000 +0100
-+++ libltdl/configure 2008-09-23 11:28:19.000000000 +0200
-@@ -7954,7 +7954,7 @@
- ;;
-
- freebsd*)
-- objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
-+ objformat=elf
- version_type=freebsd-$objformat
- case $version_type in
- freebsd-elf*)
-@@ -11518,7 +11518,7 @@
- ;;
-
- freebsd*)
-- objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
-+ objformat=elf
- version_type=freebsd-$objformat
- case $version_type in
- freebsd-elf*)
-@@ -14519,7 +14519,7 @@
- ;;
-
- freebsd*)
-- objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
-+ objformat=elf
- version_type=freebsd-$objformat
- case $version_type in
- freebsd-elf*)
-@@ -16804,7 +16804,7 @@
- ;;
-
- freebsd*)
-- objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
-+ objformat=elf
- version_type=freebsd-$objformat
- case $version_type in
- freebsd-elf*)
diff --git a/net/siproxd/pkg-plist b/net/siproxd/pkg-plist
index 009185de2695..3d85b0842e5b 100644
--- a/net/siproxd/pkg-plist
+++ b/net/siproxd/pkg-plist
@@ -1,18 +1,13 @@
etc/siproxd.conf.example
etc/siproxd_passwd.cfg
-lib/siproxd/plugin_defaulttarget.a
lib/siproxd/plugin_defaulttarget.la
lib/siproxd/plugin_defaulttarget.so
-lib/siproxd/plugin_demo.a
lib/siproxd/plugin_demo.la
lib/siproxd/plugin_demo.so
-lib/siproxd/plugin_fix_bogus_via.a
lib/siproxd/plugin_fix_bogus_via.la
lib/siproxd/plugin_fix_bogus_via.so
-lib/siproxd/plugin_logcall.a
lib/siproxd/plugin_logcall.la
lib/siproxd/plugin_logcall.so
-lib/siproxd/plugin_shortdial.a
lib/siproxd/plugin_shortdial.la
lib/siproxd/plugin_shortdial.so
sbin/siproxd
diff --git a/net/tac_plus4/Makefile b/net/tac_plus4/Makefile
index 137d80d92dd6..dc5dfc093954 100644
--- a/net/tac_plus4/Makefile
+++ b/net/tac_plus4/Makefile
@@ -36,8 +36,8 @@ CONFIGURE_ARGS+= --without-skey
.endif
.if exists(/usr/include/opie.h) && !defined(WITHOUT_OPIE)
-CFLAGS+= -DOPIE
-CONFIGURE_ENV+= LIBS="-lopie -lmd"
+CPPFLAGS+= -DOPIE
+LIBS+= -lopie -lmd
.endif
post-patch:
diff --git a/net/traff/Makefile b/net/traff/Makefile
index 87964d41b194..82572700688d 100644
--- a/net/traff/Makefile
+++ b/net/traff/Makefile
@@ -15,9 +15,7 @@ USE_RC_SUBR= traff
USES= gmake
GNU_CONFIGURE= yes
-CFLAGS+= ${PTHREAD_CFLAGS} -L${LOCALBASE}/lib
-LFLAGS= ${PTHREAD_LIBS}
-CONFIGURE_ENV+= "LIBS=-largp"
+LIBS+= -L${LOCALBASE}/lib -largp
OPTIONS_DEFINE= MYSQL PGSQL
OPTIONS_DEFAULT= MYSQL
@@ -27,20 +25,18 @@ NO_STAGE= yes
.if ${PORT_OPTIONS:MMYSQL}
USE_MYSQL= yes
-CFLAGS+= -DwithMYSQL -I${LOCALBASE}/include -L${LOCALBASE}/lib/mysql
-LFLAGS+= -L${LOCALBASE}/lib/mysql -lmysqlclient_r
+CPPFLAGS+= -DwithMYSQL -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib/mysql -lmysqlclient_r
CONFIGURE_ARGS+=--enable-mysql
.endif
.if ${PORT_OPTIONS:MPGSQL}
USE_PGSQL= yes
-CFLAGS+= -DwithPGSQL -I${LOCALBASE}/include
-LFLAGS+= -L${LOCALBASE}/lib -lpq
+CPPFLAGS+= -DwithPGSQL -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib -lpq
CONFIGURE_ARGS+=--enable-postgresql
.endif
-MAKE_ARGS+= EXTRA_LIBS="${LFLAGS}"
-
post-configure:
@${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" \
${WRKSRC}/Makefile ${WRKSRC}/traff.c
diff --git a/net/trafshow3/Makefile b/net/trafshow3/Makefile
index e7768e9bf6db..ec81a4012b10 100644
--- a/net/trafshow3/Makefile
+++ b/net/trafshow3/Makefile
@@ -22,8 +22,8 @@ LIB_DEPENDS= slang.2:${PORTSDIR}/devel/libslang2
.endif
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
ALL_TARGET= trafshow
post-patch:
diff --git a/net/trickle/Makefile b/net/trickle/Makefile
index 0f642e36f57a..282470ab9cdf 100644
--- a/net/trickle/Makefile
+++ b/net/trickle/Makefile
@@ -22,8 +22,8 @@ MAKE_JOBS_UNSAFE= yes
CONFIGURE_ARGS+=--with-libevent=${LOCALBASE} \
--sysconfdir=${PREFIX}/etc
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
PORTDOCS= *
post-install:
diff --git a/net/tsclient/Makefile b/net/tsclient/Makefile
index 3c06d16ce585..59385ccb4ea0 100644
--- a/net/tsclient/Makefile
+++ b/net/tsclient/Makefile
@@ -15,10 +15,9 @@ RUN_DEPENDS= rdesktop:${PORTSDIR}/net/rdesktop
USE_GNOME= gtk20
USES= gettext gmake libtool pathfix pkgconfig
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="`pkg-config --libs libgnomeui-2.0`"
CONFIGURE_ARGS= --disable-gnome
CPPFLAGS+= -I${LOCALBASE}/include `pkg-config --cflags libgnomeui-2.0`
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib `pkg-config --libs libgnomeui-2.0`
PORTDOCS= COPYING NEWS README
diff --git a/net/uplog/Makefile b/net/uplog/Makefile
index a24c70e2993b..26f886ccd477 100644
--- a/net/uplog/Makefile
+++ b/net/uplog/Makefile
@@ -10,8 +10,8 @@ MAINTAINER= jadawin@FreeBSD.org
COMMENT= UDP-based ping program
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
PORTDOCS= README
PLIST_FILES= bin/uplog
diff --git a/net/wire/Makefile b/net/wire/Makefile
index 2713ed2c24f0..2517456597d4 100644
--- a/net/wire/Makefile
+++ b/net/wire/Makefile
@@ -14,8 +14,8 @@ COMMENT= Wire is a screen-oriented command line Wired client
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --libdir="${LOCALBASE}/lib" --includedir="${LOCALBASE}/include"
+LIBS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS= --libdir="${PREFIX}/lib" --includedir="${PREFIX}/include"
USE_OPENSSL= yes
USES= iconv gmake
diff --git a/net/wireshark/Makefile b/net/wireshark/Makefile
index 2373e4eb5e2f..1cf5259bd410 100644
--- a/net/wireshark/Makefile
+++ b/net/wireshark/Makefile
@@ -24,20 +24,17 @@ USE_PYTHON_BUILD=yes
USES= iconv gettext pkgconfig gmake perl5 tar:bzip2
WANT_GNOME= yes
USE_OPENSSL= yes
-CONFIGURE_ENV= LIBS="${WIRESHARK_LIBS}"
CONFIGURE_ARGS+= --program-transform-name="" \
--with-ssl=${OPENSSLBASE}
USE_LDCONFIG= yes
DATADIR= ${PREFIX}/share/${DATADIR_NAME}
-LDFLAGS+= -L${LOCALBASE}/lib
CFLAGS+= -funit-at-a-time
+LIBS+= -L${LOCALBASE}/lib
DESKTOP_ENTRIES= "Wireshark" "Network Protocol Analyzer" \
"${DATADIR}/hi48-app-wireshark.png" \
"wireshark" "System;Monitor;GTK;" true
-WIRESHARK_LIBS=
-
.for x in capinfos editcap mergecap rawshark text2pcap dftest randpkt \
reordercap
.if defined(LITE)
@@ -70,7 +67,6 @@ USE_XORG= x11
.if ${PORT_OPTIONS:MX11}
PLIST_SUB+= WIRESHARK=bin/wireshark WIRESHARK_MAN=""
USE_GNOME+= gtk20
-WIRESHARK_LIBS+=${PTHREAD_LIBS}
.else
PLIST_SUB+= WIRESHARK="@comment wireshark not built" \
WIRESHARK_MAN="@comment wireshark not built "
@@ -114,7 +110,6 @@ PLIST_SUB+= LUA="@comment "
.if ${PORT_OPTIONS:MRTP} && !defined(LITE)
LIB_DEPENDS+= libportaudio.so:${PORTSDIR}/audio/portaudio
CONFIGURE_ARGS+=--with-portaudio=${LOCALBASE}
-WIRESHARK_LIBS+=${PTHREAD_LIBS}
.else
CONFIGURE_ARGS+=--without-portaudio
.endif