aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/aprsc/Makefile6
-rw-r--r--net/honeyd/Makefile6
-rw-r--r--net/honeyd/files/honeyd-1.5c-libevent2.patch211
-rw-r--r--net/ifstated/Makefile4
-rw-r--r--net/ladvd/Makefile3
-rw-r--r--net/netatalk3/Makefile5
-rw-r--r--net/netatalk3/files/patch-etc_netatalk_Makefile.in13
-rw-r--r--net/ntop/Makefile4
-rw-r--r--net/ntp-devel/Makefile3
-rw-r--r--net/nylon/Makefile5
-rw-r--r--net/openospfd/Makefile4
-rw-r--r--net/relayd/Makefile8
-rw-r--r--net/scribe/Makefile3
-rw-r--r--net/spserver/Makefile6
-rw-r--r--net/trickle/Makefile4
-rw-r--r--net/turnserver/Makefile6
16 files changed, 249 insertions, 42 deletions
diff --git a/net/aprsc/Makefile b/net/aprsc/Makefile
index 4a0496600569..cdb5edf4ce30 100644
--- a/net/aprsc/Makefile
+++ b/net/aprsc/Makefile
@@ -2,7 +2,7 @@
PORTNAME= aprsc
PORTVERSION= 2.0.14
-PORTREVISION= 2
+PORTREVISION= 3
DISTVERSIONSUFFIX= .g28c5a6a
CATEGORIES= net hamradio
MASTER_SITES= http://he.fi/aprsc/down/ \
@@ -15,10 +15,10 @@ COMMENT= Plain APRS-IS server
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= libevent-2.0.so:${PORTSDIR}/devel/libevent2
+LIB_DEPENDS= libevent.so:${PORTSDIR}/devel/libevent2
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib/event2
+LDFLAGS+= -L${LOCALBASE}/lib
MAKEFILE= GNUmakefile
WRKSRC= ${WRKDIR}/${DISTNAME}/src
diff --git a/net/honeyd/Makefile b/net/honeyd/Makefile
index a0446276ef3f..c3337cfa5b83 100644
--- a/net/honeyd/Makefile
+++ b/net/honeyd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= honeyd
PORTVERSION= 1.5c
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= net
MASTER_SITES= http://www.honeyd.org/uploads/ \
http://www.citi.umich.edu/u/provos/honeyd/
@@ -13,7 +13,7 @@ COMMENT= Simulate virtual network hosts (honeypots)
LICENSE= GPLv2
-LIB_DEPENDS= libevent.so:${PORTSDIR}/devel/libevent \
+LIB_DEPENDS= libevent.so:${PORTSDIR}/devel/libevent2 \
libdnet.so:${PORTSDIR}/net/libdnet \
libpcre.so:${PORTSDIR}/devel/pcre
@@ -23,6 +23,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libdnet=${LOCALBASE} \
--with-libevent=${LOCALBASE}
+EXTRA_PATCHES= ${FILESDIR}/honeyd-1.5c-libevent2.patch:-p1
+
.if defined(WITH_PYTHON)
USE_PYTHON= yes
CONFIGURE_ARGS+= --with-python
diff --git a/net/honeyd/files/honeyd-1.5c-libevent2.patch b/net/honeyd/files/honeyd-1.5c-libevent2.patch
new file mode 100644
index 000000000000..34897ee7e514
--- /dev/null
+++ b/net/honeyd/files/honeyd-1.5c-libevent2.patch
@@ -0,0 +1,211 @@
+diff -up honeyd-1.5c/honeydstats.c.libevent2 honeyd-1.5c/honeydstats.c
+--- honeyd-1.5c/honeydstats.c.libevent2 2007-05-28 08:12:52.000000000 +0200
++++ honeyd-1.5c/honeydstats.c 2011-07-26 13:18:14.459666984 +0200
+@@ -330,30 +330,43 @@ signature_process(struct evbuffer *evbuf
+ static int
+ signature_length(struct evbuffer *evbuf)
+ {
+- struct evbuffer tmp;
++ struct evbuffer *tmp;
+ uint32_t length, tlen;
+
+- tmp = *evbuf;
+-
++ tmp = evbuffer_new();
++ tmp = evbuffer_add_reference(tmp, evbuffer_pullup(evbuf, -1),
++ evbuffer_get_length(evbuf), NULL, NULL);
+ /* name */
+- if (tag_peek_length(&tmp, &tlen) == -1 || EVBUFFER_LENGTH(&tmp) < tlen)
++ if (tag_peek_length(tmp, &tlen) == -1 || EVBUFFER_LENGTH(tmp) < tlen) {
++ evbuffer_free(tmp);
+ return (-1);
++ }
++
++ if (evbuffer_drain(tmp, tlen) == -1) {
++ evbuffer_free(tmp);
++ return (-1);
++ }
+
+ length = tlen;
+- tmp.buffer += tlen;
+- tmp.off -= tlen;
+
+ /* signature */
+- if (tag_peek_length(&tmp, &tlen) == -1 || EVBUFFER_LENGTH(&tmp) < tlen)
++ if (tag_peek_length(tmp, &tlen) == -1 || EVBUFFER_LENGTH(tmp) < tlen) {
++ evbuffer_free(tmp);
+ return (-1);
++ }
+
++ if (evbuffer_drain(tmp, tlen) == -1) {
++ evbuffer_free(tmp);
++ return (-1);
++ }
++
+ length += tlen;
+- tmp.buffer += tlen;
+- tmp.off -= tlen;
+
+ /* data */
+- if (tag_peek_length(&tmp, &tlen) == -1 || EVBUFFER_LENGTH(&tmp) < tlen)
++ if (tag_peek_length(tmp, &tlen) == -1 || EVBUFFER_LENGTH(tmp) < tlen) {
++ evbuffer_free(tmp);
+ return (-1);
++ }
+
+ length += tlen;
+
+diff -up honeyd-1.5c/tagging.c.libevent2 honeyd-1.5c/tagging.c
+--- honeyd-1.5c/tagging.c.libevent2 2007-05-28 08:12:52.000000000 +0200
++++ honeyd-1.5c/tagging.c 2011-07-26 13:18:14.460666991 +0200
+@@ -73,7 +73,7 @@ tagging_init()
+ */
+
+ void
+-encode_int(struct evbuffer *evbuf, uint32_t number)
++encode__int(struct evbuffer *evbuf, uint32_t number)
+ {
+ int off = 1, nibbles = 0;
+ uint8_t data[5];
+@@ -108,7 +108,7 @@ void
+ tag_marshal(struct evbuffer *evbuf, uint8_t tag, void *data, uint16_t len)
+ {
+ evbuffer_add(evbuf, &tag, sizeof(tag));
+- encode_int(evbuf, len);
++ encode__int(evbuf, len);
+ evbuffer_add(evbuf, data, len);
+ }
+
+@@ -117,10 +117,10 @@ void
+ tag_marshal_int(struct evbuffer *evbuf, uint8_t tag, uint32_t integer)
+ {
+ evbuffer_drain(_buf, EVBUFFER_LENGTH(_buf));
+- encode_int(_buf, integer);
++ encode__int(_buf, integer);
+
+ evbuffer_add(evbuf, &tag, sizeof(tag));
+- encode_int(evbuf, EVBUFFER_LENGTH(_buf));
++ encode__int(evbuf, EVBUFFER_LENGTH(_buf));
+ evbuffer_add_buffer(evbuf, _buf);
+ }
+
+@@ -135,8 +135,8 @@ tag_marshal_timeval(struct evbuffer *evb
+ {
+ evbuffer_drain(_buf, EVBUFFER_LENGTH(_buf));
+
+- encode_int(_buf, tv->tv_sec);
+- encode_int(_buf, tv->tv_usec);
++ encode__int(_buf, tv->tv_sec);
++ encode__int(_buf, tv->tv_usec);
+
+ tag_marshal(evbuf, tag, EVBUFFER_DATA(_buf),
+ EVBUFFER_LENGTH(_buf));
+diff -up honeyd-1.5c/tagging.h.libevent2 honeyd-1.5c/tagging.h
+--- honeyd-1.5c/tagging.h.libevent2 2007-05-28 08:12:52.000000000 +0200
++++ honeyd-1.5c/tagging.h 2011-07-26 13:18:14.461666999 +0200
+@@ -86,7 +86,7 @@ void addr_marshal(struct evbuffer *, str
+ void tag_marshal(struct evbuffer *evbuf, uint8_t tag, void *data,
+ uint16_t len);
+
+-void encode_int(struct evbuffer *evbuf, uint32_t number);
++void encode__int(struct evbuffer *evbuf, uint32_t number);
+
+ void tag_marshal_int(struct evbuffer *evbuf, uint8_t tag, uint32_t integer);
+
+diff -up honeyd-1.5c/ui.c.libevent2 honeyd-1.5c/ui.c
+--- honeyd-1.5c/ui.c.libevent2 2007-05-28 08:12:52.000000000 +0200
++++ honeyd-1.5c/ui.c 2011-07-26 13:18:14.459666984 +0200
+@@ -246,7 +246,8 @@ ui_writer(int fd, short what, void *arg)
+ struct evbuffer *buffer = client->outbuf;
+ int n;
+
+- n = write(fd, buffer->buffer, buffer->off);
++ n = write(fd, evbuffer_pullup(buffer, -1),
++ evbuffer_get_length(buffer));
+ if (n == -1) {
+ if (errno == EINTR || errno == EAGAIN)
+ goto schedule;
+@@ -260,7 +261,7 @@ ui_writer(int fd, short what, void *arg)
+ evbuffer_drain(buffer, n);
+
+ schedule:
+- if (buffer->off)
++ if (evbuffer_get_length(buffer))
+ event_add(&client->ev_write, NULL);
+ }
+
+@@ -277,8 +278,8 @@ ui_handler(int fd, short what, void *arg
+ return;
+ }
+
+- n = mybuf->off;
+- p = mybuf->buffer;
++ n = evbuffer_get_length (mybuf);
++ p = evbuffer_pullup (mybuf, -1);
+ consumed = 0;
+ while (n--) {
+ consumed++;
+@@ -289,11 +290,12 @@ ui_handler(int fd, short what, void *arg
+ */
+ if (*p == '\n') {
+ *p = '\0';
+- ui_handle_command(client->outbuf, mybuf->buffer);
++ ui_handle_command(client->outbuf,
++ evbuffer_pullup(mybuf, -1));
+
+ evbuffer_drain(mybuf, consumed);
+- n = mybuf->off;
+- p = mybuf->buffer;
++ n = evbuffer_get_length (mybuf);
++ p = evbuffer_pullup (mybuf, -1);
+ consumed = 0;
+ continue;
+ }
+diff -up honeyd-1.5c/untagging.c.libevent2 honeyd-1.5c/untagging.c
+--- honeyd-1.5c/untagging.c.libevent2 2007-05-28 08:12:52.000000000 +0200
++++ honeyd-1.5c/untagging.c 2011-07-26 13:18:14.461666999 +0200
+@@ -114,22 +114,29 @@ tag_peek(struct evbuffer *evbuf, uint8_t
+ int
+ tag_peek_length(struct evbuffer *evbuf, uint32_t *plength)
+ {
+- struct evbuffer tmp;
++ struct evbuffer *tmp;
+ int res;
+
+ if (EVBUFFER_LENGTH(evbuf) < 2)
+ return (-1);
+
+- tmp = *evbuf;
+- tmp.buffer += 1;
+- tmp.off -= 1;
++ tmp = evbuffer_new ();
++ evbuffer_add_reference (tmp, evbuffer_pullup(evbuf, -1),
++ evbuffer_get_length(evbuf), NULL, NULL);
++ if (evbuffer_drain(tmp, 1) == -1) {
++ evbuffer_free (tmp);
++ return (-1);
++ }
+
+- res = decode_int_internal(plength, &tmp, 0);
+- if (res == -1)
++ res = decode_int_internal(plength, tmp, 0);
++ if (res == -1) {
++ evbuffer_free (tmp);
+ return (-1);
++ }
+
+ *plength += res + 1;
+
++ evbuffer_free (tmp);
+ return (0);
+ }
+
+@@ -438,7 +445,7 @@ tagging_int_test(void)
+ for (i = 0; i < TEST_MAX_INT; i++) {
+ int oldlen, newlen;
+ oldlen = EVBUFFER_LENGTH(tmp);
+- encode_int(tmp, integers[i]);
++ encode__int(tmp, integers[i]);
+ newlen = EVBUFFER_LENGTH(tmp);
+ fprintf(stderr, "\t\tencoded 0x%08x with %d bytes\n",
+ integers[i], newlen - oldlen);
diff --git a/net/ifstated/Makefile b/net/ifstated/Makefile
index 75b727cdc4b7..23a692f3010d 100644
--- a/net/ifstated/Makefile
+++ b/net/ifstated/Makefile
@@ -3,14 +3,14 @@
PORTNAME= ifstated
PORTVERSION= 5.1
-PORTEPOCH= 1
+PORTEPOCH= 2
CATEGORIES= net
MASTER_SITES= http://christianserving.org/ports/net/ifstated/
MAINTAINER= ports@christianserving.org
COMMENT= Interface state daemon
-LIB_DEPENDS= libevent-1.4.so:${PORTSDIR}/devel/libevent
+LIB_DEPENDS= libevent.so:${PORTSDIR}/devel/libevent2
PLIST_FILES= etc/ifstated.conf-sample \
sbin/ifstated \
diff --git a/net/ladvd/Makefile b/net/ladvd/Makefile
index 3e3a94ef5eca..74fc3bb4571b 100644
--- a/net/ladvd/Makefile
+++ b/net/ladvd/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ladvd
PORTVERSION= 1.0.4
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= GOOGLE_CODE \
http://blinkenlights.nl/software/ladvd/
@@ -12,7 +13,7 @@ COMMENT= Minimal LLDP/CDP daemon
LICENSE= BSD
-LIB_DEPENDS= libevent-1.4.so:${PORTSDIR}/devel/libevent
+LIB_DEPENDS= libevent.so:${PORTSDIR}/devel/libevent2
USERS= ladvd
GROUPS= ${USERS}
diff --git a/net/netatalk3/Makefile b/net/netatalk3/Makefile
index d7949fd8ece6..8ec4ddc97f48 100644
--- a/net/netatalk3/Makefile
+++ b/net/netatalk3/Makefile
@@ -15,7 +15,7 @@ COMMENT= File server for Mac OS X
LICENSE= GPLv2
LIB_DEPENDS= libgcrypt.so:${PORTSDIR}/security/libgcrypt \
- libevent-2.0.so:${PORTSDIR}/devel/libevent2
+ libevent.so:${PORTSDIR}/devel/libevent2
USE_BDB= 5+
USES= iconv gmake pkgconfig perl5 libtool tar:bzip2
@@ -30,8 +30,7 @@ CONFIGURE_ARGS+= --with-pkgconfdir=${PREFIX}/etc \
${ICONV_CONFIGURE_BASE} \
--localstatedir=/var \
--disable-bundled-libevent \
- --with-libevent-header=${LOCALBASE}/include \
- --with-libevent-lib=${LOCALBASE}/lib/event2
+ --with-libevent-header=${LOCALBASE}/include
OPTIONS_DEFINE=PAM KRB5 LDAP SENDFILE KERBEROS DTRACE DBUS MYSQL ACL TCPWRAP
OPTIONS_DEFAULT=KERBEROS DBUS TCPWRAP
diff --git a/net/netatalk3/files/patch-etc_netatalk_Makefile.in b/net/netatalk3/files/patch-etc_netatalk_Makefile.in
deleted file mode 100644
index 038587e7312b..000000000000
--- a/net/netatalk3/files/patch-etc_netatalk_Makefile.in
+++ /dev/null
@@ -1,13 +0,0 @@
-$FreeBSD$
-
---- etc/netatalk/Makefile.in.orig 2012-09-28 05:17:54.000000000 -0400
-+++ etc/netatalk/Makefile.in 2012-09-29 01:00:04.000000000 -0400
-@@ -63,7 +63,7 @@ sbin_PROGRAMS = netatalk$(EXEEXT)
- @USE_BUILTIN_LIBEVENT_TRUE@ $(top_builddir)/libevent/libevent.la
-
- @USE_BUILTIN_LIBEVENT_FALSE@am__append_3 = @LIBEVENT_CFLAGS@
--@USE_BUILTIN_LIBEVENT_FALSE@am__append_4 = @LIBEVENT_LDFLAGS@ -levent
-+@USE_BUILTIN_LIBEVENT_FALSE@am__append_4 = @LIBEVENT_LDFLAGS@ -levent-2.0
- subdir = etc/netatalk
- DIST_COMMON = $(srcdir)/Makefile.am $(srcdir)/Makefile.in
- ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
diff --git a/net/ntop/Makefile b/net/ntop/Makefile
index ad5683d5ae4b..70bc10edfd95 100644
--- a/net/ntop/Makefile
+++ b/net/ntop/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ntop
PORTVERSION= 5.0.1
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= net
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/Stable
@@ -13,7 +13,7 @@ COMMENT= Network monitoring tool with command line and web interfaces
LICENSE= GPLv3
LIB_DEPENDS= libgdbm.so:${PORTSDIR}/databases/gdbm \
- libevent-1.4.so:${PORTSDIR}/devel/libevent
+ libevent.so:${PORTSDIR}/devel/libevent2
BUILD_DEPENDS= rrdtool>=1.2:${PORTSDIR}/databases/rrdtool \
dot:${PORTSDIR}/graphics/graphviz \
geoiplookup:${PORTSDIR}/net/GeoIP
diff --git a/net/ntp-devel/Makefile b/net/ntp-devel/Makefile
index a9e29b8599b5..0e25e1e64ce8 100644
--- a/net/ntp-devel/Makefile
+++ b/net/ntp-devel/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ntp
PORTVERSION= 4.2.7p453
+PORTREVISION= 1
CATEGORIES= net ipv6
MASTER_SITES= http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-dev/ \
ftp://ftp.archive.de.uu.net/pub/unix/ntp/ntp4/ntp-dev/ \
@@ -18,7 +19,7 @@ USE_AUTOTOOLS= automake
AUTOMAKE_ARGS= --add-missing
OPTIONS_SUB= yes
USES= pathfix shebangfix libtool
-LIB_DEPENDS= libevent-2.0.so:${PORTSDIR}/devel/libevent2
+LIB_DEPENDS= libevent.so:${PORTSDIR}/devel/libevent2
NTP_SHEBANG_FILES= sbin/ntp-wait sbin/ntptrace
diff --git a/net/nylon/Makefile b/net/nylon/Makefile
index af695b6df640..bd947fb01666 100644
--- a/net/nylon/Makefile
+++ b/net/nylon/Makefile
@@ -3,14 +3,14 @@
PORTNAME= nylon
PORTVERSION= 1.21
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= net
MASTER_SITES= http://monkey.org/~marius/nylon/
MAINTAINER= ports@FreeBSD.org
COMMENT= Unix SOCKS 4 and 5 proxy server
-LIB_DEPENDS= libevent-2.0.so:${PORTSDIR}/devel/libevent2
+LIB_DEPENDS= libevent.so:${PORTSDIR}/devel/libevent2
USE_RC_SUBR= nylon
@@ -20,6 +20,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libevent=yes
CONFIGURE_ENV= EVENTLIB="`pkgconf --libs libevent`" EVENTINC="`pkgconf --cflags libevent`"
+
PLIST_FILES= bin/nylon etc/nylon.conf.sample man/man1/nylon.1.gz
post-install:
diff --git a/net/openospfd/Makefile b/net/openospfd/Makefile
index 194d54aafd90..9b2ce8ad0e66 100644
--- a/net/openospfd/Makefile
+++ b/net/openospfd/Makefile
@@ -2,7 +2,7 @@
PORTNAME= openospfd
PORTVERSION= 4.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= OPENBSD/OpenBGPD:openbsd \
LOCAL/flz/openospfd/:freebsd
@@ -18,7 +18,7 @@ LICENSE= ISCL
CONFLICTS= zebra-0* quagga-0*
-LIB_DEPENDS= libevent-1.4.so:${PORTSDIR}/devel/libevent
+LIB_DEPENDS= libevent.so:${PORTSDIR}/devel/libevent2
MAKE_ENV= BINDIR="${PREFIX}/sbin" \
MANDIR="${PREFIX}/man/man"
diff --git a/net/relayd/Makefile b/net/relayd/Makefile
index f0e2907809f0..489296beac12 100644
--- a/net/relayd/Makefile
+++ b/net/relayd/Makefile
@@ -2,7 +2,7 @@
PORTNAME= relayd
PORTVERSION= 5.4.20131122
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net
MASTER_SITES= GH
@@ -19,6 +19,8 @@ USES= uidfix
USE_GITHUB= yes
USE_RC_SUBR= relayd
+BROKEN= Abuse evbuffer API
+
CFLAGS+= -I${PREFIX}/include -Wall
MAKE_ARGS+= BINDIR=${PREFIX}/sbin MANDIR=${PREFIX}/man/man
@@ -32,10 +34,10 @@ LIBEVENT_STATIC_DESC= Build with static libevent
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MLIBEVENT_STATIC}
-BUILD_DEPENDS= ${LOCALBASE}/lib/libevent.a:${PORTSDIR}/devel/libevent
+BUILD_DEPENDS= ${LOCALBASE}/lib/libevent.a:${PORTSDIR}/devel/libevent2
MAKE_ARGS+= LIBEVENT=${LOCALBASE}/lib/libevent.a
.else
-LIB_DEPENDS= libevent-1.4.so:${PORTSDIR}/devel/libevent
+LIB_DEPENDS= libevent.so:${PORTSDIR}/devel/libevent2
MAKE_ARGS+= LIBEVENT=-levent
.endif
diff --git a/net/scribe/Makefile b/net/scribe/Makefile
index b0da95167e57..71623c8b9097 100644
--- a/net/scribe/Makefile
+++ b/net/scribe/Makefile
@@ -3,6 +3,7 @@
PORTNAME= scribe
DISTVERSION= 2.2.2013.04.15
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= https://github.com/facebook/scribe/tarball/${GITVERSION}/
DISTNAME= facebook-scribe-${GITVERSION}
@@ -13,7 +14,7 @@ COMMENT= Aggregating log data streamed in real time
BUILD_DEPENDS= fb303>0:${PORTSDIR}/devel/fb303 \
thrift:${PORTSDIR}/devel/thrift
LIB_DEPENDS= libboost_system.so:${PORTSDIR}/devel/boost-libs \
- libevent.so:${PORTSDIR}/devel/libevent \
+ libevent.so:${PORTSDIR}/devel/libevent2 \
libthrift.so:${PORTSDIR}/devel/thrift-cpp
RUN_DEPENDS= p5-Class-Accessor>0:${PORTSDIR}/devel/p5-Class-Accessor \
p5-Thrift>0:${PORTSDIR}/devel/p5-Thrift \
diff --git a/net/spserver/Makefile b/net/spserver/Makefile
index b7431aa96f77..2be1271ca3e0 100644
--- a/net/spserver/Makefile
+++ b/net/spserver/Makefile
@@ -3,7 +3,7 @@
PORTNAME= spserver
PORTVERSION= 0.9.5
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
@@ -11,7 +11,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}.src
MAINTAINER= vanilla@FreeBSD.org
COMMENT= TCP server framework library written in C++ based on libevent
-LIB_DEPENDS= libevent-1.4.so:${PORTSDIR}/devel/libevent
+LIB_DEPENDS= libevent.so:${PORTSDIR}/devel/libevent2
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_LDCONFIG= yes
@@ -19,6 +19,8 @@ USES= gmake
ALL_TARGET= all build_openssl
MAKE_JOBS_UNSAFE= yes
+BROKEN= Misuse libevent API
+
OPTIONS_DEFINE= GNUTLS
# MATRIXSSL "Enable matrixssl support" off
diff --git a/net/trickle/Makefile b/net/trickle/Makefile
index 2661c6bde994..e131cb354ab7 100644
--- a/net/trickle/Makefile
+++ b/net/trickle/Makefile
@@ -3,14 +3,14 @@
PORTNAME= trickle
PORTVERSION= 1.07
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net
MASTER_SITES= http://monkey.org/~marius/trickle/
MAINTAINER= gahr@FreeBSD.org
COMMENT= Lightweight, portable bandwidth shaper
-LIB_DEPENDS= libevent-1.4.so:${PORTSDIR}/devel/libevent
+LIB_DEPENDS= libevent.so:${PORTSDIR}/devel/libevent2
OPTIONS_DEFINE= DOCS
diff --git a/net/turnserver/Makefile b/net/turnserver/Makefile
index 530511e0408a..60d3f7e2da6a 100644
--- a/net/turnserver/Makefile
+++ b/net/turnserver/Makefile
@@ -2,6 +2,7 @@
PORTNAME= turnserver
PORTVERSION= 3.2.2.5
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://turnserver.open-sys.org/downloads/v${PORTVERSION}/ \
http://turnserver.open-sys.org/downloads/extradocs/ \
@@ -15,7 +16,7 @@ COMMENT= STUN/TURN Server; IPv6, DTLS support; RFCs 5389, 5766, 6062, 6156
LICENSE= BSD3CLAUSE
-LIB_DEPENDS= libevent-2.0.so:${PORTSDIR}/devel/libevent2
+LIB_DEPENDS= libevent.so:${PORTSDIR}/devel/libevent2
CONFLICTS= libevent-1.*
@@ -76,8 +77,7 @@ selfloadbalance/secure_relay.sh
CONFIGURE_ENV+= PTHREAD_LIBS=-pthread TURN_DISABLE_RPATH=1
.if ${PORT_OPTIONS:MPGSQL}
-USE_PGSQL= yes
-LIB_DEPENDS+= libpq.so:${PORTSDIR}/databases/postgresql90-client
+USES+= pgsql
.else
CONFIGURE_ENV+= TURN_NO_PQ=1
.endif