aboutsummaryrefslogtreecommitdiff
path: root/news/nzbget/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'news/nzbget/Makefile')
-rw-r--r--news/nzbget/Makefile25
1 files changed, 7 insertions, 18 deletions
diff --git a/news/nzbget/Makefile b/news/nzbget/Makefile
index cf99325a7757..7cb3516fcab5 100644
--- a/news/nzbget/Makefile
+++ b/news/nzbget/Makefile
@@ -1,9 +1,8 @@
# Created by: Lewis Thompson <purple@lewiz.net>
PORTNAME= nzbget
-PORTVERSION= 21.0
+PORTVERSION= 21.1
DISTVERSIONPREFIX= v
-PORTREVISION= 2
CATEGORIES= news
MAINTAINER= ports@FreeBSD.org
@@ -13,9 +12,13 @@ LICENSE= GPLv2
LIB_DEPENDS= libxml2.so:textproc/libxml2
-USES= autoreconf compiler:c++14-lang gmake localbase ncurses pkgconfig shebangfix ssl
+USES= autoreconf compiler:c++14-lang gmake localbase ncurses \
+ pkgconfig python:build shebangfix ssl
+USE_GITHUB= yes
USE_RC_SUBR= nzbget
+SHEBANG_FILES= scripts/*.py
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libcurses-includes=${NCURSESINC} \
--with-libcurses-libraries=${NCURSESLIB} \
@@ -25,26 +28,12 @@ CONFIGURE_ARGS= --with-libcurses-includes=${NCURSESINC} \
BINMODE= 0755
-SHEBANG_FILES= scripts/*.py
SUB_FILES= pkg-message
-USE_GITHUB= yes
-
-OPTIONS_DEFINE= 7Z DOCS OPTIMIZED_FLAGS PYTHON RAR
-OPTIONS_DEFAULT= PAR PYTHON RAR 7Z
-7Z_DESC= Support extraction of 7z archives
+OPTIONS_DEFINE= DOCS OPTIMIZED_FLAGS
OPTIMIZED_FLAGS_DESC= Enable optimized CPU instructions (SSE2/SSE3/NEON/etc)
-PYTHON_DESC= Support for python post-processing scripts
-RAR_DESC= Support extraction of rar archives
-
-7Z_RUN_DEPENDS= 7z:archivers/p7zip
-
OPTIMIZED_FLAGS_EXTRA_PATCHES_OFF= ${FILESDIR}/extra-disable-optimized-flags.patch
-PYTHON_USES= python:run
-
-RAR_RUN_DEPENDS= unrar:archivers/unrar
-
.include <bsd.port.options.mk>
.if (${ARCH} == "i386")