aboutsummaryrefslogtreecommitdiff
path: root/news/nzbhydra2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'news/nzbhydra2/Makefile')
-rw-r--r--news/nzbhydra2/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/news/nzbhydra2/Makefile b/news/nzbhydra2/Makefile
index 99db5cee0da1..3716b82f33a8 100644
--- a/news/nzbhydra2/Makefile
+++ b/news/nzbhydra2/Makefile
@@ -13,10 +13,18 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
ONLY_FOR_ARCHS= aarch64 amd64 powerpc64 powerpc64le
-USES= python zip
+USES= python
USE_JAVA= yes
USE_RC_SUBR= nzbhydra2
+EXTRACT_SUFX= .zip
+EXTRACT_AFTER_ARGS= --exclude executables \
+ --exclude other \
+ --exclude WindowsService \
+ --exclude *.exe \
+ --exclude nzbhydra2wrapper.py \
+ --no-same-owner --no-same-permissions
+
NO_BUILD= yes
NO_WRKSUBDIR= yes
@@ -38,13 +46,6 @@ PLIST_FILES= ${DATADIR}/lib/core-${DISTVERSION}-exec.jar \
${DATADIR}/readme.md \
${DATADIR}/LICENSE
-post-extract:
- # Cleanup unnecessary files
- @${RM} -r ${WRKSRC}/systemd ${WRKSRC}/sysv ${WRKSRC}/rc.d \
- ${WRKSRC}/upstart ${WRKSRC}/nzbhydra2wrapper.py \
- ${WRKSRC}/other ${WRKSRC}/executables ${WRKSRC}/WindowsService \
- ${WRKSRC}/NZBHydra2*
-
do-install:
@${MKDIR} ${STAGEDIR}/${DATADIR}
${INSTALL} -d -m 755 ${STAGEDIR}/${DATADIR}