aboutsummaryrefslogtreecommitdiff
path: root/palm/coldsync/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'palm/coldsync/Makefile')
-rw-r--r--palm/coldsync/Makefile19
1 files changed, 17 insertions, 2 deletions
diff --git a/palm/coldsync/Makefile b/palm/coldsync/Makefile
index ed221ff0a561..24221d7b1068 100644
--- a/palm/coldsync/Makefile
+++ b/palm/coldsync/Makefile
@@ -6,19 +6,34 @@
#
PORTNAME= coldsync
-PORTVERSION= 1.1.2
+PORTVERSION= 1.2.0
CATEGORIES= palm comms
MASTER_SITES= http://www.ooblick.com/software/coldsync/
MAINTAINER= arensb@ooblick.com
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Palm/PDB.pm:${PORTSDIR}/palm/p5-Palm
+
GNU_CONFIGURE= yes
+# The ColdSync.3 man page describes a Perl package. That's why it goes
+# in the Perl manpage directory.
+MAN1= send-mail.1 \
+ todo-text.1
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= ColdSync.3
MAN8= coldsync.8
MANCOMPRESSED= no
+.include <bsd.port.pre.mk>
+
+# I don't know from when {Net,Open}BSD support USB.
+.if ${OPSYS} == "FreeBSD" && ${OSVERSION} >= 400000
+CONFIGURE_ARGS+= --with-usb
+.endif
+
post-install:
@install-info ${PREFIX}/info/conduits.info ${PREFIX}/info/dir
@install-info ${PREFIX}/info/pdb.info ${PREFIX}/info/dir
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>