aboutsummaryrefslogtreecommitdiff
path: root/palm/ppmtoTbmp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'palm/ppmtoTbmp/Makefile')
-rw-r--r--palm/ppmtoTbmp/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/palm/ppmtoTbmp/Makefile b/palm/ppmtoTbmp/Makefile
index 1aa7541d4f4d..9c8bbd197a60 100644
--- a/palm/ppmtoTbmp/Makefile
+++ b/palm/ppmtoTbmp/Makefile
@@ -16,11 +16,10 @@ COMMENT= PPM to Pilot bitmap converter
LIB_DEPENDS= netpbm.1:${PORTSDIR}/graphics/netpbm
USE_REINPLACE= yes
-MAKE_ENV+= LDFLAGS="${LDFLAGS}"
+MAKE_ENV+= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+MAKE_ARGS= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" LDLIBS=-lnetpbm
post-patch:
- @${REINPLACE_CMD} -e "s|^CFLAGS =.*|CFLAGS += -I${LOCALBASE}/include|g; \
- s|^LDLIBS =|LDLIBS = -L${LOCALBASE}/lib|g" ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e '/^#include "ppmcmap.h"/d' ${WRKSRC}/ppmtoTbmp.c
do-install: