aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt/portgraph/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'ports-mgmt/portgraph/Makefile')
-rw-r--r--ports-mgmt/portgraph/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/ports-mgmt/portgraph/Makefile b/ports-mgmt/portgraph/Makefile
new file mode 100644
index 000000000000..c5e1ae347059
--- /dev/null
+++ b/ports-mgmt/portgraph/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= portgraph
+PORTVERSION= 0.0.1
+CATEGORIES= ports-mgmt python
+MASTER_SITES= CHEESESHOP
+
+MAINTAINER= lbartoletti@tuxfamily.org
+COMMENT= Create a dependencies graph of a(all) port(s)
+
+LICENSE= BSD2CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}graphviz>=0.8.2:graphics/py-graphviz@${PY_FLAVOR}
+
+USES= python:3.4+
+USE_PYTHON= distutils autoplist noflavors
+NO_ARCH= yes
+
+post-patch:
+ @${REINPLACE_CMD} \
+ -e 's|/usr/ports|${PORTSDIR}| ; s|ports-mgmt/py-portgraph|ports-mgmt/portgraph|' \
+ ${WRKSRC}/portgraph/portgraph.py
+
+.include <bsd.port.mk>