aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/tinderbox/Makefile10
1 files changed, 3 insertions, 7 deletions
diff --git a/ports-mgmt/tinderbox/Makefile b/ports-mgmt/tinderbox/Makefile
index 9aabd48bc506..8817eabe7c38 100644
--- a/ports-mgmt/tinderbox/Makefile
+++ b/ports-mgmt/tinderbox/Makefile
@@ -3,7 +3,7 @@
PORTNAME= tinderbox
PORTVERSION= 4.2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= ports-mgmt
MASTER_SITES= http://tinderbox.marcuscom.com/
DIST_SUBDIR= ${PORTNAME}
@@ -49,7 +49,7 @@ WEBUI= yes
.endif
.if defined(WEBUI)
-WANT_PHP_WEB= yes
+USES+= php:web
USE_PHP= session
PLIST_SUB+= WEBUI=""
.else
@@ -68,7 +68,7 @@ RUN_DEPENDS+= p5-DBD-Pg>=0:databases/p5-DBD-Pg
.if defined(WEBUI)
USE_PHP+= mysql pdo_mysql
.endif
-USE_MYSQL= yes
+USES+= mysql
RUN_DEPENDS+= p5-DBD-mysql>=0:databases/p5-DBD-mysql
.endif
@@ -89,10 +89,6 @@ RUN_DEPENDS+= hiawatha:www/hiawatha
RUN_DEPENDS+= nginx:www/nginx
.endif
-.if ${PORT_OPTIONS:MEMAILS}
-RUN_DEPENDS+= p5-Net>=0:net/p5-Net
-.endif
-
.if ${PORT_OPTIONS:MLSOF}
RUN_DEPENDS+= lsof:sysutils/lsof
.endif