aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/chucky/Makefile4
-rw-r--r--ports-mgmt/distilator/Makefile4
-rw-r--r--ports-mgmt/fbsdmon/Makefile4
-rw-r--r--ports-mgmt/freebsd-bugzilla-cli/Makefile4
-rw-r--r--ports-mgmt/kpackagekit/Makefile2
-rw-r--r--ports-mgmt/lsknobs/Makefile2
-rw-r--r--ports-mgmt/p5-FreeBSD-Portindex/Makefile4
-rw-r--r--ports-mgmt/packagekit/Makefile24
-rw-r--r--ports-mgmt/pkgcompare/Makefile4
-rw-r--r--ports-mgmt/port-authoring-tools/Makefile6
-rw-r--r--ports-mgmt/port-maintenance-tools/Makefile10
-rw-r--r--ports-mgmt/portdowngrade/Makefile2
-rw-r--r--ports-mgmt/portell/Makefile2
-rw-r--r--ports-mgmt/portest/Makefile10
-rw-r--r--ports-mgmt/portfind/Makefile4
-rw-r--r--ports-mgmt/portless/Makefile2
-rw-r--r--ports-mgmt/portscout/Makefile22
-rw-r--r--ports-mgmt/portshaker-config/Makefile2
-rw-r--r--ports-mgmt/portshaker/Makefile10
-rw-r--r--ports-mgmt/porttools/Makefile8
-rw-r--r--ports-mgmt/porttree/Makefile4
-rw-r--r--ports-mgmt/portupgrade-devel/Makefile2
-rw-r--r--ports-mgmt/portupgrade/Makefile2
-rw-r--r--ports-mgmt/poudriere-devel/Makefile2
-rw-r--r--ports-mgmt/poudriere/Makefile2
-rw-r--r--ports-mgmt/py-pytoport/Makefile2
-rw-r--r--ports-mgmt/redports-node/Makefile6
-rw-r--r--ports-mgmt/synth/Makefile4
-rw-r--r--ports-mgmt/tinderbox/Makefile20
-rw-r--r--ports-mgmt/wanted-ports/files/wanted-ports.in2
30 files changed, 88 insertions, 88 deletions
diff --git a/ports-mgmt/chucky/Makefile b/ports-mgmt/chucky/Makefile
index 747f57127c9e..7a8d76471910 100644
--- a/ports-mgmt/chucky/Makefile
+++ b/ports-mgmt/chucky/Makefile
@@ -14,8 +14,8 @@ LICENSE_NAME= CHUCKY BSD LICENSE
LICENSE_FILE= ${WRKSRC}/LICENSE
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-LIB_DEPENDS= libpkg.so:${PORTSDIR}/${PKG_ORIGIN} \
- libsqlite3.so:${PORTSDIR}/databases/sqlite3
+LIB_DEPENDS= libpkg.so:${PKG_ORIGIN} \
+ libsqlite3.so:databases/sqlite3
USE_GITHUB= yes
GH_ACCOUNT= waitman
diff --git a/ports-mgmt/distilator/Makefile b/ports-mgmt/distilator/Makefile
index 2df6c07fa9c6..f0774544b863 100644
--- a/ports-mgmt/distilator/Makefile
+++ b/ports-mgmt/distilator/Makefile
@@ -13,8 +13,8 @@ COMMENT= Command-line script to check the availability of a ports distfiles
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-RUN_DEPENDS= p5-URI>=1.56:${PORTSDIR}/net/p5-URI \
- p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= p5-URI>=1.56:net/p5-URI \
+ p5-libwww>=0:www/p5-libwww
BUILD_DEPENDS:= ${RUN_DEPENDS}
USES= perl5
diff --git a/ports-mgmt/fbsdmon/Makefile b/ports-mgmt/fbsdmon/Makefile
index 0ee7c24ca812..b3d2e1206c5c 100644
--- a/ports-mgmt/fbsdmon/Makefile
+++ b/ports-mgmt/fbsdmon/Makefile
@@ -9,8 +9,8 @@ MASTER_SITES= LOCAL/gblach/
MAINTAINER= ports@FreeBSD.org
COMMENT= Submit system and ports statistics to fbsdmon.org
-LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
- libjansson.so:${PORTSDIR}/devel/jansson
+LIB_DEPENDS= libcurl.so:ftp/curl \
+ libjansson.so:devel/jansson
SUB_FILES= 600.fbsdmon pkg-message
USE_RC_SUBR= fbsdmon
diff --git a/ports-mgmt/freebsd-bugzilla-cli/Makefile b/ports-mgmt/freebsd-bugzilla-cli/Makefile
index a59d424a387c..b1b4046463fe 100644
--- a/ports-mgmt/freebsd-bugzilla-cli/Makefile
+++ b/ports-mgmt/freebsd-bugzilla-cli/Makefile
@@ -11,7 +11,7 @@ COMMENT= Interact with the FreeBSD bugzilla instance
LICENSE= APACHE20
-RUN_DEPENDS= ca_root_nss>=0:${PORTSDIR}/security/ca_root_nss
+RUN_DEPENDS= ca_root_nss>=0:security/ca_root_nss
OPTIONS_GROUP= BACKEND
OPTIONS_GROUP_BACKEND= PYBUGZ
@@ -19,7 +19,7 @@ OPTIONS_DEFAULT= PYBUGZ
OPTIONS_SUB= yes
PYBUGZ_DESC= use devel/pybugz for bugzilla interface
-PYBUGZ_RUN_DEPENDS= bugz:${PORTSDIR}/devel/pybugz
+PYBUGZ_RUN_DEPENDS= bugz:devel/pybugz
DATADIR= ${PREFIX}/share/bz
diff --git a/ports-mgmt/kpackagekit/Makefile b/ports-mgmt/kpackagekit/Makefile
index e8899383a4df..7d44c5ba96dc 100644
--- a/ports-mgmt/kpackagekit/Makefile
+++ b/ports-mgmt/kpackagekit/Makefile
@@ -13,7 +13,7 @@ COMMENT= KDE interface for PackageKit
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libpackagekit-qt.so:${PORTSDIR}/ports-mgmt/packagekit-qt4
+LIB_DEPENDS= libpackagekit-qt.so:ports-mgmt/packagekit-qt4
USE_KDE4= automoc4 kdelibs kdeprefix
USE_QT4= moc_build qmake_build rcc_build uic_build
diff --git a/ports-mgmt/lsknobs/Makefile b/ports-mgmt/lsknobs/Makefile
index 12e04045cc61..1e7d71e7cdcc 100644
--- a/ports-mgmt/lsknobs/Makefile
+++ b/ports-mgmt/lsknobs/Makefile
@@ -11,7 +11,7 @@ EXTRACT_ONLY= # none
MAINTAINER= linder.gabriel@gmail.com
COMMENT= Simple script to help configure ports knobs and options
-RUN_DEPENDS= ${LOCALBASE}/libexec/portconf:${PORTSDIR}/ports-mgmt/portconf
+RUN_DEPENDS= ${LOCALBASE}/libexec/portconf:ports-mgmt/portconf
NO_BUILD= yes
SUB_FILES= pkg-message ${PORTNAME}.sh
diff --git a/ports-mgmt/p5-FreeBSD-Portindex/Makefile b/ports-mgmt/p5-FreeBSD-Portindex/Makefile
index 9ccb80eecf11..4c3f701837b9 100644
--- a/ports-mgmt/p5-FreeBSD-Portindex/Makefile
+++ b/ports-mgmt/p5-FreeBSD-Portindex/Makefile
@@ -12,7 +12,7 @@ COMMENT= Incremental FreeBSD ports INDEX file generation
LICENSE= BSD2CLAUSE
-BUILD_DEPENDS= p5-BerkeleyDB>0:${PORTSDIR}/databases/p5-BerkeleyDB
+BUILD_DEPENDS= p5-BerkeleyDB>0:databases/p5-BerkeleyDB
RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5 tar:xz
@@ -36,7 +36,7 @@ PLIST_SUB+= CACHE_DIR=${CACHE_DIR} \
# machine.
OPTIONS_DEFINE= GRAPHVIZ
GRAPHVIZ_DESC= Add GraphViz run-time dependency
-GRAPHVIZ_RUN_DEPENDS= dot:${PORTSDIR}/graphics/graphviz
+GRAPHVIZ_RUN_DEPENDS= dot:graphics/graphviz
post-install:
${MKDIR} ${STAGEDIR}${CACHE_DIR}
diff --git a/ports-mgmt/packagekit/Makefile b/ports-mgmt/packagekit/Makefile
index f77070239adb..aadc14a8a2ed 100644
--- a/ports-mgmt/packagekit/Makefile
+++ b/ports-mgmt/packagekit/Makefile
@@ -11,12 +11,12 @@ MASTER_SITES= http://www.packagekit.org/releases/
MAINTAINER= gnome@FreeBSD.org
COMMENT?= DBUS packaging abstraction layer
-BUILD_DEPENDS= ${LOCALBASE}/bin/docbook2man:${PORTSDIR}/textproc/docbook-utils
-LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
- libpolkit-gobject-1.so:${PORTSDIR}/sysutils/polkit \
- libck-connector.so:${PORTSDIR}/sysutils/consolekit
-RUN_DEPENDS= lsof:${PORTSDIR}/sysutils/lsof \
- bash:${PORTSDIR}/shells/bash
+BUILD_DEPENDS= ${LOCALBASE}/bin/docbook2man:textproc/docbook-utils
+LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib \
+ libpolkit-gobject-1.so:sysutils/polkit \
+ libck-connector.so:sysutils/consolekit
+RUN_DEPENDS= lsof:sysutils/lsof \
+ bash:shells/bash
IGNORE= does not build with new polkit
@@ -52,9 +52,9 @@ PORTS_DESC=Use portupgrade for management, dummy if disabled
.include <bsd.port.options.mk>
. if ${PORT_OPTIONS:MMANPAGES}
-BUILD_DEPENDS+= docbook-sgml>0:${PORTSDIR}/textproc/docbook-sgml \
- xsltproc:${PORTSDIR}/textproc/libxslt \
- ${LOCALBASE}/share/xsl/docbook/manpages/docbook.xsl:${PORTSDIR}/textproc/docbook-xsl
+BUILD_DEPENDS+= docbook-sgml>0:textproc/docbook-sgml \
+ xsltproc:textproc/libxslt \
+ ${LOCALBASE}/share/xsl/docbook/manpages/docbook.xsl:textproc/docbook-xsl
PLIST_SUB+= MAN=''
. else
CONFIGURE_ARGS+=--disable-man-pages
@@ -62,7 +62,7 @@ PLIST_SUB+= MAN='@comment '
. endif
. if ${PORT_OPTIONS:MPORTS}
-RUN_DEPENDS+= ${LOCALBASE}/sbin/portupgrade:${PORTSDIR}/ports-mgmt/portupgrade
+RUN_DEPENDS+= ${LOCALBASE}/sbin/portupgrade:ports-mgmt/portupgrade
USE_RUBY= yes
CONFIGURE_ARGS+=--enable-ports --with-default-backend=ports
PLIST_SUB+= PORTS=""
@@ -77,10 +77,10 @@ PLIST_SUB+= GTK="@comment "
CONFIGURE_ARGS+=--disable-qt
.elif defined(${SLAVEPORT}) && ${SLAVEPORT}=="qt4"
-LIB_DEPENDS+= libpackagekit-glib2.so:${PORTSDIR}/ports-mgmt/packagekit
+LIB_DEPENDS+= libpackagekit-glib2.so:ports-mgmt/packagekit
CONFIGURE_ARGS+=--enable-qt
-LIB_DEPENDS+= libcppunit.so:${PORTSDIR}/devel/cppunit
+LIB_DEPENDS+= libcppunit.so:devel/cppunit
USE_QT4+= dbus gui xml sql moc_build
#.include "${PORTSDIR}/Mk/bsd.qt.mk"
.endif
diff --git a/ports-mgmt/pkgcompare/Makefile b/ports-mgmt/pkgcompare/Makefile
index 4236526cc173..a64140a34403 100644
--- a/ports-mgmt/pkgcompare/Makefile
+++ b/ports-mgmt/pkgcompare/Makefile
@@ -13,8 +13,8 @@ LICENSE_NAME= PKG-COMPARE BSD LICENSE
LICENSE_FILE= ${WRKSRC}/LICENSE
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-LIB_DEPENDS= libpkg.so:${PORTSDIR}/${PKG_ORIGIN} \
- libsqlite3.so:${PORTSDIR}/databases/sqlite3
+LIB_DEPENDS= libpkg.so:${PKG_ORIGIN} \
+ libsqlite3.so:databases/sqlite3
USE_GITHUB= yes
GH_ACCOUNT= waitman
diff --git a/ports-mgmt/port-authoring-tools/Makefile b/ports-mgmt/port-authoring-tools/Makefile
index efe77986c216..5895f6e35613 100644
--- a/ports-mgmt/port-authoring-tools/Makefile
+++ b/ports-mgmt/port-authoring-tools/Makefile
@@ -11,8 +11,8 @@ COMMENT= "meta-port" for tools to test and submit changes to ports
USES= metaport
# note: portlint is brought in by porttools
RUN_DEPENDS= \
- ${LOCALBASE}/bin/svn:${PORTSDIR}/devel/subversion \
- ${LOCALBASE}/sbin/libchk:${PORTSDIR}/sysutils/libchk \
- ${LOCALBASE}/bin/port:${PORTSDIR}/ports-mgmt/porttools
+ ${LOCALBASE}/bin/svn:devel/subversion \
+ ${LOCALBASE}/sbin/libchk:sysutils/libchk \
+ ${LOCALBASE}/bin/port:ports-mgmt/porttools
.include <bsd.port.mk>
diff --git a/ports-mgmt/port-maintenance-tools/Makefile b/ports-mgmt/port-maintenance-tools/Makefile
index c6176f70f042..08073ee0549a 100644
--- a/ports-mgmt/port-maintenance-tools/Makefile
+++ b/ports-mgmt/port-maintenance-tools/Makefile
@@ -11,10 +11,10 @@ COMMENT= Meta-port for administrative tools to maintain ports
USES= metaport
RUN_DEPENDS= \
- ${LOCALBASE}/sbin/portupgrade:${PORTSDIR}/ports-mgmt/portupgrade \
- ${LOCALBASE}/bin/svn:${PORTSDIR}/devel/subversion \
- ${LOCALBASE}/sbin/pkg_cutleaves:${PORTSDIR}/ports-mgmt/pkg_cutleaves \
- ${LOCALBASE}/bin/pkg_tree:${PORTSDIR}/ports-mgmt/pkg_tree \
- ${LOCALBASE}/sbin/portdowngrade:${PORTSDIR}/ports-mgmt/portdowngrade
+ ${LOCALBASE}/sbin/portupgrade:ports-mgmt/portupgrade \
+ ${LOCALBASE}/bin/svn:devel/subversion \
+ ${LOCALBASE}/sbin/pkg_cutleaves:ports-mgmt/pkg_cutleaves \
+ ${LOCALBASE}/bin/pkg_tree:ports-mgmt/pkg_tree \
+ ${LOCALBASE}/sbin/portdowngrade:ports-mgmt/portdowngrade
.include <bsd.port.mk>
diff --git a/ports-mgmt/portdowngrade/Makefile b/ports-mgmt/portdowngrade/Makefile
index 5ca139597357..450363493ab2 100644
--- a/ports-mgmt/portdowngrade/Makefile
+++ b/ports-mgmt/portdowngrade/Makefile
@@ -10,7 +10,7 @@ DISTFILES= # none
MAINTAINER= crees@FreeBSD.org
COMMENT= Sets a port back to a previous version
-RUN_DEPENDS= svn:${PORTSDIR}/devel/subversion${WITH_SUBVERSION_VER}
+RUN_DEPENDS= svn:devel/subversion${WITH_SUBVERSION_VER}
NO_BUILD= yes
PLIST_FILES= sbin/portdowngrade
diff --git a/ports-mgmt/portell/Makefile b/ports-mgmt/portell/Makefile
index 5e36919e963a..44dd756ffbc2 100644
--- a/ports-mgmt/portell/Makefile
+++ b/ports-mgmt/portell/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= http://www.freebsdcluster.org/~mich/software/
MAINTAINER= mich@FreeBSD.org
COMMENT= Quick display of FreeBSD port descriptions
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}bsddb>0:${PORTSDIR}/databases/py-bsddb
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}bsddb>0:databases/py-bsddb
USES= python zip
NO_BUILD= yes
diff --git a/ports-mgmt/portest/Makefile b/ports-mgmt/portest/Makefile
index 076139822ac1..af4cdfe0e46d 100644
--- a/ports-mgmt/portest/Makefile
+++ b/ports-mgmt/portest/Makefile
@@ -10,7 +10,7 @@ COMMENT= Patch file automation for FreeBSD-ports
LICENSE= BSD2CLAUSE
-RUN_DEPENDS= portlint:${PORTSDIR}/ports-mgmt/portlint
+RUN_DEPENDS= portlint:ports-mgmt/portlint
USE_GITHUB= yes
GH_ACCOUNT= ultima1252
@@ -23,14 +23,14 @@ OPTIONS_DEFINE= GIT PORTTOOLS POUDRIERE
OPTIONS_DEFAULT= GIT PORTTOOLS POUDRIERE
GIT_DESC= Git support
-GIT_RUN_DEPENDS= git:${PORTSDIR}/devel/git
+GIT_RUN_DEPENDS= git:devel/git
PORTTOOLS_DESC= Porttools support
-PORTTOOLS_RUN_DEPENDS= port:${PORTSDIR}/ports-mgmt/porttools
+PORTTOOLS_RUN_DEPENDS= port:ports-mgmt/porttools
POUDRIERE_DESC= Poudriere and parallel build support
-POUDRIERE_RUN_DEPENDS= poudriere:${PORTSDIR}/ports-mgmt/poudriere \
- tmux:${PORTSDIR}/sysutils/tmux
+POUDRIERE_RUN_DEPENDS= poudriere:ports-mgmt/poudriere \
+ tmux:sysutils/tmux
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/portest ${STAGEDIR}${PREFIX}/sbin/portest
diff --git a/ports-mgmt/portfind/Makefile b/ports-mgmt/portfind/Makefile
index 0270ae941d77..699651dd5d36 100644
--- a/ports-mgmt/portfind/Makefile
+++ b/ports-mgmt/portfind/Makefile
@@ -10,8 +10,8 @@ COMMENT= Search the ports tree
LICENSE= BSD3CLAUSE
-BUILD_DEPENDS= sqlite3:${PORTSDIR}/databases/sqlite3
-RUN_DEPENDS= sqlite3:${PORTSDIR}/databases/sqlite3
+BUILD_DEPENDS= sqlite3:databases/sqlite3
+RUN_DEPENDS= sqlite3:databases/sqlite3
USES= perl5
USE_PERL5= build
diff --git a/ports-mgmt/portless/Makefile b/ports-mgmt/portless/Makefile
index 80d4cb8e19e7..1026173c2f84 100644
--- a/ports-mgmt/portless/Makefile
+++ b/ports-mgmt/portless/Makefile
@@ -11,7 +11,7 @@ DISTFILES= # none
MAINTAINER= mkamm@gmx.net
COMMENT= Quick display of files inside the FreeBSD ports tree
-RUN_DEPENDS= ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
+RUN_DEPENDS= ${LOCALBASE}/bin/bash:shells/bash
USES= shebangfix
NO_WRKSUBDIR= yes
diff --git a/ports-mgmt/portscout/Makefile b/ports-mgmt/portscout/Makefile
index ee6e9c8ad215..477f4346f907 100644
--- a/ports-mgmt/portscout/Makefile
+++ b/ports-mgmt/portscout/Makefile
@@ -14,14 +14,14 @@ COMMENT= Tool to scan for new versions of FreeBSD ports
LICENSE= BSD2CLAUSE
-RUN_DEPENDS= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI \
- p5-Proc-Queue>=0:${PORTSDIR}/devel/p5-Proc-Queue \
- p5-Net>=0:${PORTSDIR}/net/p5-Net \
- p5-URI>=0:${PORTSDIR}/net/p5-URI \
- p5-XML-XPath>=0:${PORTSDIR}/textproc/p5-XML-XPath \
- p5-MIME-Lite>=0:${PORTSDIR}/mail/p5-MIME-Lite \
- p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
- p5-JSON>0:${PORTSDIR}/converters/p5-JSON
+RUN_DEPENDS= p5-DBI>=0:databases/p5-DBI \
+ p5-Proc-Queue>=0:devel/p5-Proc-Queue \
+ p5-Net>=0:net/p5-Net \
+ p5-URI>=0:net/p5-URI \
+ p5-XML-XPath>=0:textproc/p5-XML-XPath \
+ p5-MIME-Lite>=0:mail/p5-MIME-Lite \
+ p5-libwww>=0:www/p5-libwww \
+ p5-JSON>0:converters/p5-JSON
OPTIONS_DEFINE= DOCS HTTPS
OPTIONS_DEFAULT= HTTPS PGSQL
@@ -37,13 +37,13 @@ SHEBANG_FILES= ${WRKSRC}/portscout.pl
PORTDOCS= UPDATING portscout-portconfig.txt xml-datasrc-example.xml
-HTTPS_RUN_DEPENDS= p5-LWP-Protocol-https>=0:${PORTSDIR}/www/p5-LWP-Protocol-https
+HTTPS_RUN_DEPENDS= p5-LWP-Protocol-https>=0:www/p5-LWP-Protocol-https
SQLITE_USES= sqlite
-SQLITE_RUN_DEPENDS= p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite
+SQLITE_RUN_DEPENDS= p5-DBD-SQLite>=0:databases/p5-DBD-SQLite
PGSQL_USES= pgsql
-PGSQL_RUN_DEPENDS= p5-DBD-Pg>=0:${PORTSDIR}/databases/p5-DBD-Pg
+PGSQL_RUN_DEPENDS= p5-DBD-Pg>=0:databases/p5-DBD-Pg
.include <bsd.port.options.mk>
diff --git a/ports-mgmt/portshaker-config/Makefile b/ports-mgmt/portshaker-config/Makefile
index 3e535d00550d..5580daaaef61 100644
--- a/ports-mgmt/portshaker-config/Makefile
+++ b/ports-mgmt/portshaker-config/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= ports-mgmt
MAINTAINER= romain@FreeBSD.org
COMMENT= Simple configuration manager for portshaker
-BUILD_DEPENDS= portshaker:${PORTSDIR}/ports-mgmt/portshaker
+BUILD_DEPENDS= portshaker:ports-mgmt/portshaker
RUN_DEPENDS:= ${BUILD_DEPENDS}
MASTERDIR= ${.CURDIR}/../portshaker
diff --git a/ports-mgmt/portshaker/Makefile b/ports-mgmt/portshaker/Makefile
index c6dc273f83fd..a2f6e9a2bd4f 100644
--- a/ports-mgmt/portshaker/Makefile
+++ b/ports-mgmt/portshaker/Makefile
@@ -21,14 +21,14 @@ OPTIONS_DEFAULT= RSYNC SVN
RSYNC_DESC= rsync support
GIT_DESC= git support
HG_DESC= mercurial support
-RSYNC_RUN_DEPENDS= rsync:${PORTSDIR}/net/rsync
+RSYNC_RUN_DEPENDS= rsync:net/rsync
.if defined(WITH_SUBVERSION_VER) && ${WITH_SUBVERSION_VER} == 18
-SVN_RUN_DEPENDS= svn:${PORTSDIR}/devel/subversion18
+SVN_RUN_DEPENDS= svn:devel/subversion18
.else
-SVN_RUN_DEPENDS= svn:${PORTSDIR}/devel/subversion
+SVN_RUN_DEPENDS= svn:devel/subversion
.endif
-GIT_RUN_DEPENDS= git:${PORTSDIR}/devel/git
-HG_RUN_DEPENDS= hg:${PORTSDIR}/devel/mercurial
+GIT_RUN_DEPENDS= git:devel/git
+HG_RUN_DEPENDS= hg:devel/mercurial
.else
OPTIONS_DEFINE= BSDSHARP ENLIGHTENMENT GECKO HASKELL MARCUSCOM TEXLIVE XORG
OPTIONS_DEFAULT= BSDSHARP
diff --git a/ports-mgmt/porttools/Makefile b/ports-mgmt/porttools/Makefile
index 83c0a33212f5..661c27762e7e 100644
--- a/ports-mgmt/porttools/Makefile
+++ b/ports-mgmt/porttools/Makefile
@@ -10,10 +10,10 @@ COMMENT= Tools for testing and submitting port updates and new ports
LICENSE= BSD2CLAUSE
-RUN_DEPENDS= portlint:${PORTSDIR}/ports-mgmt/portlint \
- cdiff:${PORTSDIR}/textproc/cdiff \
- sudo:${PORTSDIR}/security/sudo \
- svn:${PORTSDIR}/devel/subversion
+RUN_DEPENDS= portlint:ports-mgmt/portlint \
+ cdiff:textproc/cdiff \
+ sudo:security/sudo \
+ svn:devel/subversion
USE_GITHUB= yes
GH_ACCOUNT= skreuzer
diff --git a/ports-mgmt/porttree/Makefile b/ports-mgmt/porttree/Makefile
index 252cd934bc84..2356c79b2e1c 100644
--- a/ports-mgmt/porttree/Makefile
+++ b/ports-mgmt/porttree/Makefile
@@ -13,10 +13,10 @@ LICENSE= MIT
USES= python tar:bzip2
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}networkx>=1.5:${PORTSDIR}/math/py-networkx
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}networkx>=1.5:math/py-networkx
.if target(gen-dist)
-FETCH_DEPENDS+= svn:${PORTSDIR}/devel/subversion
+FETCH_DEPENDS+= svn:devel/subversion
.endif
SVNROOT?= http://porttree.googlecode.com/svn/trunk/
diff --git a/ports-mgmt/portupgrade-devel/Makefile b/ports-mgmt/portupgrade-devel/Makefile
index e512e0812c3e..db3712580d96 100644
--- a/ports-mgmt/portupgrade-devel/Makefile
+++ b/ports-mgmt/portupgrade-devel/Makefile
@@ -43,7 +43,7 @@ INSTALL_TARGET+= install-doc
.endif
# For PKG_DBDRIVER={bdb_btree,bdb_hash}
-RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/bdb.so:${PORTSDIR}/databases/ruby-bdb
+RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/bdb.so:databases/ruby-bdb
regression-test: patch
cd ${WRKSRC} && ${MAKE} test
diff --git a/ports-mgmt/portupgrade/Makefile b/ports-mgmt/portupgrade/Makefile
index 52e7fd635df2..a08e28b15956 100644
--- a/ports-mgmt/portupgrade/Makefile
+++ b/ports-mgmt/portupgrade/Makefile
@@ -43,7 +43,7 @@ INSTALL_TARGET+= install-doc
.endif
# For PKG_DBDRIVER={bdb_btree,bdb_hash}
-RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/bdb.so:${PORTSDIR}/databases/ruby-bdb
+RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/bdb.so:databases/ruby-bdb
post-install:
${MKDIR} ${STAGEDIR}${PREFIX}/lib/compat/pkg
diff --git a/ports-mgmt/poudriere-devel/Makefile b/ports-mgmt/poudriere-devel/Makefile
index 173c9e87b14b..e1e3a60395ef 100644
--- a/ports-mgmt/poudriere-devel/Makefile
+++ b/ports-mgmt/poudriere-devel/Makefile
@@ -29,7 +29,7 @@ OPTIONS_DEFAULT=ZSH
OPTIONS_SUB= yes
QEMU_DESC= Add qemu-user-static to compile ports for non-x86 architectures
-QEMU_RUN_DEPENDS= qemu-user-static>0:${PORTSDIR}/emulators/qemu-user-static
+QEMU_RUN_DEPENDS= qemu-user-static>0:emulators/qemu-user-static
post-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/share/zsh/site-functions/
diff --git a/ports-mgmt/poudriere/Makefile b/ports-mgmt/poudriere/Makefile
index 7b2f56037793..a86c311b8b53 100644
--- a/ports-mgmt/poudriere/Makefile
+++ b/ports-mgmt/poudriere/Makefile
@@ -25,7 +25,7 @@ OPTIONS_DEFAULT=ZSH
OPTIONS_SUB= yes
QEMU_DESC= Add qemu-user-static to compile ports for non-x86 architectures
-QEMU_RUN_DEPENDS= qemu-user-static>0:${PORTSDIR}/emulators/qemu-user-static
+QEMU_RUN_DEPENDS= qemu-user-static>0:emulators/qemu-user-static
post-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/share/zsh/site-functions/
diff --git a/ports-mgmt/py-pytoport/Makefile b/ports-mgmt/py-pytoport/Makefile
index df438f5e56b2..140c9005ffd2 100644
--- a/ports-mgmt/py-pytoport/Makefile
+++ b/ports-mgmt/py-pytoport/Makefile
@@ -13,7 +13,7 @@ COMMENT= Generate FreeBSD ports from Python modules on PyPI
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}spdx-lookup>=0.3.0:${PORTSDIR}/misc/py-spdx-lookup
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}spdx-lookup>=0.3.0:misc/py-spdx-lookup
USES= python:3.3+
USE_PYTHON= autoplist distutils
diff --git a/ports-mgmt/redports-node/Makefile b/ports-mgmt/redports-node/Makefile
index ec2abadfa791..42d2f2e97d50 100644
--- a/ports-mgmt/redports-node/Makefile
+++ b/ports-mgmt/redports-node/Makefile
@@ -12,9 +12,9 @@ COMMENT= Redports building node
LICENSE= BSD2CLAUSE
-RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss \
- poudriere:${PORTSDIR}/ports-mgmt/poudriere \
- ${LOCALBASE}/bin/ccache:${PORTSDIR}/devel/ccache
+RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss \
+ poudriere:ports-mgmt/poudriere \
+ ${LOCALBASE}/bin/ccache:devel/ccache
NO_BUILD= yes
USE_PHP= curl hash json openssl pcntl phar
diff --git a/ports-mgmt/synth/Makefile b/ports-mgmt/synth/Makefile
index e5c1b83dd081..93ac0a0953f3 100644
--- a/ports-mgmt/synth/Makefile
+++ b/ports-mgmt/synth/Makefile
@@ -13,8 +13,8 @@ COMMENT= Custom package repository builder for FreeBSD and DragonFly
LICENSE= ISCL
LICENSE_FILE= ${WRKSRC}/License.txt
-#BUILD_DEPENDS= ${LOCALBASE}/lib/gnat/${IFM}.gpr:${PORTSDIR}/misc/${IFM} \
-# ${LOCALBASE}/lib/gnat/${AC}.gpr:${PORTSDIR}/devel/${AC}
+#BUILD_DEPENDS= ${LOCALBASE}/lib/gnat/${IFM}.gpr:misc/${IFM} \
+# ${LOCALBASE}/lib/gnat/${AC}.gpr:devel/${AC}
USES= ada:6 ncurses:port
USE_GITHUB= yes
diff --git a/ports-mgmt/tinderbox/Makefile b/ports-mgmt/tinderbox/Makefile
index d5b4daf7892e..9aabd48bc506 100644
--- a/ports-mgmt/tinderbox/Makefile
+++ b/ports-mgmt/tinderbox/Makefile
@@ -11,7 +11,7 @@ DIST_SUBDIR= ${PORTNAME}
MAINTAINER= crees@FreeBSD.org
COMMENT= Port build tinderbox system
-RUN_DEPENDS= dialog4ports-static:${PORTSDIR}/ports-mgmt/dialog4ports-static
+RUN_DEPENDS= dialog4ports-static:ports-mgmt/dialog4ports-static
CONFLICTS= tinderbox-devel-[0-9]*
@@ -61,7 +61,7 @@ USES+= pgsql
.if defined(WEBUI)
USE_PHP+= pgsql pdo_pgsql
.endif
-RUN_DEPENDS+= p5-DBD-Pg>=0:${PORTSDIR}/databases/p5-DBD-Pg
+RUN_DEPENDS+= p5-DBD-Pg>=0:databases/p5-DBD-Pg
.endif
.if ${PORT_OPTIONS:MMYSQL}
@@ -69,36 +69,36 @@ RUN_DEPENDS+= p5-DBD-Pg>=0:${PORTSDIR}/databases/p5-DBD-Pg
USE_PHP+= mysql pdo_mysql
.endif
USE_MYSQL= yes
-RUN_DEPENDS+= p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql
+RUN_DEPENDS+= p5-DBD-mysql>=0:databases/p5-DBD-mysql
.endif
.if ${PORT_OPTIONS:MSQLITE}
.if defined(WEBUI)
USE_PHP+= sqlite3 pdo_sqlite
.endif
-RUN_DEPENDS+= p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite
+RUN_DEPENDS+= p5-DBD-SQLite>=0:databases/p5-DBD-SQLite
.endif
.if ${PORT_OPTIONS:MAPACHE}
USE_APACHE_RUN= 22+
.elif ${PORT_OPTIONS:MLIGHTTPD}
-RUN_DEPENDS+= lighttpd:${PORTSDIR}/www/lighttpd
+RUN_DEPENDS+= lighttpd:www/lighttpd
.elif ${PORT_OPTIONS:MHIAWATHA}
-RUN_DEPENDS+= hiawatha:${PORTSDIR}/www/hiawatha
+RUN_DEPENDS+= hiawatha:www/hiawatha
.elif ${PORT_OPTIONS:MNGINX}
-RUN_DEPENDS+= nginx:${PORTSDIR}/www/nginx
+RUN_DEPENDS+= nginx:www/nginx
.endif
.if ${PORT_OPTIONS:MEMAILS}
-RUN_DEPENDS+= p5-Net>=0:${PORTSDIR}/net/p5-Net
+RUN_DEPENDS+= p5-Net>=0:net/p5-Net
.endif
.if ${PORT_OPTIONS:MLSOF}
-RUN_DEPENDS+= lsof:${PORTSDIR}/sysutils/lsof
+RUN_DEPENDS+= lsof:sysutils/lsof
.endif
.if ${PORT_OPTIONS:MLOG_COMPRESS}
-RUN_DEPENDS+= p5-Compress-Bzip2>=0:${PORTSDIR}/archivers/p5-Compress-Bzip2
+RUN_DEPENDS+= p5-Compress-Bzip2>=0:archivers/p5-Compress-Bzip2
.endif
post-patch:
diff --git a/ports-mgmt/wanted-ports/files/wanted-ports.in b/ports-mgmt/wanted-ports/files/wanted-ports.in
index 3be93c465421..c8b792cc89f1 100644
--- a/ports-mgmt/wanted-ports/files/wanted-ports.in
+++ b/ports-mgmt/wanted-ports/files/wanted-ports.in
@@ -116,7 +116,7 @@ EOF
# it. Since we have no way of knowing what files are significant from
# among whatever the port installs (and the port may not even be
# installed yet) use the form
-# "pkgname>=n.nn:${PORTSDIR}/category/portname" where n.nn is the
+# "pkgname>=n.nn:category/portname" where n.nn is the
# currently available version of the port. Requires the INDEX to have
# been installed. This can return any number of dependency lines,
# including none.