aboutsummaryrefslogtreecommitdiff
path: root/print/cups-base/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/cups-base/Makefile')
-rw-r--r--print/cups-base/Makefile16
1 files changed, 13 insertions, 3 deletions
diff --git a/print/cups-base/Makefile b/print/cups-base/Makefile
index ae7b70ca248b..299fe851844e 100644
--- a/print/cups-base/Makefile
+++ b/print/cups-base/Makefile
@@ -9,19 +9,29 @@
PORTNAME= cups-base
PORTVERSION= ${CUPS_PORTVER}
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= ${CUPS_PORTEPOCH}
CATEGORIES= print
MASTER_SITES= ${CUPS_MASTER_SITES}
MAINTAINER= alane@FreeBSD.org
+pre-install:
+ -@${ECHO_CMD} "===>" Stopping cupsd ...
+ -killall cupsd || true
+ -rm -fr ${PREFIX}/etc/cups/certs/* || true
+
post-install:
- cd ${PREFIX}/etc/rc.d; ${MV} cups cups.sh.sample
+ cd ${CUPS_RCDIR}; ${MV} cups cups.sh.sample
${FIND} ${PREFIX}/man/cat* -type l -name '*.0' -delete
${FIND} ${PREFIX}/man/fr/cat* -type l -name '*.0' -delete
- ${MKDIR} ${CUPS_SPOOLDIR}
+ ${MKDIR} ${CUPS_SPOOLDIR} ${CUPS_SPOOLDIR}/tmp
${CHOWN} -R ${CUPSOWN}:${CUPSGRP} ${CUPS_SPOOLDIR}
+ ${CHMOD} -R g+w ${CUPS_SPOOLDIR}
+.for f in classes.conf client.conf cupsd.conf printers.conf
+ cd ${CUPS_ETCDIR};\
+ if test ! -f ${f}.N; then cp -p ${f} ${f}.N; else true; fi
+.endfor # classes.conf client.conf cupsd.conf printers.conf
.include "${.CURDIR}/../../print/cups/Makefile.common"
.include <bsd.port.pre.mk>