aboutsummaryrefslogtreecommitdiff
path: root/print/lilypond/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'print/lilypond/Makefile')
-rw-r--r--print/lilypond/Makefile37
1 files changed, 16 insertions, 21 deletions
diff --git a/print/lilypond/Makefile b/print/lilypond/Makefile
index 7bb59047d762..1a51e6ddc1d6 100644
--- a/print/lilypond/Makefile
+++ b/print/lilypond/Makefile
@@ -1,6 +1,5 @@
PORTNAME= lilypond
-DISTVERSION= 2.22.2
-PORTREVISION= 3
+DISTVERSION= 2.24.1
CATEGORIES= print audio
MASTER_SITES= http://lilypond.org/download/source/v${DISTVERSION:R}/
@@ -22,23 +21,24 @@ BUILD_DEPENDS= bash:shells/bash \
zip:archivers/zip
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
+ libgc-threaded.so:devel/boehm-gc-threaded \
libgmp.so:math/gmp \
+ libguile-2.2.so:lang/guile2 \
libharfbuzz.so:print/harfbuzz \
libltdl.so:devel/libltdl
RUN_DEPENDS= ${LOCALBASE}/share/fonts/dejavu/DejaVuSans-Bold.ttf:x11-fonts/dejavu \
mftrace:print/mftrace
USES= bison:build compiler:c++11-lib cpe ghostscript gmake gnome \
- magick:7,build perl5 pkgconfig python:3.5+ tex
-USE_CXXSTD= c++11
+ magick:7,build perl5 pkgconfig python:3.5+
+USE_CXXSTD= c++14
USE_GNOME= pango
USE_PERL5= build
-USE_TEX= latex
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --with-texgyre-dir=${LOCALBASE}/${TEXMFDISTDIR}/fonts/opentype/public/tex-gyre
CONFIGURE_ENV+= ac_cv_prog_MAKEINFO="${LOCALBASE}/bin/makeinfo" \
FLEX=${FLEX} \
+ GUILE_FLAVOR=guile-2.2 \
HOME=${WRKDIR} \
YACC=${YACC}
@@ -49,35 +49,30 @@ CONFLICTS_INSTALL= lilypond-devel
BINARY_ALIAS= python=${PYTHON_VERSION}
-INFO= lilypond-changes lilypond-contributor lilypond-essay \
- lilypond-extending lilypond-internals lilypond-learning \
- lilypond-notation lilypond-snippets lilypond-usage \
+INFO= lilypond-changes \
+ lilypond-contributor \
+ lilypond-essay \
+ lilypond-extending \
+ lilypond-internals \
+ lilypond-learning \
+ lilypond-notation \
+ lilypond-snippets \
+ lilypond-usage \
music-glossary
PLIST_SUB= DISTVERSION=${DISTVERSION}
-OPTIONS_DEFINE= GUILE2 NLS URW
+OPTIONS_DEFINE= NLS URW
OPTIONS_SUB= yes
-GUILE2_DESC= guile2 instead guile (incurs performance penalty)
URW_DESC= Use bundled URW fonts
-GUILE2_LIB_DEPENDS= libgc-threaded.so:devel/boehm-gc-threaded \
- libguile-2.2.so:lang/guile2
-GUILE2_LIB_DEPENDS_OFF= libguile.so:lang/guile1
-GUILE2_CONFIGURE_ENV= GUILE_FLAVOR=guile-2.2
-
NLS_USES= gettext
-NLS_USES_OFF= gettext-tools
URW_BUILD_DEPENDS= urw-base35-fonts>0:x11-fonts/urw-base35-fonts
URW_RUN_DEPENDS_OFF= urw-base35-fonts>0:x11-fonts/urw-base35-fonts
URW_CONFIGURE_WITH= urwotf-dir=${LOCALBASE}/share/fonts/urw-base35-fonts
post-patch:
- @${REINPLACE_CMD} -e 's|<FlexLexer.h>|"/usr/include/FlexLexer.h"|' \
- ${WRKSRC}/lily/include/includable-lexer.hh
- @${REINPLACE_CMD} -e 's|$save_CXXFLAGS -Werror=suggest-override|$save_CXXFLAGS|' \
- ${WRKSRC}/configure
@${SED} -e 's|%%FONTDIR%%|${WRKDIR}/fontconfig/cache/|' \
${FILESDIR}/fonts.conf > ${WRKDIR}/.fonts.conf