aboutsummaryrefslogtreecommitdiff
path: root/print/pdfmixtool/files/patch-CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'print/pdfmixtool/files/patch-CMakeLists.txt')
-rw-r--r--print/pdfmixtool/files/patch-CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/print/pdfmixtool/files/patch-CMakeLists.txt b/print/pdfmixtool/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..9229066a2c84
--- /dev/null
+++ b/print/pdfmixtool/files/patch-CMakeLists.txt
@@ -0,0 +1,15 @@
+--- CMakeLists.txt.orig 2024-01-16 00:28:44 UTC
++++ CMakeLists.txt
+@@ -142,6 +142,12 @@ target_link_libraries (
+ ${QT_LIBRARIES}
+ )
+
++target_compile_options(
++ pdfmixtool
++ PUBLIC
++ ${MAGICK_CFLAGS_OTHER}
++)
++
+ INSTALL(TARGETS pdfmixtool RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
+ INSTALL(FILES resources/eu.scarpetta.PDFMixTool.desktop DESTINATION ${CMAKE_INSTALL_DATADIR}/applications)
+ INSTALL(FILES resources/eu.scarpetta.PDFMixTool.appdata.xml DESTINATION ${CMAKE_INSTALL_DATADIR}/metainfo)