aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
Diffstat (limited to 'print')
-rw-r--r--print/hplip/Makefile2
-rw-r--r--print/hplip/files/patch-hplip-plugin35
2 files changed, 36 insertions, 1 deletions
diff --git a/print/hplip/Makefile b/print/hplip/Makefile
index c0f440632161..2b87d39d94ca 100644
--- a/print/hplip/Makefile
+++ b/print/hplip/Makefile
@@ -3,7 +3,7 @@
PORTNAME= hplip
PORTVERSION= 3.13.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= print
MASTER_SITES= SF
diff --git a/print/hplip/files/patch-hplip-plugin b/print/hplip/files/patch-hplip-plugin
new file mode 100644
index 000000000000..b0f55eb9af43
--- /dev/null
+++ b/print/hplip/files/patch-hplip-plugin
@@ -0,0 +1,35 @@
+diff -ru hplip-3.11.12.DIST/Makefile.in hplip-3.11.12/Makefile.in
+--- Makefile.in 2011-12-09 12:23:55.000000000 +0100
++++ Makefile.in 2011-12-30 16:28:26.255313535 +0100
+@@ -503,7 +503,7 @@
+ @HPIJS_INSTALL_TRUE@@HPLIP_BUILD_TRUE@ $(am__DEPENDENCIES_1)
+ hpijs_LINK = $(LIBTOOL) --tag=CXX $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
+ --mode=link $(CXXLD) $(hpijs_CXXFLAGS) $(CXXFLAGS) \
+- $(AM_LDFLAGS) $(LDFLAGS) -o $@
++ $(AM_LDFLAGS) $(LDFLAGS) -Wl,--export-dynamic -o $@
+ am__hplipjs_SOURCES_DIST = prnt/filters/hplipjs.c
+ @FULL_BUILD_TRUE@@HPLIP_BUILD_TRUE@am_hplipjs_OBJECTS = \
+ @FULL_BUILD_TRUE@@HPLIP_BUILD_TRUE@ hplipjs.$(OBJEXT)
+Only in hplip-3.11.12: dd
+diff -ru hplip-3.11.12.DIST/prnt/hpijs/hpijs.cpp hplip-3.11.12/prnt/hpijs/hpijs.cpp
+--- prnt/hpijs/hpijs.cpp 2011-12-09 12:18:33.000000000 +0100
++++ prnt/hpijs/hpijs.cpp 2011-12-30 16:27:10.976752128 +0100
+@@ -43,6 +43,9 @@
+ #include "hpijs.h"
+ #include "services.h"
+
++#undef stderr;
++FILE *stderr;
++
+ extern void SendDbusMessage (const char *dev, const char *printer, int code,
+ const char *username, const int jobid, const char *title);
+
+@@ -586,6 +589,7 @@
+ int status = EXIT_FAILURE;
+ int ret, n, i, kn=0, width, k_width;
+
++ stderr = __stderrp;
+ openlog("hpijs", LOG_PID, LOG_DAEMON);
+
+ if (argc > 1)
+