aboutsummaryrefslogtreecommitdiff
path: root/science/2d-rewriter/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/2d-rewriter/Makefile')
-rw-r--r--science/2d-rewriter/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/science/2d-rewriter/Makefile b/science/2d-rewriter/Makefile
new file mode 100644
index 000000000000..4e678569a11a
--- /dev/null
+++ b/science/2d-rewriter/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: 2d-rewriter
+# Date created: 8 December 2007
+# Whom: Igor Serikov <bt@turtle.freedns.us>
+#
+# $FreeBSD$
+#
+
+PORTNAME= 2d-rewriter
+DISTVERSION= 1.2
+CATEGORIES= science
+MASTER_SITES= http://www.crowdeduniverse.org/distfiles/
+
+MAINTAINER= bt@turtle.freedns.us
+COMMENT= Cellular automata simulator
+
+MAN1= 2d-rewriter.1
+MANCOMPRESSED= yes
+USE_IMAKE= yes
+
+post-install:
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+ (cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
+.endif
+
+.include <bsd.port.mk>