aboutsummaryrefslogtreecommitdiff
path: root/science/mmg/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/mmg/Makefile')
-rw-r--r--science/mmg/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/science/mmg/Makefile b/science/mmg/Makefile
index 66c4c5d53670..20acba012afe 100644
--- a/science/mmg/Makefile
+++ b/science/mmg/Makefile
@@ -1,6 +1,6 @@
PORTNAME= mmg
-PORTVERSION= 5.7.3
DISTVERSIONPREFIX= v
+DISTVERSION= 5.7.3
CATEGORIES= science
MAINTAINER= ports@FreeBSD.org
@@ -10,21 +10,19 @@ WWW= https://www.mmgtools.org/
LICENSE= LGPL3
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= git:devel/git \
- bash:shells/bash
LIB_DEPENDS= libscotch.so:cad/scotch \
- libElas.so:science/linearelasticity \
+ libElas.so:science/linearelasticity \
libvtksys-${VTK_VER}.so:math/vtk${VTK_VER:R}
-USES= cmake:testing perl5 shebangfix
+USES= cmake perl5 shebangfix
USE_PERL5= build
-SHEBANG_FILES= scripts/*.sh
+SHEBANG_FILES= scripts/*.pl
+USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= MmgTools
CMAKE_ON= BUILD_SHARED_LIBS
-USE_LDCONFIG= yes
.include <../../math/vtk9/Makefile.version>
.include <bsd.port.mk>