aboutsummaryrefslogtreecommitdiff
path: root/science/openmc/files/patch-CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'science/openmc/files/patch-CMakeLists.txt')
-rw-r--r--science/openmc/files/patch-CMakeLists.txt21
1 files changed, 2 insertions, 19 deletions
diff --git a/science/openmc/files/patch-CMakeLists.txt b/science/openmc/files/patch-CMakeLists.txt
index 039d87adf5a2..a07a4413bce5 100644
--- a/science/openmc/files/patch-CMakeLists.txt
+++ b/science/openmc/files/patch-CMakeLists.txt
@@ -1,9 +1,6 @@
-- workaround for https://github.com/openmc-dev/openmc/issues/1891
-- fix xtl,xtensor dependencies
-
---- CMakeLists.txt.orig 2021-06-14 14:22:01 UTC
+--- CMakeLists.txt.orig 2022-08-20 16:50:43 UTC
+++ CMakeLists.txt
-@@ -174,7 +174,7 @@ if(GIT_FOUND AND EXISTS "${CMAKE_CURRENT_SOURCE_DIR}/.
+@@ -211,7 +211,7 @@ if(GIT_FOUND AND EXISTS "${CMAKE_CURRENT_SOURCE_DIR}/.
endif()
# Check to see if submodules exist (by checking one)
@@ -12,17 +9,3 @@
message(FATAL_ERROR "The git submodules were not downloaded! GIT_SUBMODULE was \
turned off or failed. Please update submodules and try again.")
endif()
-@@ -206,9 +206,10 @@ if (NOT (CMAKE_VERSION VERSION_LESS 3.13))
- cmake_policy(SET CMP0079 NEW)
- endif()
-
--add_subdirectory(vendor/xtl)
--set(xtl_DIR ${CMAKE_CURRENT_BINARY_DIR}/vendor/xtl)
--add_subdirectory(vendor/xtensor)
-+#add_subdirectory(vendor/xtl)
-+#set(xtl_DIR ${CMAKE_CURRENT_BINARY_DIR}/vendor/xtl)
-+#add_subdirectory(vendor/xtensor)
-+find_package(xtensor REQUIRED)
-
- #===============================================================================
- # GSL header-only library