aboutsummaryrefslogtreecommitdiff
path: root/science/paje/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/paje/Makefile')
-rw-r--r--science/paje/Makefile19
1 files changed, 18 insertions, 1 deletions
diff --git a/science/paje/Makefile b/science/paje/Makefile
index 44feb9fe5889..017456b547b3 100644
--- a/science/paje/Makefile
+++ b/science/paje/Makefile
@@ -3,7 +3,7 @@
PORTNAME= paje
PORTVERSION= 1.97
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= science gnustep
MASTER_SITES= SF/${PORTNAME}/Releases
DISTNAME= Paje_${PORTVERSION}
@@ -24,4 +24,21 @@ post-patch:
${REINPLACE_CMD} -e 's|^GNUSTEP_INSTALLATION_DOMAIN|#GNUSTEP_INSTALLATION_DOMAIN|' \
${WRKSRC}/GNUmakefile
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/GNUstep/Local/Applications/Paje.app/Paje \
+ ${STAGEDIR}${PREFIX}/GNUstep/Local/Library/Bundles/Paje/AggregatingFilter.bundle/AggregatingFilter \
+ ${STAGEDIR}${PREFIX}/GNUstep/Local/Library/Bundles/Paje/ContainerFilter.bundle/ContainerFilter \
+ ${STAGEDIR}${PREFIX}/GNUstep/Local/Library/Bundles/Paje/EntityTypeFilter.bundle/EntityTypeFilter \
+ ${STAGEDIR}${PREFIX}/GNUstep/Local/Library/Bundles/Paje/FieldFilter.bundle/FieldFilter \
+ ${STAGEDIR}${PREFIX}/GNUstep/Local/Library/Bundles/Paje/FileReader.bundle/FileReader \
+ ${STAGEDIR}${PREFIX}/GNUstep/Local/Library/Bundles/Paje/General.bundle/General \
+ ${STAGEDIR}${PREFIX}/GNUstep/Local/Library/Bundles/Paje/ImbricationFilter.bundle/ImbricationFilter \
+ ${STAGEDIR}${PREFIX}/GNUstep/Local/Library/Bundles/Paje/OrderFilter.bundle/OrderFilter \
+ ${STAGEDIR}${PREFIX}/GNUstep/Local/Library/Bundles/Paje/PajeEventDecoder.bundle/PajeEventDecoder \
+ ${STAGEDIR}${PREFIX}/GNUstep/Local/Library/Bundles/Paje/PajeSimulator.bundle/PajeSimulator \
+ ${STAGEDIR}${PREFIX}/GNUstep/Local/Library/Bundles/Paje/ReductionFilter.bundle/ReductionFilter \
+ ${STAGEDIR}${PREFIX}/GNUstep/Local/Library/Bundles/Paje/SpaceTimeViewer.bundle/SpaceTimeViewer \
+ ${STAGEDIR}${PREFIX}/GNUstep/Local/Library/Bundles/Paje/StatViewer.bundle/StatViewer \
+ ${STAGEDIR}${PREFIX}/GNUstep/Local/Library/Bundles/Paje/StorageController.bundle/StorageController
+
.include <bsd.port.mk>