aboutsummaryrefslogtreecommitdiff
path: root/science/plumed/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/plumed/Makefile')
-rw-r--r--science/plumed/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/science/plumed/Makefile b/science/plumed/Makefile
index 72f7d9e5ee54..9930e357c40b 100644
--- a/science/plumed/Makefile
+++ b/science/plumed/Makefile
@@ -1,6 +1,7 @@
PORTNAME= plumed
DISTVERSIONPREFIX= v
DISTVERSION= 2.8b
+PORTREVISION= 1
CATEGORIES= science graphics
MAINTAINER= yuri@FreeBSD.org
@@ -12,9 +13,14 @@ LICENSE_FILE= ${WRKSRC}/COPYING.LESSER
BROKEN_i386= undefined reference to `__atomic_load'
BUILD_DEPENDS= bash:shells/bash
+LIB_DEPENDS= libblas.so:math/blas \
+ libfftw3.so:math/fftw3 \
+ libgsl.so:math/gsl \
+ liblapack.so:math/lapack
RUN_DEPENDS= bash:shells/bash
+TEST_DEPENDS= gawk:lang/gawk
-USES= autoreconf compiler:c++11-lang gmake pkgconfig shebangfix
+USES= autoreconf compiler:c++11-lang gmake localbase pkgconfig shebangfix
USE_LDCONFIG= yes
SHEBANG_GLOB= *.sh
@@ -31,7 +37,9 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-shared --disable-python
TEST_TARGET= check # the 'installcheck' target checks installed version
-# 27 tests are known to fail: https://github.com/plumed/plumed2/issues/782
+# 1 test is known to fail: https://github.com/plumed/plumed2/issues/782
+
+BINARY_ALIAS= make=${GMAKE} # only needed for tests
post-patch:
@${REINPLACE_CMD} -e 's|#! /bin/bash|#! ${LOCALBASE}/bin/bash|' ${WRKSRC}/src/lib/Makefile