aboutsummaryrefslogtreecommitdiff
path: root/science/py-PyNE/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/py-PyNE/Makefile')
-rw-r--r--science/py-PyNE/Makefile23
1 files changed, 18 insertions, 5 deletions
diff --git a/science/py-PyNE/Makefile b/science/py-PyNE/Makefile
index 70882d74548d..0c46bc576621 100644
--- a/science/py-PyNE/Makefile
+++ b/science/py-PyNE/Makefile
@@ -1,15 +1,18 @@
PORTNAME= PyNE
DISTVERSION= 0.7.5
+PORTREVISION= 1
CATEGORIES= science
MASTER_SITES= http://raw.githubusercontent.com/pyne/data/master/:decay \
http://raw.githubusercontent.com/pyne/data/master/:cram \
http://raw.githubusercontent.com/pyne/data/master/:dlc \
- http://raw.githubusercontent.com/pyne/data/master/:clc
+ http://raw.githubusercontent.com/pyne/data/master/:clc \
+ https://github.com/pyne/data/raw/master/:nuc_data
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTFILES= decay.tar.gz:decay \
cram.tar.gz:cram \
decay-linux-clang.tar.gz:dlc \
- cram-linux-clang.tar.gz:clc
+ cram-linux-clang.tar.gz:clc \
+ prebuilt_nuc_data.h5:nuc_data
DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
EXTRACT_ONLY= ${DISTNAME}.tar.gz
@@ -26,6 +29,7 @@ PY_DEPENDS= ${PYNUMPY} \
BUILD_DEPENDS= cmake:devel/cmake \
${PY_DEPENDS}
LIB_DEPENDS= libhdf5.so:science/hdf5 \
+ libMOAB.so:math/moab \
libsz.so:science/szip
RUN_DEPENDS= ${PY_DEPENDS}
@@ -39,8 +43,15 @@ GH_PROJECT= pyne
MAKE_ENV= DESTDIR=${STAGEDIR}
FFLAGS+= -fallow-argument-mismatch
-PYDISTUTILS_BUILDARGS= --slow # this chooses slow compilation of sources from {decay,cram}.tar.gz
- # over incompatible pre-compiled assembly from {decay,cram}-linux-clang.tar.gz
+# all arguments are described here: http://pyne.io/install/source.html#source
+PY_EXTRA_ARGS= --slow # this chooses slow compilation of sources from {decay,cram}.tar.gz
+ # over incompatible pre-compiled assembly from {decay,cram}-linux-clang.tar.gz
+PY_EXTRA_ARGS+= ${_MAKE_JOBS}
+PY_EXTRA_ARGS+= --hdf5 ${LOCALBASE}
+PY_EXTRA_ARGS+= --moab ${LOCALBASE}
+
+PYDISTUTILS_CONFIGUREARGS= ${PY_EXTRA_ARGS}
+PYDISTUTILS_BUILDARGS= ${PY_EXTRA_ARGS}
post-extract:
.for f in decay.tar.gz cram.tar.gz decay-linux-clang.tar.gz cram-linux-clang.tar.gz
@@ -48,9 +59,11 @@ post-extract:
.endfor
do-install:
- # install
+ # install project
cd ${INSTALL_WRKSRC} && \
${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${PYDISTUTILS_SETUP} ${PYDISTUTILS_INSTALL_TARGET}
+ # also install nuc_data.h5 because it is referred to in the code and is required by Jupyter notebooks
+ ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/prebuilt_nuc_data.h5 ${STAGEDIR}${PYTHON_SITELIBDIR}/pyne/nuc_data.h5
# strip
${STRIP_CMD} \
${STAGEDIR}${LOCALBASE}/lib/lib*.so \