aboutsummaryrefslogtreecommitdiff
path: root/science/py-cirq-core/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/py-cirq-core/Makefile')
-rw-r--r--science/py-cirq-core/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/science/py-cirq-core/Makefile b/science/py-cirq-core/Makefile
index 214d74adbf8c..f0b119b2fc28 100644
--- a/science/py-cirq-core/Makefile
+++ b/science/py-cirq-core/Makefile
@@ -1,18 +1,19 @@
PORTNAME= cirq-core
DISTVERSIONPREFIX= v
-DISTVERSION= 0.14.1
-CATEGORIES= science python
+DISTVERSION= 1.3.0
+CATEGORIES= science python # quantum-computing
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= yuri@FreeBSD.org
COMMENT= Framework for Noisy Intermediate Scale Quantum (NISQ) circuits
+WWW= https://github.com/quantumlib/cirq
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}cirq-google>0:science/py-cirq-google@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}duet>=0.2.0:net/py-duet@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}duet>=0.2.6:net/py-duet@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}matplotlib>0:math/py-matplotlib@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}networkx>0:math/py-networkx@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pandas>0:math/py-pandas@${PY_FLAVOR} \
@@ -23,7 +24,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}tqdm>0:misc/py-tqdm@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}typing-extensions>0:devel/py-typing-extensions@${PY_FLAVOR}
-USES= python:3.8+
+USES= python
USE_PYTHON= distutils autoplist
USE_GITHUB= yes