aboutsummaryrefslogtreecommitdiff
path: root/science/py-nibabel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/py-nibabel/Makefile')
-rw-r--r--science/py-nibabel/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/science/py-nibabel/Makefile b/science/py-nibabel/Makefile
index 41d0bc6f5515..3fbc19195c17 100644
--- a/science/py-nibabel/Makefile
+++ b/science/py-nibabel/Makefile
@@ -1,5 +1,5 @@
PORTNAME= nibabel
-DISTVERSION= 5.1.0
+DISTVERSION= 5.2.0
CATEGORIES= science python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -17,10 +17,12 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}packaging>=17:devel/py-packaging@${PY_FLAVOR}
USES= python:3.9+
-USE_PYTHON= pep517 concurrent autoplist pytest # 3 tests fail, see https://github.com/nipy/nibabel/issues/1235
+USE_PYTHON= pep517 concurrent autoplist pytest # 1 tests fails, see https://github.com/nipy/nibabel/issues/1285
NO_ARCH= yes
+TEST_ENV= ${MAKE_ENV} PATH=${STAGEDIR}${PREFIX}/bin
+
post-install:
@${REINPLACE_CMD} -i '' -e 's|#!python|#!${PYTHON_CMD}|' \
${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/nibabel/cmdline/diff.py \