aboutsummaryrefslogtreecommitdiff
path: root/science/simlib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'science/simlib/Makefile')
-rw-r--r--science/simlib/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/science/simlib/Makefile b/science/simlib/Makefile
index a9aab480172a..a6a5f4633a4b 100644
--- a/science/simlib/Makefile
+++ b/science/simlib/Makefile
@@ -10,16 +10,17 @@ WWW= https://www.fit.vutbr.cz/~peringer/SIMLIB/index.html.en
LICENSE= LGPL20
+BROKEN_riscv64= fails to compile: process.cc:53:3: module process.cc is not ported to this processor architecture
+NOT_FOR_ARCHS= aarch64 armv6 armv7 mips mips64 powerpc powerpc64 sparc64
+NOT_FOR_ARCHS_REASON= contains not working ${ARCH}-dependent assembly code
+
USES= gmake
+USE_CXXSTD= c++14
USE_LDCONFIG= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
CXXFLAGS+= -fPIC
-BROKEN_riscv64= fails to compile: process.cc:53:3: module process.cc is not ported to this processor architecture
-NOT_FOR_ARCHS= aarch64 armv6 armv7 mips mips64 powerpc powerpc64 sparc64
-NOT_FOR_ARCHS_REASON= contains not working ${ARCH}-dependent assembly code
+WRKSRC= ${WRKDIR}/${PORTNAME}
.include <bsd.port.options.mk>