aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
Diffstat (limited to 'science')
-rw-r--r--science/code_saturne/Makefile2
-rw-r--r--science/gnudatalanguage/Makefile2
-rw-r--r--science/py-MDAnalysis/Makefile2
-rw-r--r--science/py-ase/Makefile2
-rw-r--r--science/py-chempy/Makefile2
-rw-r--r--science/py-gpaw/Makefile2
-rw-r--r--science/py-obspy/Makefile2
-rw-r--r--science/py-pyteomics/Makefile4
-rw-r--r--science/py-scikit-optimize/Makefile2
-rw-r--r--science/rdkit/Makefile2
-rw-r--r--science/v_sim/Makefile2
-rw-r--r--science/wwplot/Makefile2
12 files changed, 13 insertions, 13 deletions
diff --git a/science/code_saturne/Makefile b/science/code_saturne/Makefile
index b74c666ea435..206e8b15fabb 100644
--- a/science/code_saturne/Makefile
+++ b/science/code_saturne/Makefile
@@ -26,7 +26,7 @@ USE_GITHUB= yes
GH_ACCOUNT= code-saturne
USES= autoreconf bison compiler:c11 fortran gettext gnome gmake \
- iconv libtool pyqt:5 python:3.6+ shebangfix
+ iconv libtool pyqt:5 python:3.7+ shebangfix
USE_GNOME= libxml2
USE_PYQT= core gui sip widgets xml_build
diff --git a/science/gnudatalanguage/Makefile b/science/gnudatalanguage/Makefile
index 31ede8f3120c..875dc7e54d0f 100644
--- a/science/gnudatalanguage/Makefile
+++ b/science/gnudatalanguage/Makefile
@@ -104,7 +104,7 @@ NETCDF_LIB_DEPENDS= libnetcdf.so:science/netcdf
NETCDF_CMAKE_ON= -DNETCDF:BOOL=YES -DHDF:BOOL=NO
NETCDF_CMAKE_OFF= -DNETCDF:BOOL=NO
-#PYTHON_USES= python:3.6+
+#PYTHON_USES= python:3.7+
#PYTHON_BUILD_DEPENDS= ${PYNUMPY}
#PYTHON_RUN_DEPENDS= ${PYNUMPY} \
# ${PYTHON_PKGNAMEPREFIX}matplotlib>0:math/py-matplotlib@${PY_FLAVOR}
diff --git a/science/py-MDAnalysis/Makefile b/science/py-MDAnalysis/Makefile
index e3d0a7142075..f3d5d837c8a0 100644
--- a/science/py-MDAnalysis/Makefile
+++ b/science/py-MDAnalysis/Makefile
@@ -25,7 +25,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}scipy>=1.0.0:science/py-scipy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>=1.4.0:devel/py-six@${PY_FLAVOR}
-USES= compiler:c++11-lang python:3.6+
+USES= compiler:c++11-lang python:3.7+
USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/science/py-ase/Makefile b/science/py-ase/Makefile
index ac32ebb24048..341ef925d0c7 100644
--- a/science/py-ase/Makefile
+++ b/science/py-ase/Makefile
@@ -16,7 +16,7 @@ RUN_DEPENDS= ${PYNUMPY} \
nwchem:science/nwchem
# optional dependencies: x11-toolkits/py-tkinter, www/py-flask (see https://wiki.fysik.dtu.dk/ase/install.html)
-USES= python:3.5+
+USES= python:3.7+
USE_PYTHON= distutils concurrent autoplist
NO_ARCH= yes
diff --git a/science/py-chempy/Makefile b/science/py-chempy/Makefile
index 34befbaa797c..df3400d96549 100644
--- a/science/py-chempy/Makefile
+++ b/science/py-chempy/Makefile
@@ -29,7 +29,7 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-cov>0:devel/py-pytest-cov@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-flakes>0:devel/py-pytest-flakes@${PY_FLAVOR}
-USES= python:3.5+
+USES= python:3.7+
USE_PYTHON= distutils autoplist
NO_ARCH= yes
diff --git a/science/py-gpaw/Makefile b/science/py-gpaw/Makefile
index 1e61583a6bb9..35e12484c1a1 100644
--- a/science/py-gpaw/Makefile
+++ b/science/py-gpaw/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ase>0:science/py-ase@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}matplotlib>0:math/py-matplotlib@${PY_FLAVOR} \
${PYNUMPY}
-USES= gettext-runtime localbase python:3.5+ shebangfix
+USES= gettext-runtime localbase python:3.7+ shebangfix
USE_PYTHON= distutils concurrent autoplist
SHEBANG_FILES= tools/*
diff --git a/science/py-obspy/Makefile b/science/py-obspy/Makefile
index 1e2b24e6360b..6b77bdbc952f 100644
--- a/science/py-obspy/Makefile
+++ b/science/py-obspy/Makefile
@@ -21,7 +21,7 @@ BUILD_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}sqlalchemy10>=0:databases/py-sqlalchemy10@${PY_FLAVOR}
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= fortran python:3.6+ shebangfix zip
+USES= fortran python:3.7+ shebangfix zip
SHEBANG_FILES= obspy/taup/tests/data/TauP_test_data/gendata.sh
USE_LDCONFIG= yes
LDFLAGS+= -shared
diff --git a/science/py-pyteomics/Makefile b/science/py-pyteomics/Makefile
index 187d7c5d0518..b9edb37e43b4 100644
--- a/science/py-pyteomics/Makefile
+++ b/science/py-pyteomics/Makefile
@@ -9,7 +9,7 @@ COMMENT= Python modules for proteomics data analysis
LICENSE= APACHE20
-USES= python:3.6+
+USES= python:3.7+
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
@@ -20,7 +20,7 @@ DF_DESC= DataFrame support
GRAPHICS_DESC= Graphics support
TDA_DESC= Target-decoy approach support
UNIMOD_DESC= Unimod database support
-XML_DESC= XML support
+XML_DESC= XML support
DF_RUN_DEPENDS= ${PY_PANDAS}
GRAPHICS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}matplotlib>=0:math/py-matplotlib@${PY_FLAVOR}
diff --git a/science/py-scikit-optimize/Makefile b/science/py-scikit-optimize/Makefile
index a449ad0784ea..c2382ceea92c 100644
--- a/science/py-scikit-optimize/Makefile
+++ b/science/py-scikit-optimize/Makefile
@@ -18,7 +18,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}joblib>=0.11:devel/py-joblib@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}scikit-learn>=0.20.0:science/py-scikit-learn@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}scipy>=0.19.1:science/py-scipy@${PY_FLAVOR}
-USES= python:3.6+
+USES= python:3.7+
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/science/rdkit/Makefile b/science/rdkit/Makefile
index 48d07c89b420..a98f8046a3d1 100644
--- a/science/rdkit/Makefile
+++ b/science/rdkit/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libfreetype.so:print/freetype2 \
libmaeparser.so:science/maeparser
-USES= bison:build cmake compiler:c++11-lang eigen:3 python:3.6+
+USES= bison:build cmake compiler:c++11-lang eigen:3 python:3.7+
USE_GITHUB= yes
GH_TUPLE= rareylab:RingDecomposerLib:v1.1.3_rdkit:RingDecomposerLib/External/RingFamilies/RingDecomposerLib
USE_LDCONFIG= yes
diff --git a/science/v_sim/Makefile b/science/v_sim/Makefile
index dbc62dbc75a6..ad482c2cdd8e 100644
--- a/science/v_sim/Makefile
+++ b/science/v_sim/Makefile
@@ -33,7 +33,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}matplotlib>0:math/py-matplotlib@${PY_FLAVOR}
USES= autoreconf blaslapack compiler:c11 fortran gl gmake gnome \
- libtool:keepla localbase:ldflags pkgconfig python:3.6+ \
+ libtool:keepla localbase:ldflags pkgconfig python:3.7+ \
shebangfix tar:bzip2 xorg
SHEBANG_GLOB= *.py
USE_XORG= x11
diff --git a/science/wwplot/Makefile b/science/wwplot/Makefile
index 12f3d5937555..4b6d0e8ec6c1 100644
--- a/science/wwplot/Makefile
+++ b/science/wwplot/Makefile
@@ -19,7 +19,7 @@ PY_DEPENDS= ${PYTHON_PKGNAMEPREFIX}matplotlib>0:math/py-matplotlib@${PY_FLAVOR}
${PYTHON_PKGNAMEPREFIX}pyside2>0:devel/pyside2@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR}
-USES= gettext meson python:3.6+ shebangfix
+USES= gettext meson python:3.7+ shebangfix
SHEBANG_FILES= wwplot.in
USE_GITHUB= yes
GH_ACCOUNT= wwmm