aboutsummaryrefslogtreecommitdiff
path: root/security/clamav/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/clamav/Makefile')
-rw-r--r--security/clamav/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index b9a4288f3a11..8846d2fcabf7 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= clamav
-PORTVERSION= 0.100.2
+PORTVERSION= 0.101.1
PORTEPOCH= 1
CATEGORIES= security
MASTER_SITES= http://www.clamav.net/downloads/production/
@@ -152,8 +152,13 @@ post-patch:
${WRKSRC}/etc/clamd.conf.sample \
${WRKSRC}/etc/freshclam.conf.sample \
${WRKSRC}/etc/clamav-milter.conf.sample
- @${REINPLACE_CMD} -e 's|0x100000000|0x100000000ULL|g' \
- ${WRKSRC}/libclamunrar/unrar.c
+.if exists(/usr/lib/libstdc++.so)
+ @${REINPLACE_CMD} -e 's|-Wno-logical-op-parentheses||' \
+ -e 's|-Wno-dangling-else||' \
+ ${WRKSRC}/libclamav/Makefile.am \
+ ${WRKSRC}/libclamav/Makefile.in \
+ ${WRKSRC}/libclamunrar/makefile
+.endif
pre-configure-TESTS-on:
@if ! ${PYTHON_CMD} -c "import thread" >/dev/null 2>&1; then \
@@ -177,6 +182,6 @@ post-install:
${STAGEDIR}${DBDIR} \
${STAGEDIR}${LOGDIR} \
${STAGEDIR}${RUNDIR}
- ${INSTALL_DATA} ${WRKSRC}/docs/html/* ${STAGEDIR}${DOCSDIR}/html
+ (cd ${WRKSRC}/docs/html; ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}/html)
.include <bsd.port.mk>