aboutsummaryrefslogtreecommitdiff
path: root/security/kf5-kdesu/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/kf5-kdesu/Makefile')
-rw-r--r--security/kf5-kdesu/Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/security/kf5-kdesu/Makefile b/security/kf5-kdesu/Makefile
new file mode 100644
index 000000000000..a6558681b6d7
--- /dev/null
+++ b/security/kf5-kdesu/Makefile
@@ -0,0 +1,16 @@
+# Created by: tcberner
+# $FreeBSD$
+
+PORTNAME= kdesu
+PORTVERSION= ${KDE_FRAMEWORKS_VERSION}
+CATEGORIES= security kde kde-frameworks
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= KF5 integration with su for elevated privileges
+
+USES= cmake:outsource compiler:c++11-lib gettext kde:5 tar:xz
+USE_KDE= config coreaddons dbusaddons ecm i18n pty service
+USE_QT5= buildtools_build core dbus qmake_build xml
+USE_XORG= ice sm x11 xext
+
+.include <bsd.port.mk>