aboutsummaryrefslogtreecommitdiff
path: root/security/krb5-119/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/krb5-119/Makefile')
-rw-r--r--security/krb5-119/Makefile12
1 files changed, 2 insertions, 10 deletions
diff --git a/security/krb5-119/Makefile b/security/krb5-119/Makefile
index 183d32b7208a..9d7d1a1a7430 100644
--- a/security/krb5-119/Makefile
+++ b/security/krb5-119/Makefile
@@ -41,7 +41,7 @@ CPE_PRODUCT= kerberos
OPTIONS_DEFINE= EXAMPLES NLS KRB5_PDF KRB5_HTML DNS_FOR_REALM LDAP LMDB
OPTIONS_DEFAULT= KRB5_PDF KRB5_HTML READLINE
OPTIONS_RADIO= CMD_LINE_EDITING
-OPTIONS_RADIO_CMD_LINE_EDITING= READLINE READLINE_PORT LIBEDIT
+OPTIONS_RADIO_CMD_LINE_EDITING= READLINE LIBEDIT
CMD_LINE_EDITING_DESC= Command line editing for kadmin and ktutil
KRB5_PDF_DESC= Install krb5 PDF documentation
KRB5_HTML_DESC= Install krb5 HTML documentation
@@ -56,8 +56,7 @@ LMDB_LIB_DEPENDS= liblmdb.so:databases/lmdb
LMDB_IMPLIES= LDAP
NLS_USES= gettext
READLINE_USES= readline
-READLINE_PORT_DESC= Command line editing via devel/readline
-READLINE_PORT_USES= readline:port
+READLINE_CONFIGURE_WITH=readline
LIBEDIT_USES= libedit
LIBEDIT_CONFIGURE_WITH= libedit
@@ -91,13 +90,6 @@ LDFLAGS:= -Wl,-rpath,${_RPATH}${F:S/-Wl,-rpath,//} \
BROKEN= LIB_DEPENDS when using KRB5_HOME is broken
.endif
-# OPTIONS helper causes conflicting with/without
-.if ${PORT_OPTIONS:MREADLINE} || ${PORT_OPTIONS:MREADLINE_PORT}
-CONFIGURE_ARGS+= --with-readline
-.else
-CONFIGURE_ARGS+= --without-readline
-.endif
-
.if defined(PROGRAM_TRANSFORM_NAME) && ${PROGRAM_TRANSFORM_NAME} != ""
CONFIGURE_ARGS+= --program-transform-name="${PROGRAM_TRANSFORM_NAME}"
.endif