aboutsummaryrefslogtreecommitdiff
path: root/security/libmatekeyring/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/libmatekeyring/Makefile')
-rw-r--r--security/libmatekeyring/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/security/libmatekeyring/Makefile b/security/libmatekeyring/Makefile
new file mode 100644
index 000000000000..342241e78586
--- /dev/null
+++ b/security/libmatekeyring/Makefile
@@ -0,0 +1,32 @@
+# Created by: Michael Johnson <ahze@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libmatekeyring
+PORTVERSION= 1.6.0
+CATEGORIES= security mate
+MASTER_SITES= MATE
+DIST_SUBDIR= mate
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Program that keeps passwords and other secrets
+
+BUILD_DEPENDS= gtkdoc-check:${PORTSDIR}/textproc/gtk-doc
+LIB_DEPENDS= libgcrypt.so:${PORTSDIR}/security/libgcrypt \
+ libdbus-1.so:${PORTSDIR}/devel/dbus
+
+PORTSCOUT= limitw:1,even
+
+USES= gettext gmake pathfix pkgconfig
+USE_XZ= yes
+USE_MATE= autogen common:build intlhack ltverhack
+USE_GNOME= glib20
+USE_LDCONFIG= yes
+USE_AUTOTOOLS= aclocal:env autoconf:env automake:env libtool libtoolize:env
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-gtk-doc \
+ --with-html-dir=${PREFIX}/share/doc
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+PATHFIX_MAKEFILEIN= Makefile.*
+
+.include <bsd.port.mk>