aboutsummaryrefslogtreecommitdiff
path: root/security/logcheck
diff options
context:
space:
mode:
Diffstat (limited to 'security/logcheck')
-rw-r--r--security/logcheck/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/security/logcheck/Makefile b/security/logcheck/Makefile
index 2a6409b82c31..801935cc7479 100644
--- a/security/logcheck/Makefile
+++ b/security/logcheck/Makefile
@@ -13,14 +13,15 @@ DISTNAME= logsentry-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
+USE_REINPLACE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PKGMESSAGE= ${WRKDIR}/MESSAGE
pre-configure:
- ${PERL} -pi -e "s@/usr/local/etc/tmp@${PREFIX}/var/tmp@g; \
+ ${REINPLACE_CMD} -e "s@/usr/local/etc/tmp@${PREFIX}/var/tmp@g; \
s@/usr/local@${PREFIX}@" ${WRKSRC}/Makefile \
${WRKSRC}/systems/freebsd/logcheck.sh
- ${PERL} -pi -e "s@/bin/mkdir@${MKDIR}@g" ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e "s@/bin/mkdir@${MKDIR}@g" ${WRKSRC}/Makefile
post-build:
@${SED} -e 's,%%PREFIX%%,${PREFIX},g' ${PKGDIR}/pkg-message > ${PKGMESSAGE}