aboutsummaryrefslogtreecommitdiff
path: root/security/logcheck
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-06-23 20:39:23 +0000
committerPatrick Li <pat@FreeBSD.org>2002-06-23 20:39:23 +0000
commit3429beb3d69bf05cc09137cac5b420f8e26b86db (patch)
tree4affc92982e244cfbe7e05e3bdd22240b4c28520 /security/logcheck
parentec8028156e7ada0e0867358c46bf5af20c16fec3 (diff)
downloadports-3429beb3d69bf05cc09137cac5b420f8e26b86db.tar.gz
ports-3429beb3d69bf05cc09137cac5b420f8e26b86db.zip
PERL -> REINPLACE_CMD
PR: ports/39729, ports/39727, ports/39726, ports/39724 PR: ports/39722, ports/39721, ports/39720, ports/39719, ports/39718 Submitted by: Scott Flatman <sf@dsinw.com>
Notes
Notes: svn path=/head/; revision=61839
Diffstat (limited to 'security/logcheck')
-rw-r--r--security/logcheck/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/security/logcheck/Makefile b/security/logcheck/Makefile
index 2a6409b82c31..801935cc7479 100644
--- a/security/logcheck/Makefile
+++ b/security/logcheck/Makefile
@@ -13,14 +13,15 @@ DISTNAME= logsentry-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
+USE_REINPLACE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PKGMESSAGE= ${WRKDIR}/MESSAGE
pre-configure:
- ${PERL} -pi -e "s@/usr/local/etc/tmp@${PREFIX}/var/tmp@g; \
+ ${REINPLACE_CMD} -e "s@/usr/local/etc/tmp@${PREFIX}/var/tmp@g; \
s@/usr/local@${PREFIX}@" ${WRKSRC}/Makefile \
${WRKSRC}/systems/freebsd/logcheck.sh
- ${PERL} -pi -e "s@/bin/mkdir@${MKDIR}@g" ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e "s@/bin/mkdir@${MKDIR}@g" ${WRKSRC}/Makefile
post-build:
@${SED} -e 's,%%PREFIX%%,${PREFIX},g' ${PKGDIR}/pkg-message > ${PKGMESSAGE}