aboutsummaryrefslogtreecommitdiff
path: root/security/openssh-portable/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/openssh-portable/Makefile')
-rw-r--r--security/openssh-portable/Makefile8
1 files changed, 1 insertions, 7 deletions
diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index 351a41d6e976..70d027db63a2 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -41,7 +41,7 @@ gssapi_PKGNAMESUFFIX= -portable-gssapi
OPTIONS_DEFINE= DOCS PAM TCP_WRAPPERS LIBEDIT BSM \
HPN KERB_GSSAPI \
- LDNS NONECIPHER XMSS FIDO_U2F BLACKLISTD BADUSER
+ LDNS NONECIPHER XMSS FIDO_U2F BLACKLISTD
OPTIONS_DEFAULT= LIBEDIT PAM TCP_WRAPPERS LDNS FIDO_U2F
.if ${FLAVOR:U} == hpn
OPTIONS_DEFAULT+= HPN NONECIPHER
@@ -63,7 +63,6 @@ NONECIPHER_DESC= NONE Cipher support
XMSS_DESC= XMSS key support (experimental)
FIDO_U2F_DESC= FIDO/U2F support (security/libfido2)
BLACKLISTD_DESC= FreeBSD blacklistd(8) support
-BADUSER_DESC= Treat "Invalid user" as blacklistd AUTH_FAIL
OPTIONS_SUB= yes
@@ -93,7 +92,6 @@ FIDO_U2F_CONFIGURE_ON= --with-security-key-builtin
FIDO_U2F_CONFIGURE_OFF= --disable-security-key
BLACKLISTD_EXTRA_PATCHES= ${FILESDIR}/extra-patch-blacklistd
-BADUSER_IMPLIES= BLACKLISTD
ETCDIR?= ${PREFIX}/etc/ssh
@@ -211,10 +209,6 @@ post-patch:
@${ECHO_CMD} '#define SSH_VERSION_FREEBSD_PORT "${VERSION_ADDENDUM_DEFAULT}"' >> \
${WRKSRC}/version.h
-post-patch-BADUSER-on:
- @${REINPLACE_CMD} \
- -e 's|BLACKLIST_BAD_USER|BLACKLIST_AUTH_FAIL|' ${WRKSRC}/auth.c
-
post-configure-XMSS-on:
@${ECHO_CMD} "#define WITH_XMSS 1" >> ${WRKSRC}/config.h