aboutsummaryrefslogtreecommitdiff
path: root/security/pks
diff options
context:
space:
mode:
Diffstat (limited to 'security/pks')
-rw-r--r--security/pks/Makefile13
-rw-r--r--security/pks/files/patch-configure.in4
-rw-r--r--security/pks/files/patch-kd_generic.c26
-rw-r--r--security/pks/files/patch-kd_search.c13
-rw-r--r--security/pks/files/patch-mkpksdconf.in4
-rw-r--r--security/pks/pkg-descr2
-rw-r--r--security/pks/pkg-plist4
7 files changed, 54 insertions, 12 deletions
diff --git a/security/pks/Makefile b/security/pks/Makefile
index 1feb28707c96..6e712e1c3a2f 100644
--- a/security/pks/Makefile
+++ b/security/pks/Makefile
@@ -3,6 +3,7 @@
PORTNAME= pks
PORTVERSION= 0.9.6.20040312
+1P1O1R1T1R1E1V1I1S1I1O1N1=1 1 121
CATEGORIES= security www
MASTER_SITES= http://pks.sourceforge.net/:sf ${MASTER_SITE_LOCAL}:local
MASTER_SITE_SUBDIR= .:sf mandree:local
@@ -11,17 +12,16 @@ DISTFILES= pks-current.tgz:sf,local
MAINTAINER= tphilipp@potion-studios.com
COMMENT= PGP Public Key Server
-LICENSE= BSD4CLAUSE
+LICENSE= BSD4CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_GCC= any
-USE_BDB= yes
-WANT_BDB_VER= 41 # pks dumps core with 42 and doesn't build with 43+
+USE_BDB= 48+
-OPTIONS_DEFINE= DOCS
-PORTDOCS= pks_help.* README EMAIL
+OPTIONS_DEFINE= DOCS
+PORTDOCS= pks_help.* README EMAIL
GNU_CONFIGURE= yes
USE_AUTOTOOLS= autoconf
CONFIGURE_ARGS= --datadir=${PREFIX}/share/pks --localstatedir=/var/pks \
@@ -31,10 +31,11 @@ MAKE_ENV+= SUBDIRS=
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV= DBLIB="-L${BDB_LIB_DIR} -l${BDB_LIB_NAME}" DBINC=-I${BDB_INCLUDE_DIR} DBHDR=db.h
-
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
+PLIST_SUB+= RESETPREFIX=${PREFIX}
+
USE_RC_SUBR= pksd
.include <bsd.port.options.mk>
diff --git a/security/pks/files/patch-configure.in b/security/pks/files/patch-configure.in
index 466af4727cc4..39a93721326d 100644
--- a/security/pks/files/patch-configure.in
+++ b/security/pks/files/patch-configure.in
@@ -1,5 +1,5 @@
---- ./configure.in.orig 2011-03-21 20:49:39.000000000 +0100
-+++ ./configure.in 2011-03-21 20:50:42.000000000 +0100
+--- ./configure.in.orig 2004-01-18 00:19:56.000000000 +0100
++++ ./configure.in 2014-08-15 18:32:37.000000000 +0200
@@ -74,126 +74,6 @@
# Checks for libraries.
dnl Checks for Berkeley DB
diff --git a/security/pks/files/patch-kd_generic.c b/security/pks/files/patch-kd_generic.c
new file mode 100644
index 000000000000..fe385b4af2c9
--- /dev/null
+++ b/security/pks/files/patch-kd_generic.c
@@ -0,0 +1,26 @@
+--- ./kd_generic.c.orig 2003-08-04 21:57:27.000000000 +0200
++++ ./kd_generic.c 2014-08-15 18:41:14.000000000 +0200
+@@ -325,13 +325,13 @@
+ /* create/open/close/sync */
+
+ static int
+-kd_worddata_compare (DB * db, const DBT * a, const DBT * b)
++kd_worddata_compare (DB * db, const DBT * a, const DBT * b, size_t *locp)
+ {
+ return (memcmp (b->data, a->data, 12));
+ }
+
+ static void
+-kd_errcall (const char *db_errpfx, char *buffer)
++kd_errcall (const DB_ENV *dbenv, const char *db_errpfx, const char *buffer)
+ {
+ log_error (db_errpfx ? db_errpfx : "db_errcall", buffer);
+ }
+@@ -396,7 +396,6 @@
+ if (oflags & KD_OPEN_RECOVER)
+ {
+ appflags |= DB_INIT_LOG | DB_RECOVER | DB_CREATE;
+- dbenv->set_verbose (dbenv, DB_VERB_CHKPOINT, 1);
+ dbenv->set_verbose (dbenv, DB_VERB_WAITSFOR, 1);
+ dbenv->set_verbose (dbenv, DB_VERB_DEADLOCK, 1);
+ dbenv->set_verbose (dbenv, DB_VERB_RECOVERY, 1);
diff --git a/security/pks/files/patch-kd_search.c b/security/pks/files/patch-kd_search.c
new file mode 100644
index 000000000000..e5e70ad79352
--- /dev/null
+++ b/security/pks/files/patch-kd_search.c
@@ -0,0 +1,13 @@
+--- ./kd_search.c.orig 2003-08-04 21:57:34.000000000 +0200
++++ ./kd_search.c 2014-08-15 18:37:29.000000000 +0200
+@@ -1058,8 +1058,8 @@
+ if (we->len > sizeof (word))
+ {
+ s->err->fatal = 0;
+- sprintf (s->err->buf, "search word is greater than %d characters",
+- sizeof (word));
++ sprintf (s->err->buf, "search word is greater than %lu characters",
++ (unsigned long)sizeof (word));
+ return (0);
+ }
+
diff --git a/security/pks/files/patch-mkpksdconf.in b/security/pks/files/patch-mkpksdconf.in
index b48a3d74e9e5..bab902712ba5 100644
--- a/security/pks/files/patch-mkpksdconf.in
+++ b/security/pks/files/patch-mkpksdconf.in
@@ -1,5 +1,5 @@
---- ./mkpksdconf.in.orig 2014-01-22 15:36:39.574285045 -0500
-+++ ./mkpksdconf.in 2014-01-22 15:37:49.289280305 -0500
+--- ./mkpksdconf.in.orig 2003-02-28 18:27:20.000000000 +0100
++++ ./mkpksdconf.in 2014-08-15 18:32:37.000000000 +0200
@@ -44,7 +44,7 @@
cat << EOF
diff --git a/security/pks/pkg-descr b/security/pks/pkg-descr
index c5fc42c8e2d6..688a67eb4482 100644
--- a/security/pks/pkg-descr
+++ b/security/pks/pkg-descr
@@ -1,4 +1,4 @@
This program implements a standard PGP Key Server, which can be assumed
to be in addition to the public key server at MIT.
-WWW: http://www.mit.edu/people/marc/pks/
+WWW: http://www.mit.edu/people/marc/pks/
diff --git a/security/pks/pkg-plist b/security/pks/pkg-plist
index 699bccfbf3b7..50f21383b4e2 100644
--- a/security/pks/pkg-plist
+++ b/security/pks/pkg-plist
@@ -17,7 +17,9 @@ man/man8/pks-queue-run.sh.8.gz
man/man8/pksclient.8.gz
man/man8/pksd.8.gz
man/man8/pksdctl.8.gz
-/var/pks/index.html
+@cwd /
+var/pks/index.html
+@cwd %%RESETPREFIX%%
@unexec rmdir "/var/pks/db" >/dev/null 2>&1 || :
@unexec rmdir "/var/pks/incoming" >/dev/null 2>&1 || :
@unexec rmdir "/var/pks" >/dev/null 2>&1 || :